Question about 2000 Mitsubishi Eclipse

1 Answer

Just changed the fuel pump . When car runs for about two hours then turn off will not start back up its starts then cuts off like its not getting any fuel?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Guru:

    An expert who has written 7 tips or uploaded 3 video tips

  • Expert
  • 63 Answers

Check the release valve to see its getting fuel and check the coil

Posted on Apr 30, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2000 beetle car cranks bit doesn't start after sitting for awhile. Give it a few shots of starting fluid and it fires right up and runs fine. Once it's been running and gets warm i can turn it off...


Next time it won't start after two hours, push your gas pedal all the way to the floor and see if it starts. If it starts, it could be a fuel injector or fuel pressure regulator issue.

Feb 06, 2015 | 2000 Volkswagen Beetle

1 Answer

1994 continental runs than cuts off and takes awhile to start back up?


might be the Fuel Pump Relay. They get intermittent like this. If it was never changed, I'd start there

Oct 05, 2012 | Lincoln Continental Cars & Trucks

1 Answer

91 acclaim v6. starts and runs good, but once its been running for awhile (hour or so), and i turn it off, it doesnt want to start back up, or does and dies. wait 2 hours and it starts right up. recently...


Sounds like either you have a clogged fuel line and or clogged fuel filter or the fuel pump is failing. What happens when the vehicle runs the fuel pump heats up, as it heats up it produces less and less fuel for your car. Eventually ti stops working until its cool again on faulty pumps. Given the age of your vehicle I would say you need to replace both pump and filter.

Sep 19, 2010 | 1991 Plymouth Acclaim

1 Answer

Starting problems


In the past, waiting for the fuel lines to pressurize was the only way to start fuel injected cars. Newer cars are designed to keep the line pressurized after you turn it off, and there is no need to pressurize upon restarting. Seem like your vehicle is losing the pressure gradually after shutting it off. Gasoline pressure can only be lost 2 ways: 1) A broken line, with fuel dripping to the floor, which, obviously you can see and smell, or gas going back into the tank due to a faulty pump or pump installation.

Jun 21, 2010 | 1993 Ford Thunderbird

1 Answer

Have to use starting fluid to get started once it is running i can cut it off and back one when it sets for a couple hours it wont start put new plugs and wires on still doing it but not as bad


possibly the fuel pressure regulator,or fuel pump sending unit. I had 2000 olds similar symptoms.sending unit pump resolved issue.good luck!

Mar 23, 2010 | 1999 Oldsmobile Bravada

1 Answer

95 f150 will turn over but not start. If it sits


Sounds like fuel pump or fuel pump relay but most likely pump. If the pump get too hot after running, the pump will not build up enough pressure to start but after sitting, it will cool off enough to build up the proper fuel pressure.

Another thing to check is the ignition module for the distributer. They are known to heat soak also however you typiocally get a cut out or miss feel when those have issues.

Sep 13, 2009 | 1995 Ford F150 Styleside Regular Cab

1 Answer

1994, 6.5 LTR DIESEL SIERRA. RUNS FOR ABOUT 1 MIN THEN CUTS OUT


Check that the fuel tank breather pipe is clean and not blocked.

Sep 01, 2009 | 1997 GMC Sierra

2 Answers

Car starts but turns off after a 10 min or so.


This definitely sounds like a fuel pump/filter issue. Good news if it's the filter, it's only about 10 dollars to buy a new one and about 5 minutes labor, including jacking up your car.

Fuel pumps cant be a pain in the arse at times, others are fairly easy. Best way to determine if it's the fuel pump, run over to Canadian tire and pick up an ohms meter. Test the fuel pump that way.

Jan 10, 2009 | 1992 Buick Park Avenue

1 Answer

Fuel Pump issue with 95 WRX STi


On both cars, check the fuel pump/guage harness connector under rear seat - the old fuel pump draws too much current and melts the connector causing poor conatct & voltage drop off. Easy to see usually, just cut the two fuel pump wires from either side of the connector and re-join with new crimp connectors, or solder joint.

Oct 07, 2008 | 2007 Subaru Impreza WRX STI Limited Sedan

Not finding what you are looking for?
2000 Mitsubishi Eclipse Logo

49 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8557 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...