Question about Oldsmobile Silhouette

1 Answer

I have a 99 oldsmobile silhouette van - we have changed the plugs, o2 sensor, had the njectors cleaned, and the car runs bad.... if you press on the gas the RPM go down - it is like it is smothering.. Went to the auto store and they say they are receiving readings of Cam Shaft, oxy sensor 1 and 2 air in fuel line, dist cap rotor bad (not on brakes) When you give it gas it it like it smothers the engine....

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 27 Answers

Look under your distributor cap. It should be clean have good metal contacts. Also look at the rotor button right under that. It should have a nice shiny metal contact. This spins under your distributor and fires your spark plugs. Wipe it with your finger or a rag and drive. If that was it...replace the cap and rotor.

Posted on Apr 30, 2010

  • power_stroke Nov 21, 2010

    I hate to say this....... But your silhouette has 3 coil packs not a distributor cap and button .... each coil pack controls two plugs... ive replaced mine on a 99 silhouette there $35 each @ napa and $42 each @ advance auto......................

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Can not find the idle screw so I can adjust the idle , because my van's idle is to slow.


Idle speed on fuel injected engines is controlled by the idle air motor. Yours may be dirty, EGR dirty, vacuum leaks, MAF dirty, tune up issues. DON'T turn the screw which controls the throttle blade closed position, but do check that the blade is clean and not sticking open, as this prevents the IAC from doing its job. Bad coolant temp sensor or O2 sensor can affect idle quality also.

Aug 01, 2015 | 1999 Oldsmobile Silhouette

1 Answer

99 olds silhouette... changed plugs wires and coil packs and crank position sensor .... but the odd part is ... timing off ... with timing light when u crank over engine is outta time but the more you...


will try to help,are you sure the fuel pump comes on and runs through the whole cycle of turning key on for 10 seconds through at least 5 cycles? the timing light may be picking up the crankshaft positioning sensor signal, it's magnetic pulse. and then again you could be dealing with a bad timing chain or belt,most likely chain driven. am trying to help, but not sure unless i hear it onsite. at least this may point you to something. sorry at no charge, hope this helps and thank you for choosing fixya.com if no help please repost!!!1

Nov 21, 2010 | 1999 Oldsmobile Silhouette

1 Answer

Need help locating O2 Sensor One Bank One in my 2002 Olds Silhouette Van.


It should be the sensor on the rear exaust manifold , kinda tricky to get at but not impossible.

Jul 22, 2010 | 2002 Oldsmobile Silhouette

1 Answer

99 silhouette


Would try removing the MAF and cleaning it.They make MAF cleaner in a can.If that doesn't work you may need to relace it.I would not run without it.The computer needs to know the amount of air that is flowing to regulate the fuel mixture.

Mar 09, 2010 | 1999 Oldsmobile Silhouette

1 Answer

Why is all the fluid staying in reserve tank-none


The line to the reserve tank to the radiator could be plugged up or you have a loose radiator cap or a bad seal causing the tank to hold whats in it. The coolant system is a pressurized system and if a seal is bad or a line is plugged you will experience this problem for the pressure is not there to take whats needed from the tank to deploy in the coolant system

Jan 26, 2010 | 1999 Oldsmobile Silhouette

2 Answers

My van shuts off under braking


Sounds like the torque converter is not unlocking.Have you had it scanned for codes?

Dec 31, 2009 | 2001 Oldsmobile Silhouette

2 Answers

When the car is back firing, which oxegen sensor is bad


I have never seen an o2 sensor cause a car to backfire. sounds more like a timing issue rather then o2 sensors. why do you think there is a bad sensor? does it have any engine codes?

Jun 12, 2009 | 1999 Oldsmobile Silhouette

3 Answers

My 1995 Oldsmobile Silhouette van shuts off while driving


I had a the same problem with my 95' Silhouette it got worse and then would not restart until it cooled off. the problem is most likely the crankshaft position sensor this is what resolved my issue.

Mar 28, 2009 | 1995 Oldsmobile Silhouette

1 Answer

O2 Sensor???


this sounds like a vacum leak o2 sensor does not cause this problem look for a broke or disconeted hose some times its helpfull so spray water aruund the hoses and it will change the way the engin runs if you find one

Oct 12, 2008 | 2000 Oldsmobile Silhouette

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

146 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8557 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...