Question about 2003 GMC Yukon Denali

1 Answer

I have a 2003 yukon denali and my oil pressure gauge went to Zero. Does tis mean I have to replace the oil pump? the car does turn on.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,317 Answers

You might want to use a oil pressure test gauge and verify the actual oil pressure. You would connect it to where the sending unit screws into the engine. It's on the driver side back of the motor, under the distributor area. by the fuel lines.

Posted on Apr 30, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 yukon denali oil pressure switch pegged over the 80 psi indicator. Oil qty is good.


Sounds like a bad oil pressure sending unit.

Try unplugging it and see if the gauge drops to zero. If it does than replacing the oil pressure sending unit will most likely fix your problem.

It is not easy to see or get at but you can find it on the back side of the engine on the drivers side, kind of in between the valve cover and the intake plenum

Apr 08, 2013 | 2003 GMC Yukon Denali

1 Answer

No oil pressure on my 2009 Yukon


You need to be careful here. If you are driving your Vehicle with ZERO PRESSURE, you are going to blow up your engine.

There is also one of 2 other scenero's for a GM Vehicle

FIRST: Instrument Cluster STEPPER MOTORS are KNOWN to be going BAD in GM's/. If the Stepper Motor is bad, make sure you replace it with a X27.168

SECOND. Your Sending Unit could have come unplugged or the Unit itself went bad.

I am Betting that your Stepper Motor went bad (Happens that Frequently).

I would put a Gauge on the Motor and see what the Oil Pressure Actually is, if it is Truly ZERO... do not start or Drive the vehicle and take it to a Good Mechanic or if still under warranty.. To the DEALER

Apr 08, 2013 | 2009 GMC Yukon XL

1 Answer

Oil pressure gauge goes to 80 and stays


Another gauge needs to be connected to the car to check that oil pressure sensor or the gauge itself is not the problem.

If an independent gauge shows the same readings I would suspect a sticking oil pressure relief valve.

Dec 28, 2012 | 2003 GMC Yukon Denali

2 Answers

Why is my oil pressure gauge on my 2003 hummer h2 always read 80 when the vehicle is running, back to zero when shut off?


because when the engine is shut off, the oil pump is also shut off, therefore no oil pressure. no problem here!

Mar 24, 2010 | 2003 Hummer H2

1 Answer

Oil gauge on 2003 yukon denali vortec 6000 engine is either all the way to 80 or to 0. can it be the sending unit and where is it located?


on these it is above the oil filter housing underneath. the best way to tell is to have a "wet guage" installed to test what the actuall pressure is. if the oil pressure is to spec then the problem more then likely is the motor in the speedomemeter unit itself. they do have a problem with these little motors. all the guages use the same style motors. cheers

Jan 14, 2010 | 2003 GMC Yukon Denali

1 Answer

The dashboard on my 2003 Yukon Denali won`t light up, the warning lights, the gauges and indicators...nothing is working. The CD player and cigarette lighters all work.


I had this problem on my '03 Yukon. There is an IC or other component on the dash/gauge panel that went bad, but I pulled the gauge cluster and sent it to mrwhizard.com. They replaced some parts, and i paid to have the stepper motors replaced as well, since they would prob go in the very near future. I want to say it cost me about $150-$180 total, including s/h, and had it back in a week or so. It retained my original odometer reading as well, which I was very curious/cautious of.....
Good luck.

Jan 06, 2010 | 2003 GMC Yukon Denali

1 Answer

The oil pump does not have compression how do i check it for its compression? 2002 yukon denali


do you mean pressure? they sell a kit to check pressure. if your engine is not ticking then it is probably a bad sender.

Nov 12, 2009 | 2002 GMC Yukon Denali

1 Answer

My 03 Denali makes a loud whinning noise when I accelerate mechanic says needs to replace brake hydroboost


It could be any thing from the alternator to the Power steering pump. The power steering pump feeds the hydro boost unit. It is unlikely the hydroboost is causing the noise. I recomend you take it to the dealer and have them perform the proper diagnostics as they will have the proper pressure gauges and equipment needed to perform the tests.

I hope this helps.

Roy

Nov 06, 2009 | 2003 GMC Yukon Denali

2 Answers

2006 Yukon Denali, oil pressure gauge malfunction


Most likely the oil pressure sensor is bad. Its located in the very rear of engine on top of bell housing area.

Oct 30, 2009 | 2006 GMC Yukon Denali

Not finding what you are looking for?
2003 GMC Yukon Denali Logo

854 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...