Question about 1994 Chevrolet S-10 Blazer

1 Answer

I have a 92 tahoe 4x4 I,ve changed the plugs this made it run better but 15 mins later it stalled and now it wont start but it sputters a bit. Ive got fresh fuel in it have you got any ideas?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 267 Answers

Any check engine lights? How about some more info like mileage and any other things done recently. Have you checked to see if the fuel pump is working? Get starting fluid from auto parts store and have someone spray into sir supply while trying to start engine. If it fires then suspect fuel pump. If this helps please reply as this helps me continue to answer questions here and good luck

Posted on Apr 29, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1998 f250 5.4l would not start. changed feul pump and filter still would not start. 20 mni later started. was cleaning engine while running 10 15 min later died wont start.


Check fuel pressure at the injector rail. Could be your fuel pump relay is cutting out. If fuel pressure is good, check for sparks at the plug wires. Read the link below for more info.
Do It Yourself Diagnosis and Repair

Jul 26, 2017 | Cars & Trucks

1 Answer

98 honda runs fine then turns off while running on freeway then will crank but not start for about 30 mins changed ignition switch plugs an wires help plz


it may take some talking back and forth but i can help you fix this. does it seem like the engine stalls once its good and warmed up and wont start till its cooled down a bit? this is very common and its ussually caused by the coolant temp sender (not the one for the dash the one that runs you fuel and emissions) more or less it goes out and you car doesnt know its warmed up so it floods the motor out after a few miles because more or less the choke is stuck "on" . once the motor cools down it will typically start right back and and then repeat the symptom. ive seen other issues cause this but the coolant temp sender is very common and also a cheap fix ( just did one on a buick and the part cost 14 bucks and it took me about 15 minutes to replace). is the check engine or service engine soon light on or does it come on then go off?

Feb 18, 2012 | Chevrolet Camaro Cars & Trucks

1 Answer

I have a 2000 pontiac Bonneville sle and it was running fine it stalled yesterday on me n after a bit started back up and ran fine the rest of the night, This morning It started fine and then 15 mins...


I had the same problem with my 2000 Bonneville SLE and I replaced the crank shaft sensor and it solved the problem. The crank shaft sensor is located behind the harmonic balancer. You have to take the balancer off to get to the part. You will need a puller to get it off. You will also have to take the fly wheel cover off and hold the fly wheel when you remove the nut from the front of balancer.

Jun 14, 2011 | 2000 Pontiac Bonneville

1 Answer

Every time i put a new muffler on my 1997 jeep grand cherokee the motor bakfires and blows the muffler compleatly apart it dosent do it right away it runs fine for a few miles then boom then it starts to...


What a funny set of events.Of course the tail pipe is clear(you would have checked that)The only other thing it might be is the cat/converter is blocked.New muffler is allowing a heap of air through and it suddenly clears and the bang.They do block up so it may be worth getting it checked.Hope this helps

Oct 31, 2010 | 1997 Jeep Grand Cherokee

1 Answer

2002 Chevy Tahoe sputters and stalls out while driving.....


Fuel filter. Timing/timing chain. Idle air control valve. Idle sensor. Vacuum leak. Probably one of the above, but the filter is cheapest place to start. Change your air filter too, if you haven't for a while.

Sep 12, 2009 | 2002 Chevrolet Tahoe

1 Answer

92 max Sputtering and stalling out??


sounds like your crank triger after it cools then does it fire up fine then when it warms up it dies if so it would be your crank triger

Aug 09, 2009 | 1992 Nissan Maxima

2 Answers

My 1992 Nissan Maxima is sputtering upon acceleration. It has 220,000 miles on it and it seems to mainly have this problem in first gear. And mostly happens shortly after starting the car. Ive done a basic...


92 max
I own a 92 max 370 kms runs good but one day just cuts out while doing about 30 km, I pull over i can start it no problem but when I touch the pedal to accelerate the car stalls out.

It got worse to the point of sputtering on the highway , sometimes i could keep it alive by working the pedal but others would slow down and stall out.

I have changed the fuel filter and plugs seemed to make it a bit better but still stalling. I ran it in my driveway for 10 mins on idle then it stalls out

Is this the fuel pump??

Jun 13, 2009 | 1992 Nissan Maxima

2 Answers

2000 2.0 vw shutt down after running 20 min


Replace the fuel pump relay, it's easy and cheap.

Jun 08, 2009 | 2000 Volkswagen Jetta TDI

1 Answer

Missing and not starting when gets warm and run for a bit


ok.. for starters you need to check why you are loosing revs.. it could be your powersteering switch on your steering rack not working.. just bridge switch to test.. revs should not drop on steering.. then check fuel pump relay.. and efi relay.. theese cars are gettin on.. so could be faulty with long use..heat related.. insert a visual inline fuel filter and when it stalls check fuel flow... aswell as put a little fuel in the vacum hose line and see if it starts to confirm its a fuel issue... if the visualis fuel flow than its fuel pump related.. wires can come loose of pump .. as they travell under rear seat.. and into tank.. ... good luck

Nov 06, 2008 | 1991 Daihatsu Charade

Not finding what you are looking for?
1994 Chevrolet S-10 Blazer Logo

75 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8123 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...