Question about 1997 Chevrolet K1500

1 Answer

I have 1997 Silverado 5.7 miss on #5 when under load take your foot off wait put your foot backin and it will run fine did all the wires plugs cap rotar same miss more so on uphill what do think is wrong?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 409 Answers

If you have isolated to one cylinder, you need to look at the compression on that cylinder, should be at lease 110psi. Also check the valve springs, a broken spring will allow engine to run smooth unloaded and miss under load. Remove valve cover and push down on valves, if they move at all the spring is bad. You can also do a cylinder leakdown test and it will tell you if you have a valve or rings going bad.

Posted on Apr 26, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

GoingUphill. misses under load runs fine otherwise


Check to make sure the EGR valve is not opening prematurely. It is is the controller could be bad or the valve could be gummed up with carbon. Also check the ignition wires (spark plug wires) to see if they need replacing, they may be "leaking" under a load.

Sep 17, 2012 | 1997 Buick LeSabre

1 Answer

Geo jerking under acceleration


They come with a 3 or 4 cyl engine, but either way it would not take much to make it run rough.
Usually a miss-fire under load is ignition related.
Have you checked or replaced the plugs, cap, rotor, and wires ?
If not I would start with an inspection of that first.

Sep 14, 2012 | 1997 Geo Metro

1 Answer

Why does my 1998 sebring idle fine but sputter badly under load.


Does it use spark plug wires or individual ignition coils for the each plug?. My 98 intrepid uses coils and occasionally I have to change them out cause it would start to miss when normal temperature was achieved. If it uses wires, try replacing them, along with the spark plugs.

Jun 21, 2012 | 1998 Chrysler Sebring

1 Answer

I have a 98 silverado 5.7 runs but skips at idle when in geat whole truck jerks i replace dis.cap, roto button, plugs, wires,fuel filter and tps help me please


I think you should buy repair manual first for your vehicle after that it will be easy for you to solve the problem. Check the link may be you will find something useful here
Chevy Silverado Sierra 1998 2006 Workshop Service repair manual

Nov 28, 2017 | 1998 Chevrolet C1500

1 Answer

2004 Silverado 4.3 V6 Has miss on cylinders 2 and 4. Have done complete tune up Plugs Wires Cap Rotor,Fuel Filter. Still had Miss. Compression on all 6 within 8 lbs of each other. lowest reading 168...


Check engine light on? Any codes? Missed before and after the cap was changed? Or is the cap new so you assume its good. I have had caps bad out of the box.

May 29, 2011 | Chevrolet C1500 Cars & Trucks

1 Answer

Why does a spark plug fire at idle but not on acceleration ?


You may need to check the ignition wires and the distributor cap/rotor.
Older ignition wires will "break down" and the spark will actually short out on nearby metal/engine block etc.
Try this test. With the car running, parking brake set, and foot firmly holding the brakes, put the car in Drive and accelerate. If the engine misses under a load, it's most likely the ignition wires..


Jul 09, 2010 | 1991 Ford F150

2 Answers

2005 Silverado Firing Order


bee97bf.gif


Can you tell us the fault code there?

May 11, 2010 | 2003 Chevrolet Silverado 1500

1 Answer

96 s-10 4.3, the truck idle's fine. Runs under a load fine, but when I hold the throttle steady I get a miss.. It will run like that until it sets code po300.. it has new wire's, plugs,cap rotor.


You can't hold the throttle as steady as the pcm sees it. You may have a miss fire if the Generic 300 Code applies to your veh. You need a professional scanner and better yet oscilloscope on the Throttle Position Sensor under the conditions you were able to create.

Feb 06, 2010 | Chevrolet S 10 Cars & Trucks

2 Answers

I have a 1997 Chevrolet Silverado 350 vortec 5.7 liter.Most of the time while I'm driving it will run ok then starts skipping like it's starving for gas or something.I have changed the fuel pump several...


i have a 1997 silverado isurges about 57&62 mph i have put a tune up on it plugs wires rotor button&cap everything is right but it still surges what can i do next?

Jan 08, 2010 | Chevrolet Silverado Cars & Trucks

1 Answer

1997 Aerostar 4 liter engine has miss on several cylinders. New wires and plugs. Miss is intermintent. Usually worse under load. At times van runs fine.


check for vacume leaks on intake and other vacume hoses. random misfire is also usually a clogged fuel filter or pressure regulator. could also be a cam or knock sensor. are their any trouble codes.

Aug 16, 2009 | 1997 Ford Aerostar Extended

Not finding what you are looking for?
1997 Chevrolet K1500 Logo

187 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

79865 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...