Question about Ford Expedition

1 Answer

I have a 97 ford expedition 4.6L im having some trouble with. It started having some hesitation and sputtering in the acceleration and some backfiring when driving. First code said too rich or too lean in bank one and bank two. So i cleaned the mass air flow sencer. So That fixed that. The next day I got the code PO301 and PO304. The first time it was PO301, so i changed the spark plug in cylinder 1. It stopped the problem for two or three days. Next it was both PO301 and PO304 so changed out the coilpack and the plugs again, it worked for two or three days. Then next time i got it i changed out all the plugs for the original equipment ones and i changed out all of the plug wires. This has worked for the past two months. Now the check engine light flashes and it gives the PO301 and PO304 again. Any ideas anyone.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

This may or may not help.
i have a 98 F150 with a 4.6 that i had an independent garage change the plugs and coil packs after i had the same problems you did. i had to take it back to him several times after and it never ran correctly, out of frustration i called the dealer where i bought the truck and took it to them. this was a small dealer about 200 miles from where i live, but my family is there. no large dealer ****, just leave the truck with us. one week later i got it back with everything fixed and it has run flawlessly since 2005. i was told that the problem was (1) the 1st guy didnt know what he was doing. (2) aftermarket parts didnt work. sounds like a load,but...

Posted on Apr 26, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

89 ford probe hesitates when leaving a red light, then runs fine otherwise, fuel filter?


Engine Runs Rough, Stalls, Hesitates on Acceleration, Hard ...

repairpal.com > Problems > Ford > Probe
Ford Probe Engine Runs Rough, Stalls, Hesitates on Acceleration, Hard Starting, Poor Performance. This is a verified problem based on 9 reports. Learn more ...

Starting Problems - 1997 Ford Probe - RepairPal

repairpal.com > Questions > Ford > Probe > 1997 Ford Probe
Dec 5, 2010 - Starting Problems on 1997 Ford Probe ... If the engine runs rough,stalls, hesitates on acceleration, is hard to start, or has generally poor ...

A new misfire/hesitation on accel. Problem.. - ProbeTalk.com Forums

forums.probetalk.com > Tech Section > 2nd Gen (93-97) V6 2.5L

Feb 05, 2016 | Ford Cars & Trucks

1 Answer

2003 Ford Expedition intermittent engine/ignition failures


this could be because of the fuel pump not functioning properly.

Oct 11, 2008 | 2003 Ford Expedition

1 Answer

'80 jeep cj5 2.5 engine. Cranks and idles fine. Sputters and hesitates during acceleration. Revs smooth while in neutral. New plugs, wires + accel. Pump.


CJ5 Hesitates when accelerating - JeepsUnlimited

www.jeepsunlimited.com/.../showthread.php?...CJ5-Hesitates-when-accel...

Mar 29, 2006 - 19 posts - ‎13 authors
If it still hesitates I'd say it was a carburetor issue (accelerator pump, power valve..). If it is only acting up when accelerating (while driving) that would tell me it ... 1980 CJ5Renegade with 304 v8 .... The idle mixture screws were nearly 3 turns out, I think i have them somewhere around 2.5 turns right now.

97 TJ 2.5L hesitating and sputtering - JeepsUnlimited

www.jeepsunlimited.com/.../showthread.php?...97...hesitating...sputterin...

Dec 8, 2001 - 20 posts - ‎9 authors
Reving the engine in gear with the clutch in a bit would load the ... alot longer to warm up and tends to hesitate when pulling away from a ... Jeep rater score from the factory:26, today:238 ..... 92 XJ 155/80r13s and 17"s of lift.Missing: cj5

Hesitation on Acceleration... performance problems #1 ...

? 7:13
https://www.youtube.com/watch?v=0m4IiVzwjzE
Nov 17, 2013 - Uploaded by Luke Nodzo
Luke will explain why your car may be hesitating or sputtering on... +ameer aklil My 2012 2.5l Frontier does the same thing when it is in 3rd and ...

Dec 16, 2015 | Jeep Cars & Trucks

1 Answer

I have a 2000 ford expedition. Out of the blue it started sputtering and shaking when I accelerate. Vehicle has144,000 miles.


Sounds like one of the coil over plugs have gone bad. this will cause mis-fire which causes your car to sputter, skip, and shake. It can be changed easily when finding out which one it is. But rather expensive for a simple part $40+ each.

Jan 02, 2010 | 2000 Ford Expedition

4 Answers

97 Expedition, 5.4L hesitated during acceleration 40-45MPH. Check Engine light flashed, then stayed on. Would get up to 55-60MPH. All guages read ok. First trouble ever with this car.


go to a parts store and they will let you use their scanner for free. sounds like a cylinder misfiring. The scanner will tell you which one it is.

Dec 13, 2009 | 1997 Ford Expedition

1 Answer

Engine hesitated when trying to accelerate. Now


check engine for spark....sounds like a bad electronic control module

Nov 22, 2009 | 2000 Ford Expedition

1 Answer

Why does my 2001 Ford Expedition Sputters When I Accelerate?


YOU NEED TO HAVE THE DEALER TEST THE SYSTEM FOR TROUBLE CODES, U HAVE A FAILED ENGINE CYLINDER, MOST LIKEY AN IGNTION PROBLEM.

Nov 09, 2009 | 2001 Ford Econoline

2 Answers

My 97 ford expedition sputters when I drive it


u need more high octane gasoline....97% or more

Jul 12, 2009 | 1997 Ford Expedition

1 Answer

Motor hesitates and sputters when idleing and acceleration


Absolutely is the Problem! Please Rate My Response! Thanks!

Feb 01, 2009 | 1994 Chevrolet S-10 Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

443 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5481 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...