Question about 1999 Oldsmobile Alero

1 Answer

I changed my alternator on my car but the engine light still on and when i drive up hill i loose power and the track off light comes on.whats is the problem?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Oldsmobile Master
  • 22,219 Answers

Take it to a garage for a diagnostic reading and let them put it right

Posted on Apr 25, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

2003 chevrolet check engine light flashes going up hills looses power


flashing is usually a sign of a bad misfire situation, check the plugs and wires, also check for coolant in the oil or oil in the coolant.

Sep 03, 2012 | Cars & Trucks

1 Answer

Won't start-clicking sound-good lights


the battery is low on power. the lights will still light for a bit longer but your engine needs more cranking amps to turn it over. Have someone help you jump the car. or if you have a manual transmission, get the car moving 5mph+ somehow (push or hill) and pop the clutch out with the keys in the ignition in the on position. your car will start right up. if your car regularly needs jumped you probably have a bad battery. if your car looses power while driving you have a bad alternator.

May 03, 2011 | 2008 Chrysler Pt Cruiser

2 Answers

What happens when serpentine belt goes bad


When a serp belt breaks you loose all power steering. water pump is not operating so car will run hot. battery light would come on because alternator is not working. You would basically loose anything that worked off the drive belt. You would also loose air conditioning.

Feb 01, 2011 | 1998 Jeep Grand Cherokee

1 Answer

The hill descent, abs and tracking lights have come on two times within the last week. They come on while driving and will not come back on when the engine is started.


Suggests either Wheel Bearing, ABS Sensor Fault, or Shuttle valve. Best to get it to a dealer and on the computer for them to diagnose what exactly is wrong.

Feb 10, 2010 | 2003 Land Rover Discovery

4 Answers

SC 400 engine light and track light on-but engine runs great


to reset any malfuntion in memory , disconnect the negative battery terminal few minutes

Mar 03, 2009 | 1992 Lexus Sc 400

9 Answers

2002 Hyundai Accent lost power


Hi and welcome to FixYa,

Offhand, definitely an electrical issue. Some ideas to check, consider and/or explore:
  • IGN switch - check for loose, corroded or heating connections. To test, under normal usage of the vehicle, should feel warm but not overly hot. If so, then possibly loose connection;
  • fuse/relay box - check for loose, corroded or burned terminals, holders, clips and connectors/pins. Use an electrical contact cleaner and spray. It may also be necessary to scrape to remove burnt marks/corrosion;
  • fusible link - the battery would have 2 wires connected to the + terminal. The big wire goes to the starter, the smaller of the two is the electrical systems main wire. This normally goes to the fuse/relay box. Check for frayed ends, loose connection, corroded terminals. In some instances instead of being at the battery's + terminal, it is connected to the end of the big cable down at the starter motor.
  • ALL connectors with big wires - these carry the main +12 either as always ON, ACC or IGN. If a connector has a wire bigger than the others, check them. It may be necessary to disconnect to enable you access to the inside pins/terminals. Scrape them clean.
Good luck and Thank you for using FixYa.

Dec 29, 2008 | 2002 Hyundai Accent

4 Answers

Loosing power


Wow, I just went through the same problem and guess what it was a clogged converter and a bad oxyegen sensor. The garaged fixed it up for me by putting an eco converter on it and a new O2 sensor. I have a 2003 Chevy Impala,V6 3.8 engine. Good Luck!!!!

Aug 18, 2008 | 2003 Chevrolet Impala

Not finding what you are looking for?
1999 Oldsmobile Alero Logo

Related Topics:

42 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8516 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...