Question about 1993 Chevrolet S-10 Blazer

1 Answer

Its a 1993 chevy blazer 4.3 l and its been for three years having problems right now its the spark it was running just fine and then it stops get it towed then sometimes it will start the next day and it won't right now no spark / thiers a new dist. cap / rotor / batt. / plugs / wires / so what now the brain ? or the ing. module ? and wheres that at ? thanks mark l.

Posted by on

  • mark lynch Apr 25, 2010

    and where would that be at ?? and thank's for all your help this is a great sit i just found it its a good deal !!

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 57 Answers

Had a mitsubishi do that too. ECM was out of it. I think you can have the module tested, but if not, they aren't that much to try one, could still be it. They usually only give you problems when they get hot. As for your computer, it's behind the glove box. Take out the glove box, your computer is in a white plastic box with a bunch of wires running into it. When I looked into one at autozone for my 93 K1500 with the same engine, I think they were like 100 bucks.

Posted on Apr 25, 2010

Testimonial: "thank's but i forgot to put in that its a s-10 blazer with a4.3 l "

  • Juston Apr 25, 2010

    No problem. Shouldn't matter too much on that, they are all basically the same :)

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I was given a 1994 s10 Chevy Tahoe vortex blazer


I was given a 1994 s10 Chevy Tahoe vortex blazer??????? It's either a S-10 pick-up or it's a Tahoe or a Blazer not all three . So which is it ?

Mar 11, 2017 | 1994 Chevrolet S-10 Blazer

3 Answers

1993 Chevy S-10 blazer turns over but won't start


spray starting fluid in the air intake if it fires you have fuel problem , if it dont it is ignition probably the ign module in the distributor

Nov 06, 2009 | 1993 Chevrolet S-10 Blazer

1 Answer

Removed & replaced dist. cap and rotor on 1993 S10 Blazer 4.3 V-6


The firing order for a Chevy s10 depends on which engine you have. 1.9L engine the firing order is: 1-3-4-2 . Distributor rotates counterclockwise. 2.0L engine the firing order is: 1-3-4-2 . Distributor rotates clockwise. 2.5L engine the firing order is: 1-3-4-2 . Distributor rotates clockwise. 2.8L engine the firing order is: 1-2-3-4-5-6 . Distributor rotates clockwise. 4.3L engine the firing order is: 1-6-5-4-3-2 . Distributor rotates clockwise.

Jul 03, 2009 | 1993 Chevrolet S-10 Blazer

1 Answer

4L60E won't shift to 3rd on 1993 Chevy Blazer 1500


Sounds like you have a bad shift solenoid. Not sure if the Chevys are a solenoid pack, or seperate, but it will need to be replaced.

Jun 02, 2009 | 1993 Chevrolet K1500

1 Answer

4 wheel drive


small switch isnt working right on the top of transfer case. vacome operated. replace or check the three lines that run to it

Dec 06, 2008 | 1993 Chevrolet S-10 Blazer

1 Answer

1993 Chevy Blazer Oil Pressure


nothing ..normal low pressure at idle while hot ...but really should be thinking fresh oil change and filter soon..also what are the RPM's at idle hot in gear with A/C radio and other accessories running?

Nov 10, 2008 | 1993 Chevrolet S-10 Blazer

3 Answers

99 Chevy Blazer


Have you tested the crank sensor? sounds like no command from PCM to pulse injectors.

Aug 04, 2008 | 1999 Chevrolet Blazer

Not finding what you are looking for?
1993 Chevrolet S-10 Blazer Logo

193 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7772 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...