Question about 1999 Ford Expedition

1 Answer

My ford expedition xlt is leaking coolant from behind the motor and over heating. i have already replaced the thermostat, and the water pump. i was told i may need to replace the freeze plug.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,317 Answers

Could be one of the freeze plugs in the back of the block. You'd have to remove the transmission or motor to get to it. Also check the heater hoses at the firewall, the intake too. A mirror on and extension might help.

Posted on Apr 25, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 98 expedition and it is using alot of


i myself had this problem it cud be your thermostat malfunctioning a clogged heater core or a leak in the cooling system or even worse a bad head gasket . does your overflow tank blow out coolant? check your oil look for water if no check your coolant over flow tank does it smell like exhaust? if oil is good and overflow tank smells fine you have eliminated bad head gasket few right.so then you check thermostat make sure its not sticking open or closed .check heater core if you have heat thats good . so best case sinario its the water pump atleast was the case with mine in summer ran water in it but water evaporates quickly as expected but as winter approached i added antifreeze right then and there the water pump started to squeel and leak antifreeze out the weep hole located on the top of water pump i replaced water pump and have not had a problem since hope this helps good luck

Sep 17, 2014 | 1998 Ford Expedition

1 Answer

How do i find out why my 2007 1.4 fiesta is over heating


At home when motor is cold check coolant level. Start car with hood open watch for leaks .if no leaks and no hoses suck shut,replace water pump an thermostat And replace coolant. If hose suck shut replace radator cap

Jul 07, 2014 | 2007 Ford Fiesta 1.4

1 Answer

2004 explorer 4.0 coolant reservoir boils over when stabolized at normal level, no heat when level drops temp indicator normal


go to autozone rent the free tool called a block tester buy the fluid for it (about $8.00 us)drive the car make sure the resivour is about 3 inches down so you dont suck any fluid into block tester. pour blue fluid into block tester put it in antifreeze resavour. squeeze bulb sucking air from resouivour for up to 2 minutes if fluid turns yellow your head gaskets are leaking. I think you may find this to be your problem

Feb 12, 2013 | 2004 Ford Explorer XLT

1 Answer

2000 FORD EXPEDITION OVERHEATING....changed thermostat,radiator cap, confirmed fan clutch is working, no radiator leak noted, changing coolant temperature sensor as a type...water pump not leaking or...


yes. the impellor on these engines have a tendency to come off the water pump.First you can see if the pump is working by removing a heater hose then have someone to start the engine. if the water sprays a good, solid stream out then the water pump is good. if the water just barely comes out or not at all then the pump is weak or "bad".

Aug 13, 2011 | Ford Expedition Cars & Trucks

1 Answer

Car over heats when warm and pushes water and coolant into over flow tank already changed thermostat


well if you have already changed thermostat there is a few other things that can cause this they are listed below
1. faulty rad cap
2. coroded water pump impeller / replace pump
3. rad fan not coming on / possible faulty coolant temp sensor will cause this

May 05, 2011 | Ford Thunderbird Cars & Trucks

1 Answer

My ford expedition 2000 is over heating


it can be a number ot things, start by checking the coolant level and condition, next check it for leaks, if no leaks start by cheking the temp. on the hoses comming out ou the radiator are the both hot it they are both hot it could be the fan, or a head gasket, if one is cool to the touch and the other is hot replace the thermostat, then recheck if its still over heating the water pump may not be providing sufficient flow. it might need replacing.

Dec 19, 2010 | 2000 Ford Expedition

2 Answers

My 1999 Ford Expedition XLT started loosing coolant and the engine started heating up. I have replaced the thermostat, but it made no difference. There are no signs of a leakage, and no puddle are found...


check the motor oil to see if the level is higher on the dip stick, also remove the oil filler cap and look at the side that goes into the engine, see if the cap is clean or has a light brown milkshake look to it.
if you find the milkshake under the cap or the motor oil is much higher than normal the coolant is leaking inside the crankcase. continued driving will ruin the crank bearings.
if you find what I described, have your vehicle towed to your shop, stop driving it.

Jan 07, 2010 | 1999 Ford Expedition

2 Answers

1998 ford expedition 4.6 engine without tow package...overheating


If you're running it without a thermostat it's clear there isn't enough/any coolant circulating through the block. When the motor is running are the hoses off the radiator soft and flexible or stiff. If they're soft there's no coolant flowing through them. Chances are the radiator core is bad or there is a crack in it somewhere. Have it removed and tested.

Sep 15, 2009 | 1998 Ford Expedition

2 Answers

Car over heats,fans are working can't find relay.


low coolant level , restriction, bad water pump, or stuck thermostat.

Jul 19, 2009 | Ford Escort Cars & Trucks

1 Answer

Problem getting the heat in my Ford Expedition to get hot


First where is the coolant temp at on the gauge, If the water isnt getting to 180 to 210 then you may have a stuck open thermostat.. Its also possible your water pump impellers are deteriorated to the point they dont push enough water. This is all based on knowing that noone put stop leak in the system. Stop leak could clog the heater core but not effect the engine and it could of caused the themostat to stick open. Also its possible your climate control knob is bad. I've seen then crack. Pull it off and look. Also listen with the fan on. Listen for the doors changing. Also do you have duel climate control. If you have heat in the back but not in the front then i'd suspect a control issue. If you have the same front anfd back I would suspect a coolant issue.

Jul 13, 2009 | 1999 Ford Expedition

Not finding what you are looking for?
1999 Ford Expedition Logo

379 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

fordexpert

Level 3 Expert

5495 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...