Question about 1987 Buick Century

1 Answer

Ok we changed the ignition module in our 1987 buick century, 2.5 liter and now when you start the car it just dies continuiously but once we get it started it will go but acts like it wants to die at stop lights, what can it be? is it the map sensor? we already changed the oxygen sensor, ignition module,spark plugs,new battery. please can you tell me what it could be?

Posted by on

  • stressedoutm Apr 23, 2010

    well this car has no distributor so it is in the back of block with coils

  • Clint Smock
    Clint Smock May 11, 2010

    I can't remember exactly when they switched the ignition system on the 2.5. Was the module you replaced on the back of the block with coils mounted to it or is it in a distributor?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 4,669 Answers

Did you replace the crank sensor that is bolted to the back of the module? Is it possible that you got two of the plug wires switched. Or maybe 1 of the two coils is bad.

Posted on Apr 23, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 87 buick centry stalls while driveing but when it stalls the battery light and service engine light comes on but once i put the car in park or nutrol it will start back up


My 1987 buick centry limited cuts off when i drive but when i start it back up it will start right bacc up at times some times it starts and die agin but when it dies the battery light and service engine light comes on but once it starts the service engine and battery light goes away and dont do it agine tell it cuts off agine

May 27, 2012 | 1987 Buick Century

1 Answer

A family member has a 1987 Buick Century 2.5L. Car would intermittently stall out and restart after sitting for a while. Now it won't start at all and has been in the garage for 2 weeks. They have...


try and change out the crankshaft position sencor it has a lot to do with the timeing and fuel i had a 12995 chrysler concorde that did the same thing i switched that out and it ran great i now also have the same buick as your family member hope this helps

Mar 19, 2011 | 1987 Buick Century

1 Answer

Shuts down after getting hot 1992 buick century custom has high mileage transmission is okay last tune up at 60,000 one plug was not changed hard to get to


What you need to do is check and see if your losing fuel or spark when it dies.If it`s spark then you probably have a bad ignition module.If fuel you will have to check the fuel pressure.If it is a 3.3 then it should be 41-47 psi.If not check fuel filter for being plugged.If ok then replace fuel pump.Hope this helps.Good luck.

Dec 12, 2009 | 1992 Buick Century

1 Answer

I have a 1987 Buick Century. That stalls out


I'm not Roger but can tell you this....if you have a bad crankshaft position sensor or a corrupt ECM....your car will do that.....last things could be the timing belt.

Dec 04, 2009 | 1987 Buick Century

2 Answers

1987 Buick Century, V6, 2.8L will not start. No


the 3 coils are mounted to the ignition module and as long as the sensors that signal the module to fire the coils individually are working I would try a module especially if all 3 coils are not firing..also if you have an ohmmeter for checking electrical resistance, the spec for the coils are 5000 to7000 ohms, measured between each coil from tower to tower (ie) #1and#4 2+5 and 3+6 any more than that and the coils are toasted..lol hope this helps also check the spark plug wires at each end maximum resistance is no more than 1000 ohms per inch,,,good luck

Nov 25, 2009 | 1987 Buick Century

2 Answers

1994 buick century blowing ignition modual


I doubt it I think you are close I'd check ground wires at module and at frt left side of eng to trans bolts also ck connectors for module see if green if go to radio shack get elect cleane to use

Aug 30, 2009 | 1994 Buick Century

1 Answer

1987 Buick Century Limited V-6 engine w/ac. Engine cranks but won't start. Instrument panel light shows "Service Engine Soon". Also light shows "Oil Choke". And light shows picture of battery.


I took my car to my mechanic. He did a diagnostic circuit test on the engine and then replaced the distributer ignition module and camshaft and crankshaft position sensors.

Jun 18, 2009 | 1987 Buick Century

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

153 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7768 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...