Question about 1994 Chevrolet S-10 Blazer

2 Answers

I have a 94 Blazer with the vortec 4.3 liter. It will not start without added fuel into the air intake. Now I have changed the pump and sending unit and I have pressure at the shrader valve and have looked at the spider injector assembly and its good. Its not dumping the fuel into the engine. I did notice however that the pump seems to run for a longer than usual time when you shut the key off. I even replaced the regulator on the injector assembley and no change. I catn seem to get this on figured out. Any ideas would be a great help. Thanks.

Posted by on

  • 1 more comment 
  • Ed Woods
    Ed Woods Feb 08, 2010

    I dont understand what you are reffering to.

  • Ed Woods
    Ed Woods Feb 09, 2010

    anyone got any clearer ideas. I have changed pump and still am having issues. I am at fresh out of ideas. Also changed sending unit due to a idea that the check valve in the sending unit could be bad.

  • Ed Woods
    Ed Woods Apr 03, 2010

    turns out it was just a faulty fuel pump from auto zone. Got it swapped out and runs fine now.

×

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 14 Answers

Check the BYPASS valve is the one inyect fuel into the imtake manifold to start thats it

Posted on Feb 08, 2010

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

The oil pressure switch takes over running the fuel pump as soon as you start to crank the engine up until this time the fuel pump is just primed or turned on by the black relay on the driver's side firewall under the hood. Most likely your problem lies in a faulty oil pressure switch. It is engineered not to start if no oil is received by the engine, and it will turn the fuel pump off if oil stops going thru the engine.

Posted on Sep 22, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Our fuel pump stopped working on our 98 Chevy Blazer V6 4.3L Vortec Engine, so we bought a new one. A couple days later (before replacing the fuel pump) it started up and ran but ran crappy. So we did


what did you do (replace it) if you still have a miss you may need to tune it up / make sure the fuel pump you bought is for the right psi for your blazer

Mar 27, 2013 | 1998 Chevrolet Blazer

1 Answer

94' blazer will not strart just died one day while driving it .i replaced fuel pump,fuel filter,fuel ragulater, if you spray starting fluid in it it will start but then die whin the starting fluid burns...


check to make sure they sold you the right fuel pump. they are two pumps for a 4.3 ones a vortek and one is a throtlle body. the eighth digit of the vin will tell you one is a vin w and one is a vin z. the throtlle body only puts out about 11psi of pressure and the vortek puts out about 60psi of pressure.if you put the throttle body pump in a vortek engine there is not enough fuel pressure to run it.

Oct 20, 2010 | 1994 Chevrolet S-10 Blazer

1 Answer

I have a 96 chevy blazer with a 4.3 vortec rough


Do a compression test on all of your cylinders when it is cold. Backfiring is a sign of a worn valve seat allowing mixed fuel and air (lit by spark) to be forced back into the intake. You will probably see compression loss on one or more cylinders.

Also... there is a chance that the EGR valve is not totally seated when the engine is cold with just a small blow by. The EGR valve seats coke up over time with black gunk.

Jan 28, 2010 | 1996 Chevrolet Blazer

2 Answers

94 Blazer, 4.3L Vortec Engin runs fine for a


Could be a fuel issue, Start by changing the fuel filter, if that doesnt work you might want to drop the gas tank and check the strainer on the fuel pump and make sure the tank is clean.

Jan 20, 2010 | Chevrolet Blazer Cars & Trucks

2 Answers

1993 Chevy S10 Blazer engine hesitation with smoke from exhaust


Had a 94 Olds Bravada that did a similar thing and it was EGR valve on the front of the intake. It' s easy to take off and clean with WD 40 and if you have an air compressor blow it out good.

Dec 19, 2009 | 1993 Chevrolet S-10 Blazer

1 Answer

'94 S 10 Blazer V6 Vortec EFI. Fuel pressure good, new fuel injectors installed, fuel pump works ok. Only starts with starter fluid sprayed into air intake. Any Suggestions?


your statement is fuel pump work ok, have you tested for proper fuel pressure. just because the fuel pump works it could have less pressure needed to start the engine. maybe the fuel filter is plugged. start out by replacing the fuel filter, if this doesn't fix it, you need to pressure test the pump. even 10 psi reduction in pressure will allow the engine not to start.

Nov 03, 2009 | 1994 Chevrolet S-10 Blazer

1 Answer

Not cranking


If the engine is locked up try pulling spark plugs to see if radiator fluid is inside. If so the intake plenum would need replacing as well as an oil change.

Apr 14, 2009 | 1994 Chevrolet S-10 Blazer

1 Answer

My 94 blazer wont start


I have the same problem with my 95 blazer I have heard that it is the fuel pressure regulator. That is the next part I will be replaceing.

Good luck to all.

If any one finds any thing out please let me know!

Dec 13, 2008 | 1994 Chevrolet S-10 Blazer

3 Answers

Help


Sounds like it needs a new fuel pump. Get a Fuel Pressure Gauge and check it make sure it up to the Specs,What I think is about 35 to 40 psi without looking in my book. Also you would want to make sure the fuel filter was changed, Your getting spark and fuel, But You stated your able to start it with starting fluid so I would say it must be a fuel pump problem.. I hope that help you out. If not get back to me and we can try some more trouble shooting. Take Care, Bear

Jun 11, 2008 | 1993 Chevrolet S-10 Blazer

Not finding what you are looking for?
1994 Chevrolet S-10 Blazer Logo

312 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

77186 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...