Question about Plymouth Voyager

1 Answer

No fuel getting to engine. Possibe fuel pump. Replace fuel filter with aftermarket brand 6 months ago.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 21 Answers

Possibility that's it's the pump, the fuel pump relay, check the relay and pump for power/ground etc.
Although you changed the filter 6 months ago i wouldn't X that as a possibilty, i always try to change parts with Ac Delco or another OEM equivalent brand.
Could also be injectors, test the resistance at each one, however if none are giving gas then it's extremely rare that they all died at once.

Posted on Feb 08, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Loss of power and shuttering when accelerating


You sure filter is facing flow correctly?:I'd check that first,some cars/trucks have in-line filters.

Feb 10, 2014 | 1996 Chevrolet Tahoe

1 Answer

Does anybody have any idea want could be wrong with my 2001 chevy tahoe??I replaced my fuel pump 2 yrs ago but now these past few weeks.I can drive about 6 to 8 miles away all day long stopping places and...


I had the same problem with my 1996 tahoe and it wound up that the fuel pump was going bad and then finally did go out completely. make sure you get an a/c delco or delphi fuel pump as they are much better than the cheaper aftermarket brands that fail after about 1 year or so. also, make sure they check the fuel pump relay located under your hood on the driver's side in the main fuse box. its about 10 bucks or so and also will cause your truck to die and not start again. it's well worth the investment to just replace it when doing the fuel pump. lastly, make sure they install a new wiring harned from the fuel pump in your gas tank to the electrical connector running to the engine. hopes this helps.

Oct 21, 2011 | 2001 Chevrolet Tahoe

1 Answer

I got a 1999 ford ranger with a 2.5l it runs smooth at idle, an runs smooth while drive but bad fuel economy. when u rev up at idle an let go of the throttle it runs rough an then smooths out. ive...


You have two coils on this engine. Test each wire for spark with the engine running. You'll find at least one wire not sparking. replace the coil that has the wire that's not sparking.

May 14, 2011 | Ford Ranger Cars & Trucks

2 Answers

I have a 1994 gmc 1500 truck with a 5.7 v8.one fuel injector is pumping fuel and the other injector is not!!!!i swapped the injectors and its not the injector.


Go to the parts store and get a noid light for your truck, plug it into the injector electrical and turn the engine over to see if there is electrical pulse, also check the fuel pressure, the pump needs 9-13 psi with the engine running. you know if there is no pulse your going to need to check the wireing first. let me know

Feb 10, 2011 | 1994 GMC Sierra

1 Answer

Starting problems


you may need to get the fuel pump tested for proper voltage and pressure

Apr 02, 2010 | 2001 Chevrolet Silverado

1 Answer

Bank 1 too rich.


does your truck have an airfuel regulator.try that

Jan 24, 2010 | Chevrolet 1500 Cars & Trucks

1 Answer

My Camry's engine ran out of oil, according to the Toyota repairman, because the oil filter where it screws into the block was loose. He said because whoever changed the oil didn't replace it tightly. It...


Ive worked in a Toyota dealership for the past 11 years and yes I have seen oil filters work there way loose and vibrated off, but you are right, not usually after 4 months of driving. It could have happend if it was loose origanally and then it finally worked its way off. idk its hard to tell- but ill tell you one thing usually when this happens it it with an aftermarket oil filter and not a genuine Toyota filter. and 08 Camry motors rarley blow and dont burn or leak oil so the filter over time had to be the only way for it to loose oil. Im not trying to take the dealers side cause i work at one- all im saying is that it is possibe.

Dec 02, 2009 | 2008 Toyota Camry

1 Answer

Engine cranks, won't start. Three days later, it starts???


probaly a fuel pump its common for vehicles to do that the best thing to do next is a fuel pressure check to verifiy its the pump

Apr 15, 2009 | 2000 GMC Jimmy

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

157 people viewed this question

Ask a Question

Usually answered in minutes!

Top Plymouth Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8557 Answers

Are you a Plymouth Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...