Question about 1996 Mercedes-Benz E-Class

1 Answer

Odomoter in e230 not illuminating with either lights on or off

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Key remote is no working

Posted on Feb 14, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Mercedes e230 1996


ETS light is electronic throttle system.

Jun 17, 2013 | Mercedes-Benz Cars & Trucks

1 Answer

Locked out of my merc e230 1998. can't open bonnet


Call either the RAA or another roadside assistance company!

Apr 13, 2013 | Cars & Trucks

1 Answer

Dash lights won't work


You may have a defective headlight dimmer control switch. It is common on this make.

Oct 01, 2012 | Jeep Wrangler Cars & Trucks

1 Answer

The LED light has gone out on my odomoter. How or


I own a 2001 Buick LS, I had the same problem ,Odometer lights and I fixed it myself. Here is a YouTube video that may help. Let me know how it goeshttp://www.youtube.com/watch?v=84FAjLxoK00

Another site where I originally located the very helpful information is RegalGS.org look under topic: Instrument Cluster Fix-Write Up.

http://www.regalgs.org/forum/viewtopic.php?f=45&t=31452

Jan 05, 2010 | 2001 Buick Regal

1 Answer

I have a 1996 VW Jetta, odomoter and speedometer


Either you have a broken wire some where from the speed sensor to the cluster or you have connector at fault, the one which hookup the dash cluster to the main wire bundel. Check the connector, maybe a pushed back pin !!

Aug 08, 2009 | 1996 Volkswagen Jetta

1 Answer

Windshield wiper blade on my MB E230 1996 makes noise


A better quality (aftermarket)blade fixed that problem on my E230

Dec 06, 2008 | 1996 Mercedes-Benz E-Class

1 Answer

1995 hyundai excel speedo problem


The speedometer cable needs to be changed or tightened.

Aug 01, 2008 | 1994 Hyundai Excel

Not finding what you are looking for?
1996 Mercedes-Benz E-Class Logo

Related Topics:

77 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...