Question about Chevrolet S 10

1 Answer

96 s-10 4.3, the truck idle's fine. Runs under a load fine, but when I hold the throttle steady I get a miss.. It will run like that until it sets code po300.. it has new wire's, plugs,cap rotor.

Posted by on

1 Answer

You can't hold the throttle as steady as the pcm sees it. You may have a miss fire if the Generic 300 Code applies to your veh. You need a professional scanner and better yet oscilloscope on the Throttle Position Sensor under the conditions you were able to create.

Posted on Feb 06, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

What causes engine miss at idle under load?


I'm not sure what you mean by "under load", maybe with a/c on, etc. Also is it really an engine misfire or a rough idle. If it really is a misfire, a scantool at your local parts store should be able to read a code for that. Sometimes a rough idle could be due to just a cracked or disconnected vacuum hose or dirty throttle body. You didn't say whether it runs ok at highway speeds. Sometimes a rough idle can be cleared up a lot with throttle body service or injector flush. Sorry, this is the best I can do with information provided.

Jul 16, 2014 | 2002 Hyundai Santa Fe

1 Answer

Rough idle cold or warmed up,runs great on highway


tune up,fuel filter,air filter,clean throttle body.

Mar 09, 2013 | 1996 Ford Thunderbird LX

1 Answer

1994 Toyota 4runner runs intermittently, no vacuum sounds as if there is a leak, all fluids topped off, truck cranks over and does start but will not stay running. Idle changes drastically until hot. Once...


You should check you MAF sensor. clean your throttle body and change your spark plugs. shouldn't be anything if you say there is NO vacuum leak.would recommend searching your PCV valve for a vacuum leak

Feb 07, 2013 | Cars & Trucks

1 Answer

How to fix f85 codes in cadillac


this is what i found about code f85




QUESTION: 1991 Sedan Deville, 4.9 port injection
Car runs great until outside temp reaches 92 deg. or above. the car will start to cut out under load (take off or hill. if i pull over the car will idle fine rev the engine to a steady high rpm and it will cut out. i had a code e44 (o2 sensor rich)so i replaced o2 sensor with no effect. the other code received was f85 (Throttle body service required). I have checked all connectors and hoses attached to the throttle body. all ok. looking inside throttle body there ar two tubes under the flaps one is totaly restricted with a black buildup and the other partly blocked. Not sure what these tubes do and if that could cause engine to cut out when hot and under load. any ideas?

ANSWER: You found your problem which is this black residue which when hot turns to a jelly substance and blocks the idle air passage. You need to clean all that residue from the throttle body and do not forget to spray the small hole in the side of the throttle body just behind the throttle plate.

Dec 05, 2012 | Cars & Trucks

1 Answer

1994 jeep wrangler engine missing at mid range


check fuel pressure regulator and fuel pressure. should be between 45-50 psi and hold steady.. shut off car and let sit 5 min if pressure drops more than 10 lbs one of the two is bad...

Jul 07, 2012 | 1998 Jeep Wrangler

1 Answer

2004 Silverado 4.3 V6 Has miss on cylinders 2 and 4. Have done complete tune up Plugs Wires Cap Rotor,Fuel Filter. Still had Miss. Compression on all 6 within 8 lbs of each other. lowest reading 168...


Check engine light on? Any codes? Missed before and after the cap was changed? Or is the cap new so you assume its good. I have had caps bad out of the box.

May 29, 2011 | Chevrolet C1500 Cars & Trucks

1 Answer

My 02 sentra ser spec V runs fine if it is under a load and while accelarating but at an idle it keeps jumping up between 1000 and 2500 rpm for a few seconds before finally settling in at around 1200 rpm. ...


Idle speed control valve located on your throttle body. It has the engine searching for idle, internal plunger is not backing down. This will cause the check engine light to light . if you wont, i think they still offer free check engine light checks at auto zone, i now they still do around here

Mar 24, 2011 | 2002 Nissan Sentra

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

127 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7688 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...