Question about 1999 Mercury Cougar

1 Answer

My 99 cougar stick shift V-6 2.5 is acting up the Battery light keeps coming on if i dont shift Before 3 Rpm the light goes off or if i do 60 the light then goes off i think i need a new alternator does any body Know hats wrong or had this problem????the out put dosenot drop it just losses power every time the Battery light goes off this is when i reach 60(or when it feels like doing this)also would having a lose or old belt make this problem??

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Mercury Master
  • 1,146 Answers

Hi:
I would definitely have your alternator checked out. The battery light means that the car is running off the battery, and not the alternator,. If you can or know someone who can remove it, most auto parts stores will check it out for free, and tell you if it is bad or good.

Posted on Feb 05, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Transmission -does fine until it warms up, then does not want to shift correctly, drive begins flashing.


d flash mans, tranny fault
so scan it. us the obd2 scan tool, any and scan it.
the A/T IS VERY complex, do the tests shown in the FSM
guessing dont work
but in general (experience)
wont shift correctly dont cut it. (200 parts, and 50 was to mess up)
????
flare, skips gears, wont up shift, wont down shift, or shifts wrong speed. what gears work, what dont. just a clue and help goes get better
The tranny TCM can go to limphome mode, this mode is very clear.
and covered in the FSM and
one common failure, that happens with high mileage and poor service (not doing a flush at 50k miles)
is stuck in 1st gear, hot. only.
the ATF fluid gets more thin hot and pump output drops
this is usually a vary bad sign.
the Stall test fails.
the pump pressure test fails, hot.
there is no vacuum lines to this electronically shifted trans.
the ended back 1990(about). with old 3speeds.

scan it, could be something slimple like
the PRNDL shift switch fibbing like crazy. (common)
this car has TCM, a transmission brain.
look for OBD2 DTC errors P07xx (trans)
this TCM (part of PCM) function relies on sensor for shifting
they are:
1: TPS
2: engine INPUT rpm
3: tranny output rpm
4: shift selector.
5: ECT (engine temps)
6: ECU part of the PCM calculates load at all times and sends that to the TCM , so that TCM can down shift on hills, or upshift faster on the flat or down hill.
this LOAD feature is what replaced the VACUUM of old days.

The D light , hopefully is just a bad input (cheap)
scan it. and see, its begging for you to do that.

Jan 02, 2014 | 2001 Honda Odyssey

1 Answer

2002 Tundra, replaced battery, alternator was checked and is good, but engine cuts out when I slow down/break, and battery light comes on. Starts back up easily.


stop guessing, please.$$$$$
hot or cold engine, or both.
ever heard of engine stall? the rpm drops below 800 and stalls?
the engine rpm is KEY
post all symptoms, and we can fix it.
so far all i have is the hint of a stall or engine running at 300 rpm.
the alternator don't work at 300 rpm. at stall or near that.
your car dont have a tachometer? if it has one learn to watch it.
stalls are complex.
can be.
The engine PCM controls idle speed and Regulation at all times.
and is the LAST thing to work right, in EFI.

think of a juggler of bowling pins, a delicate balancing act.
so if the pins are slippery , he drop one, so easy.
EFI is Electronic fuel Injection (makes spark too , on gas engines..)

on EFI, idle fails (low) 800 is normal hot block, (look up yours. no engine options or size or cylinder counts stated)

the low RPM is caused by. many things. (i have a list of 50) so skip that....
1: too rich , too lean,. misfiring, DTCs set, ever scan the PCM YET?
2: EGR sticking open(clean it)
3: ISC (IAC electric) stuck closed, (again clean it)
4: never did the 60k mile tune up? if you did it would run ,if not the person doing it would tell you why it dont run right or even fix. it.
during a tune up , we check the ISC and EGR for filth and clean them.

now ill do the marco (physics answer)
1: bad engine, engine compression bad on 1 or more cylinders.
2: bad spark , tuneups fix this 99% of time, and work
3: bad fueling. (vastly complex. but most times bad inputs to ECU)

there are exceptions, but all land on #1 (stops engine from pumping air)

Dec 30, 2013 | 2002 Toyota Tundra

1 Answer

Mazda 6 2005 u0101,u0155,u0121,u0073,u0100 codes coming up


I got the same problem. u ever figure it out? ive cleared codes and there the same. light on cluster lit up . plus some time after pulln away from stop car goes five mph. turn off start up drives fine. im about to burn this thing.

Apr 21, 2013 | 2005 Mazda 6

1 Answer

The transmission has checked out to b ok but every so often when the car acts like its having problems shifting.The rpm wil go up but takes it a minute 2 shift.When it shifts tho it dont shift hard just...


does it happen more when turning,could be the fuel pump,they had a replacement program for them for awhile, i have owned one silver one got t-bone by dumba$$ running red light and i own a black one now, i didnt think it made any since that it could be the fuel pump in mine but it was when u get below a 1/4 tank of gas it may do it to, my transmission on this one is leaking all my tranny fuild out it pours out sometimes n wont leak others cant c were its is coming from

Aug 19, 2010 | 2000 Mercury Cougar

2 Answers

Well i have a 99 couger and i had to replace the pcm so took it to ford dealer had the car re programed so it would start now when i put it in drive it takes off in high and want shift up or down and speed...


most likely you need to replace the speedometer sensor..it control the transmission shifter by sending the signal to the pcm and the pcm to transmission shift solenoid..that why it don't shift right

Apr 21, 2010 | 1999 Mercury Cougar

1 Answer

My 99 cougar stick shift is acting up the Battery


If the alternater output drops when the rpm's increase
you may have a slipping belt. Stop at a parts store
autozone/napa/ or advance. They will put meter on it
for free. Hope this helps.

Feb 05, 2010 | 1999 Mercury Cougar

2 Answers

My 1999 cougar will not start its not the battery


My 99 cougar sometimes dont start but it dont even make a noise. it has something to do with the security system. i turn on the head lights a couple of times and it will start.

Aug 07, 2009 | 1999 Mercury Cougar

Not finding what you are looking for?
1999 Mercury Cougar Logo

137 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

fordexpert

Level 3 Expert

5467 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...