Question about 1994 Volvo 850

2 Answers

I have a 1994 volvo 850 sportwagon non-turbo. I can only use this car if i either bump start it by parking it on a hill or tow starting it. The engine turns over with the starter motor and is spinning fast enough for it to start. I have fitted 5 New spark plugs, changed the fuel filter and cleaned the mass air flow sensor with brake cleaner. The MAF is giving me a reading of 110 ohms over a coulpe of the the terminals. But i cant find out if this is the correct resistance, have tried to search on the net but no joy. I am 100% sure that the fuel pump is fully functional and that im getting enough pressure to the injector rail, and that all of the injectors are working correctly. Once the car starts it goes like a dream its just getting it started. Any help would be much appreciated

Posted by on

  • 3 more comments 
  • icedragon240 Feb 05, 2010

    The starter motor is definatly engaging, the car has a had a new battery and there is an aftermarket chassis to engine ground calbe that someone else has fitted before i got the car.

  • icedragon240 Feb 06, 2010

    The starter motor is definatly engaging, the car has a had a new battery and there is an aftermarket chassis to engine ground calbe that someone else has fitted before i got the car.

  • icedragon240 Feb 06, 2010

    The starter motor is definatly engaging, the car has a had a new battery and there is an aftermarket chassis to engine ground calbe that someone else has fitted before i got the car.

  • icedragon240 Feb 06, 2010

    The starter motor is definatly engaging, the car has a had a new battery and there is an aftermarket chassis to engine ground calbe that someone else has fitted before i got the car.

  • icedragon240 Feb 06, 2010

    Hi, You say the vehicle runs like a dream after pop start and/or tow start, so is it fair to say that the engine does not give any indication that it has a problem when you get it running? Not really, no major smoke.



    Like any type of smoke. Are there any engine lights that are lit when running?



    There has been one light on the dash which has not been on before with the same problems, it came on after i unpluged and the pluged back in the maf. But i think i8t may disapear after a ecu reset.



    Are there any trouble codes? unsure of where to find such codes



    You say the fuel pressure is ok, did you place a gauge on it? No squirts up about 6-7 inches straight abouve the fuel pump and does the same i the engine bay, should i be getting a good flow on the return when the engine is not running? havent looked at that.



    If so, what was the PSI?



    Also, when this engine is running, how much run time are we talking about? Did about 200kms for a couple of days in a row, no worrys




    Right now, taking into consideration that the vehicle runs like a dream when pop started, it is not your Mass Air flow.


    The only thing that stands out to me is when you pop start the vehicle which requires it to be in Gear, it runs. When you start the vehicle in Park, it does not run.



    Its a manual



    I know you installed plugs, but are you getting spark??? I figure that because it runs i must be getting a spark but i will double check tomorrow. Today i did supprise me, when i shut it down i tried it about 5 mins later and it struck up but took a little bit of winding over.



    I need to know the answer to all my previous questions in order to try and help. Thanks.

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 2,926 Answers

Hi, You say the vehicle runs like a dream after pop start and/or tow start, so is it fair to say that the engine does not give any indication that it has a problem when you get it running? Like any type of smoke. Are there any engine lights that are lit when running? Are there any trouble codes? You say the fuel pressure is ok, did you place a gauge on it? If so, what was the PSI? Also, when this engine is running, how much run time are we talking about?
Right now, taking into consideration that the vehicle runs like a dream when pop started, it is not your Mass Air flow.
The only thing that stands out to me is when you pop start the vehicle which requires it to be in Gear, it runs. When you start the vehicle in Park, it does not run. I know you installed plugs, but are you getting spark??? I need to know the answer to all my previous questions in order to try and help. Thanks.

Posted on Feb 06, 2010

  • GetMeOttaHere Feb 06, 2010

    Check fuel pressure also....with a gauge.

×

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 128 Answers

So you have no trouble getting car going when bump starting, then i would concentrate on the starter circuit. have someone crank over the engine while you watch, you should be able to watch the accessory drive belt and crank pulley spin as this is done. It sounds as if the starter is not engaging the ring gear to turn the engine over. this would normally require starting motor replacement. this would cause the starter to sound like it is spinning the engine over fast but it is only spinning over itself. also a tsb exists for this car due to faulty starting motors and bad battery ground wire and spark plugs (which you have taken care of) for a no start condition. As for the mass air flow sensor check that it is getting battery voltage but you do not really do resistance checks on this particular sensor (unless it is only an intake air temp sensor, different sensor), and monitor voltage on it with a dvom or scanner to check for proper operation, also cleaning it should be done with the right cleaner (some brake cleaners contain harmful chemicals that can damage sensors, not rated as sensor safe, i do not however thing this is the problem), you can try unplugging the sensor to see if it starts then but as for the sensor itself being faulty if it runs fine when you "bump start" then it is more doubtful. If you find the starter is working let me know i may have some more info to help you. good luck

Posted on Feb 05, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 1994 Volvo 850 turbo has been loosing power mainly going down hills. It will turn over and start right after, then I put it in drive and it dies again. Last night I waited an hour before trying it


It may be your fuel regulator, mine did the same thing, and the turbo should go almost down to no power while going down hill, thats normal

Sep 23, 2014 | 1994 Volvo 850

2 Answers

My 1994 volvo 850 is leaking oil from the filler cap...why?


Clogged up PCV System ---maybe

Too much crank case pressure

Nov 29, 2012 | 1994 Volvo 850

1 Answer

Radio reset code 1994 volvo 850 sportwagon turbo


Sorry, nobody is going to have that for you I'm afraid. All stereos have a different reset code, and may not use generic codes as far as I am aware.

Nov 07, 2012 | 2001 Ford Focus

1 Answer

94 - 850 non turbo starts and runs okay but after awhile fule starts leaking around the front of car close to or maybe past the firewall where could this possibly be coming from ?


If I'm not mistaken, right about at firewall is a rubber hose that connects steel fuel line coming from tank to steel line to engine. Check there for your leak.

Mar 03, 2011 | 1994 Volvo 850

1 Answer

1994 volvo 850 wont start


Well if the engine is turning over while trying to start but won't, going to have to start with the basics. If the engine light is on when she does run check for codes and see what they are and repost or have someone look at it with a scan tool at a garage. If no codes are present or none that are relavent then Start by checking the spark to the plugs with a spark tester, the adjustable gap kind are best but inline would be ok. if you got spark, check for fuel while cranking of course, (you could smell it out the tail pipe), or remove plugs and see a small spray coming out as the engine is cranking (be careful with this as these are not appropriate tests and you are dealing with fuel, explosive and dangerous to breathe). Don't crank too much as this can wash the cylinders down. if the cylinders get washed down you will need to put some oil in each cylinder just a little, to rebuild compression. If fuel is present in the cylinders while cranking, and you say you have good fuel pressure then will need to ensure compression and timing, and if all these are good, you will have to check for problems with wiring and electronically controlled grounds, etc. You may want to seek some help on these if you are unsure how to continue on with voltage drop tests, and resistance, but maybe you can. I hope this helps and if you have anymore info on the vehicle like test values etc, or need more help, just post back. good luck

Feb 05, 2010 | 1994 Volvo 850

1 Answer

Odometer does not work


This is a common problem with all models of volvo, with the non digital odometer  pre 1998,, there is a tiny nylon gear deep inside the odometer that needs to be replaced. Your dealer will not fix it, but will put in a new one for you as the cost of fixing in labour is more than a new one,, My solution is much cheeper,, I have
many low milage VOLVO odometer/instr clusters, a few hi'r km 1s


ODOMETERS FROM 1987-PRESENT
I have many pre 1998 Volvo instrument clusters, most with Very low milage, almost all in Km, I have most models of Volvo.

at these prices IT'S A GOOD IDEA TO HAVE AN EXTRA ONE , comes with detailed instructions -with pictures-on how to remove your old one and re-install

just for example
I have 4,, 1994-1997 850/s70/v70 /c70turbo with less than 10,000 km
2 1994-1997 850/s70/v70/c70 non turbo with less than 10,000 km
1 1990 740 -940 turbo with less than 4.000 kms

I also have many Volvo instrument clusters from 1987 to PRESENT with varied milage,,let me know what year and model and milage you are looking for,, I will have something close

WILL SHIP ANYWHERE IN N.AMERICA

Dec 12, 2008 | 1994 Volvo 850

1 Answer

Power loss under load on hills and from take off


The codes stored in the engine computer are needed to further diagnose this problem. To check the codes, go here!

Retrieve the codes in terminal A2. (and A6 if you have a non-turbo)

List the codes here and I can assist you further.

Bret
RepairPal.com

Oct 21, 2008 | 1994 Volvo 850

Not finding what you are looking for?
1994 Volvo 850 Logo

Related Topics:

49 people viewed this question

Ask a Question

Usually answered in minutes!

Top Volvo Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7726 Answers

Are you a Volvo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...