Question about 2003 Land Rover Range Rover

1 Answer

Fan will not blow at high speed? - 2003 Land Rover Range Rover

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 200 Answers

Look for a seperate fuse in the area by the heater motor. Many cars use a seperate circuit for High speed. Usual fuse is in the fuse box for all speeds except High. Larger diameter wire and fuse goes directly to the motor or a relay.Usually in the engine compartment.

Posted on Feb 05, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

In cold temp,heater motor do not run


you mean low heat. at all ducts with full fan speed and blows hard,
here is the correct order.
1: engine at 180F or more holding, a absolute must.
2: fan runs at full speed on HIGH, (sounds like it)
3: fan actual blows (felt) at full speed, to any vent, try all vents.
4: now heat, will happen, if not, the dampers are closed or wrong.
damper can be complex on newer cars,they have motor controlled damper servos';

is this just blower fan dead? problem. on high, if yes say so.

Jan 26, 2014 | 2008 Suzuki Grand Vitara

2 Answers

A t600 kenworth 2000 model the blower motor only blows on high is it the resister


Yes - you diagnosed the problem yourself. The classic symptom of a heater that only blows on the "High" setting is a burned out/damaged or otherwise inoperative blower resistor.
Replacing the resistor should return the two missing blower fan speeds.

Dec 05, 2011 | Cars & Trucks

1 Answer

A/c is cold but the fan is not working to blow it into the car stopped working on high first now will not blow at all


Check your blower motor resistor. It is commonly the part that the blower motor power connector plugs into. It sounds like the high speed element went first and you lost the high fan speed. If the remaining resistor element is broken, the fan will stop working. The resistor only have 2 elements; if they're both broken, it creates an open circuit to the blower.

Jun 24, 2011 | 1996 Mercury Mystique

1 Answer

My ac/heater fan stops blowing then it blows sometimes? The air is still cold just not blowing out. when it does blow it is cold.


replace fan speed resistor block if this only happens on lower fan settings if it happens on high fan speed also, replace blower fan

Jan 20, 2011 | 2001 Isuzu Trooper

1 Answer

1996 Ranger 2wd interior fan blows hi spd only


Possible solution is to check the fan speed switch. These go bad and won't change the speed/ or function in the lower speeds.

Dec 29, 2009 | 1996 Ford Ranger SuperCab

1 Answer

Air conditioner blower only works on high speed


Blowing air at high speed only indicates that the fan controller is dying or the fan itself is dying. Have a mechanic check this out.

Jul 12, 2009 | 2003 Toyota Corolla

1 Answer

A/c blows hot air at idle


u have a trinary type switch on the high side somewhere on the high side,,,it may have 2 or more wires going to it and it is mounted on the high side line/or compressor,this is ur problem

Jul 08, 2009 | 2005 Chevrolet Equinox

1 Answer

2001 Town and Country has only high speed fan both front and back fans. Connector to fan has 12v only on one of the 6 leads. Grounding the lead with the 12v on it turns fan on high speed. Where is...


if the blower only blows on high then it is you blower motor resistor that is located behind the glove box it has two screws that hold it in place

Jun 19, 2009 | 2001 Chrysler Town & Country

1 Answer

Only have 1 speed on HVAC fan


the fan relay(resister) that control fan speed is probably burned out.When this occurs it will only blow at high speed because its getting 12volts directly to the fan

May 25, 2009 | 2004 Pontiac Vibe

2 Answers

Does ac blower have a fan relay ? It doent blow ******* max


if it doesnt work on all speed its the blower motor resistor that broken thanks pierre

Jul 30, 2008 | 1979 Pontiac Firebird

Not finding what you are looking for?
2003 Land Rover Range Rover Logo

Related Topics:

146 people viewed this question

Ask a Question

Usually answered in minutes!

Top Land Rover Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8560 Answers

Are you a Land Rover Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...