Question about 2004 Chevrolet Cavalier

1 Answer

On a 2004 Cavalier when I turn on the wiper full blast it works fine But when its on slow or delay it pulsates and doesn't stop in the proper place.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Chevrolet Master
  • 2,050 Answers

Chances are good that the wiper motor is the issue. The "park" mode for your wipers is controlled by the motor.

Posted on Feb 04, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My windsheild wipers stop in the up position on the delay setting but park all the way down when turned off. How do I fix this


You will need to diagnose this with a multi meter....on dark green terminal d at the wiper pulse board, with the wipers on any delay position, you should be reading .0005 Amps and 12 Volts and at the same time on the delay position one click below low(the fastest delay speed) you should be reading .0003Amps and 12V on terminal E gray wire, The purple wire (terminal C) should have 12V on high speed only. The yellow wire (terminal B) should have 12V when the key is on and the black wire (terminal A) should always be grounded....check all of that and we should be able to find your problem.
The Amperage should change on terminal E (the gray wire) with each position on the switch but the change will be very small. i.e. the first speed (longest delay) will read .000017 A, the second setting .00004 A and so on. Check that and let me know...(by the way, amps are checked in series with the connector so unplug it, place one probe in the connector and the other in the motor plug terminal. )

Sep 30, 2016 | 2004 Pontiac Montana

1 Answer

Passenger Side Windshield Wiper Broken


Hi Jill,
The first thing to check is a 13mm nut that holds the wiper arm in place.See if you can move the wiper arm freely back and forth.There is a nut at the base of that wiper arm,Lift up a cover that is hiding the nut. If it comes loose from being froze from ice or snow. Put the wiper in its rest position and tighten the nut back up.

Feb 06, 2014 | 2004 Chevrolet Cavalier

1 Answer

Drivers side windshield wiper on a 2004 Chevy caviler stopped working,how do i fix it


have to replace the wiper arm.there are splines on the arm that attach it to the stub.most likely stripped out in winter due to frozen windshield.

Jul 28, 2012 | 2004 Chevrolet Cavalier

1 Answer

THe wipers in my 2004 escalade are not functioning


Sounds like one of two things. Either the circuit board on the wiper motor is bad or the switch on the column is bad. Just to let you know GM had a serious issue with the circuit boards on their wiper motors. Might be covered under a recall you can check with the local dealer.

Oct 07, 2009 | 2004 Cadillac Escalade Esv

1 Answer

Windshield wipers slow, then stop working and then come on again


I have a 98 Montero Sport. My wipers paused and went then they stopped completly. Come to find out the grease inside the wiper motor had dried out so I put some grease in it and walla works like new. Better then spending 200 on a new wiper motor ^_^

May 26, 2009 | 2004 Mitsubishi Galant

1 Answer

Intermittent windshield wipers


If it's not the switch, it's the electronic board in the wiper motor. If it's you can pick the board up at The Auto Zone less then at the dealer and they can help you determine if it is the board. Good luck

Apr 08, 2009 | 2003 Chevrolet Cavalier

1 Answer

Delay wipers don't work.


Try making sure the connection is good.
If it is then you should try replacing the wiper switch.


Brandon Bird

Jan 25, 2009 | 1999 Jeep Cherokee

Not finding what you are looking for?
2004 Chevrolet Cavalier Logo

178 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7768 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...