Question about Kia Rio

1 Answer

My car will not start after I get gas and only then. I've never had any other problems with starting the car. I think the car revs up kinda funny like it goes up with out me pushing on the gas and then lowers itself. No one I've taken it to can find the problem.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 204 Answers

Have you replaced the air filter? Or have them look at the bypass air valve.

Posted on Feb 03, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Problem with 1995 chevy blazer


What is the trouble code stored in the computer, and have you checked the idle air control valve ?

Jan 10, 2013 | 1995 Chevrolet Blazer

1 Answer

Sc 400 smoking , runs funny on low revs


Try replacing the Air Control Valve

Jan 09, 2013 | 1992 Lexus Sc 400

1 Answer

89 camry won't rev up


id look into fuel filter or pump may be too weak

Dec 05, 2012 | 1989 Toyota Camry

1 Answer

Oldsmobile alero starting issues


I doubt it is ignition related.
Could be a problem with the idle air control valve or a dirty throttle body.
Could also be a vac leak, or fuel pressure issues.

Jul 13, 2012 | Oldsmobile Alero Cars & Trucks

1 Answer

This is kinda funny please don't judge me I was


This sounds like you may have broken a transmission line or damaged the transmission pan. the oil has leaked out of transmission that is why it will not move,

Do not start car until you have repaired the leak, running the engine will damage the transmission due to low oil in it,

you will need to add 2qts of transmission fluid then jack up the front of the car and look for the leak, if you do not see it then have someone start the car and look, you will be able to see it leak out, i thing it will end up being the pan, good day.

May 18, 2012 | 1997 Ford Taurus

1 Answer

OK so I've had my celica VVTI 140 (W plate) for some time now and have so far (due to crossed wires with my hubby about checking oil) had to have a newer engine fitted, I think this one is about 6 yrs...


Running a gas tank lower than 1/4 level is one of the worst things you can do, since gas acts as a coolant for the fuel pump that is in your gas tank. In addition, if the gas is a dirty as you say, the cumulative deposits have become a sediment in the bottom of the tank and at low levels is no longer suspended in a volume of liquid-which will clog the 'sock' around the base of the pump, and can even clog your fuel filter. I suspect your fuel system will need a good going over-have the fuel pressure checked (simple procedure) and take it from there-good luck

Jun 01, 2011 | 2000 Toyota Celica

1 Answer

My 02 3.1L V6 chevrolet malibu one day started to idle at a higher rpm than it normally did. It happened at around 72XXX and now is just acting funny. i kinda have a clue what it could be but does anyone...


Most likely it is a vacuum leak some where if you have a propane torch do not light it but let the gas flow out slowly as you move it around the engine and if it revs up you have found you leak.

Dec 13, 2010 | 2002 Chevrolet Malibu

1 Answer

Hard starts, rough chugging idle, huge delay from


Sounds like ignition components may need replaced like the coils and wires.

Jul 12, 2010 | 1991 Mercedes-Benz 420

1 Answer

1991 Honda del Sol Overheating and funny idle


The idle problem kinda sounds like the IAC (Idle Air Control) valve on the intake manifold. Another idea is maybe coolant temp. sensor. And if it's leakings coolant still after replacing all those parts then i would say maybe the water pump is leaking since i believe on those motors its by the timing belt which is behind the plastic cover on the motor so maybe that's why you're not seeing fluid so much because it's in there. Hope some of this helpes, good luck.

Nov 04, 2008 | 1994 Honda Civic Del Sol

1 Answer

Check engine light


Go to Autozone and have them scan the engine code. Post what you find. My guess is an O2 sensor.

Jul 14, 2008 | 1999 Honda Civic

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

44 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kia Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Kia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...