Question about 2002 Isuzu Rodeo

2 Answers

When I start driving, the engine revs high and barely goes anywhere. it goes slowly up till 25mph and then is fine. It just started today

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Isuzu Master
  • 14,036 Answers

SOUND LIKE TRANSMISSION SLIPPING.CHECK TRANSMISSION FLUID LEVEL.IF TRANSMISSION FLUID LEVEL OKAY, IF IT HAS BEEN A LONG SINCE FLUID CHANGE.DO A TRANSMISSION FLUID AND FILTER CHANGE SEE IF HELPS PROBLEM.

Posted on Oct 08, 2011

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 24 Answers

I believe '02 rodeo's have buttons for power mode and winter mode located between the shifter and the flip up console.You may have accidentally activated winter mode which cuts power to the drive wheels for driving in ice and snow.If so look on the instrument cluster and "winter mode" will be lit in green,simply push the button again to deactivate it while in PARK.Hope this helps ,good luck.

Posted on Feb 03, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2009 ford mustang v6, standard, will not accelerate, no matter in which gear I am in why?


Sorry old son but your clutch sounds like it has gone to the big junk yard in the sky reserved for dead clutches . When a clutch starts to slip it will continue to do so until that is all it will do . solution a new clutch is required .

Nov 19, 2013 | Cars & Trucks

1 Answer

Ford e-250 transmission problems


My Econoline 250 with 4.2 lost fluid from hose leak, fixed leak everything was normal for 3 days till I drove it on highway. When it went into overdrive lost forward power. Turned off OD and did ok for a while. Lost forward gears slowly, put in fluid, hard to tell when full. Reverse is fine but have to rev up engine to get forward to engage, then everything is fine at lights and such till take out of drive, then have to rev engine to about 2500rpm to engage drive. Help?

Nov 05, 2013 | 1990 Ford F250

1 Answer

I have a 99 chevy malibu with roughlt 220 thousand miles... make a long story short I was in a fender bender at about 25 mph. Minor. Impact front left panel. Completely drivable from the scene. Well I only...


Sounds like maybe a motor mount may have broken,if you
open the hood and put the car in drive ,then neutral then reverse
the engine should only "rock" about an inch or so,if it really jumps
that is the problem.

Feb 26, 2013 | Cars & Trucks

1 Answer

92 accord engine/rpm/lack of power problem


i had the same prob on a toyota check out the fuel presure if its good its prob the fuel regulater i think it should have around 32 psi but call and double check that

Feb 27, 2012 | 1992 Honda Accord

1 Answer

Good afternnon, I have a landrover 110 diesel 1987 the engine wont rev initially but if you hold down the accellerator it will slowly pick up.After engine has reached high revs when you remove your foot...


Its possible the fuel lift pump is faulty. remove the fuel filter, if you see that its half full of fuel, then this will tell you the pump is at fault.
There is a lever on the fuel lift pump, turn the ngine till you feel itgo harder, then feel the travel of the pump and if it is firm or easy to operate.
Lift pump failure is common on these.

Sep 21, 2009 | 1994 Land Rover Defender

1 Answer

Stalls when put into drive on starting


Sounds like their is a vacume leak some where. Try replacing any cracked or broken vacume lines. This should fix ya.

Please contact me if your problem presists.

Thanks, Charlie

Jan 31, 2009 | 1997 Ford Escort

3 Answers

88 Nissan z24i backfires through throttle body and loses power when in gear


Check your intake and exhaust modules. I have a 1987 D21 and had the same problem (if I understand your post). I replaced the modules located behind the driver side headlights and it fixed the problem. Good luck! I hope this helps.

Nov 04, 2008 | 1987 Nissan Pickup

Not finding what you are looking for?
Cars & Trucks Logo

418 people viewed this question

Ask a Question

Usually answered in minutes!

Top Isuzu Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Steve Hurc
Steve Hurc

Level 3 Expert

450 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Are you an Isuzu Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...