Question about 1993 Chevrolet S-10

1 Answer

Ok - 96 S-10 4.3 with the 6 injectors. usually runs great after warm up. If I let the truck sit more than two days, engine cranks but does not start. When it does start and I take off it will sputter a bit until after reaching operating temps. I suspect EGR? Now doesn't start but will crank. Where am I going with this?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 212 Answers

Check fuel pressure to see if fuel pump is working. Can you hear fuel pump cycle when you turn key on? If not fuel pump could be failing.

Posted on Feb 03, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1989 mpv mazda does not start on cold mornings and days


I'm assuming the engine cranks with the starter but does not start and run.

check the operation of the cold start injector. This is a separate fuel injector that injects fuel into the intake manifold to help richen up the mixture for cold starts. It operates on a timer that is linked to a sensor that measures engine coolant temperature. Once warm or the timer runs out, the cold start injector is turned off. Other things to check:

Fuel pressure too high (floods engine through cold start injector), engine coolant temp sensor or intake air temp sensor is stuck at full hot (doesn't allow enough fuel for cold starts), fuel injectors are leaking (floods engine with fuel).

Feb 10, 2011 | 1989 Mazda MPV

1 Answer

Hard to start cold but once running is ok


I believe you have a throtle body correct? IF so you have poor fuel pressure, plugged filter of injector.If by some miracle you have a carberated engine the the fuel is leaking from the bowl. Get a carb rebuild kit.

Aug 23, 2009 | 1987 Chevrolet Blazer

1 Answer

Most of the time it is difficult to start cold,


It is very p0ossible that the fuel system is a little clogged. It happens to all cars eventually especially if you use the cheaper fuels like supermarkets etc.

Anyway, you can try a decent Injector Cleaner and even change the oil but again use a decent Engine Flush. The stuff I use on my own and friends motors is Injection-Correction.co.uk. You can buy it online and it works a treat. Same stuff the prestige garages use...

Usually a dose of this stuff will give the fuel system a good clear out and make it alot easier to start when cold. Starting issues are usueally fuel related or electrical but by the sound of yours it is purely fuel related. Try it out and reap thebenefits.....

Jun 13, 2009 | 1996 Subaru Legacy

2 Answers

Rapid engine mis-fire code


Try changing the ignition control module IF replacing the cranksensor doesn't fix the problem. If the problem still persists check the injectors. They should test at 12V or higher. If they test lower... they need to be replaced. Newer injectors usually sit at around 14V. But start with the crank sensor...sounds stupid and little but it plays a major role in how well the engine runs.

Jan 20, 2009 | 2001 Chevrolet Monte Carlo

1 Answer

I HAVE A 1998 NISSAN MAXIMA ABOUT 120,000 MILES . CAR WILL TRY TO CUT OFF WHEN YOU FIRST CRANK IT, ESPECIALLY WHEN IT IS COLD. SOMETIMES WHEN YOU FIRST CRANK IT , IT WILL TURN RIGHT BACK OFF. ACTS LIKE ITS...


i have a 1998 nissan maxima when the engine is cold the engine will cut off when you first crank it. It will cut off but i can usually get it going the second time. After engine warms up car runs great. Why does this occur

Dec 21, 2008 | 1998 Nissan Maxima

3 Answers

6.6 liter deisel engine will not fire after it is warmed up


heat related issues usually
fuel blockage or electrical resistance to ignitors...run on indicates fuel issues at pressure head not shuttign off fuel.. so check there first...also many related engine management sensors are related to fuel dilvery so get code checked and computer tested/.... good luck

Dec 16, 2008 | 2003 GMC Sierra 2500HD

1 Answer

Starts ok, but if turn of, will not restart


does the spark go at same as injector pulse? let me now and i will try to help worked on these cars from day one

Aug 18, 2017 | 1988 Jaguar Xj Series

Not finding what you are looking for?
1993 Chevrolet S-10 Logo

Related Topics:

77 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8215 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...