Question about 1999 Chevrolet Silverado 1500

2 Answers

1999 Chevy silverado 5.3 engine setting codes p171 p174 already replaced mas air flow and checked for leaks

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 226 Answers

Oxygen sensor failure
P0171 System too Lean (Bank 1) - Read Our Article On Oxygen Sensor Codes For Help With This Generic Check Engine Light Code
P0174 System too Lean (Bank 2) - Read Our Article On Oxygen Sensor Codes For Help With This Generic Check Engine Light Code
hope this is a bit of a push in the right direction ...

Posted on Feb 04, 2010

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 1 Answer

1999 Chevrolet Silverado 5.3L keeps giving codes 171, 174 so we replaced all the O2 sensors still won't run right, then we replaced the mass air sensor, then the map sensor, and still it gives me the same codes over and over and will not run right. It was running down the freeway just fine and then this just started out of the blue with the lean bank in 1 and 2, there is nothing more to replace, and it does not set the code sitting in place and revving the engine, it only acts up when driving or under a load persay. I have been throught the entire fuel management system and replaced every part, so can you please tell which .22 cent part I missed that is causing all this grief to the tune of over 450.00. mjw

Posted on Mar 23, 2010

  • Unk Jim Feb 27, 2011

    I have same problem does any one answer this? ? I am thinking maybe fuel pump . where to find its pressure requirements so I can test it?

  • thomas johnston
    thomas johnston Oct 20, 2013

    u need to get a fuel gauge and put it on the fuel rail nipple it sould be around 50 psi if lower u have a bad fuel pump

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2004 flex fuel tahoe 5.3. P171 and p174. Codes on. Have replaced fuel pump , pressure reg., plugs and fuel filter. Hard to start but runs fine for awhile then starts acting up.


2002 Chevy Tahoe + P0171/P0174 - Chevrolet Forum - Chevy ...

chevroletforum.com > ... > General Discussion Forums > General Tech
Jul 8, 2007 - I have cleaned the MAF sensor, changed the fuel filter, ... I also have a 2002 Tahoe that is posting the p171 and P174 codes and .... I have a 2000 ChevyTahoe with a 5.3L V8. ... That seems normal for the light to go off after running, the IAC motor should have its own fault code, so it may not be that, but not ...Missing: flex

SilveradoSierra.com • P 171, P 174 error code : Vortec 5300 ...

Chevy 5.3 liter lifter noise and motor flush solution How to ...? 14:10https://www.youtube.com/watch?v=4RecrxxLT4sAug 29, 2011 - Uploaded by briansmobile1Chevy 5.3 liter lifter noise and motor flush solution How to .... was there an issue with the oil pressure gauge on the dash? my '04tahoe with the 5.3 when it's .... 2004 chevy suburban1500 5.3Lflex fuel - I followed this but still have the ticking. .... How to jack up your car without jacking up your car - Duration: ...Truck Jerking/Studdering Around 45-50 mph - Ford Truck Enthusiasts ...www.ford-trucks.com > ... > 1997 - 2003 F150Dec 6, 2010 - Right around 45-50 mph, my truck starts to jerk or studder as I attempt to .... the EGR system operation causes very lean air/fuel ratios that requires higher coil voltage to fire. .... 06 f150 5.4 jerking at 45-50, trucks12345, 2004 - 2008 F150, 6 ...1966 - 1977 Early Broncos, Ford Vans and other vehicles, 2014+ ...

Nov 29, 2015 | Cars & Trucks

3 Answers

Changed the mass air sensor and temperature sensor and I have still have codes p171 & p174 on my 96 thunderbird lx hellp


p0171 p0174 indicate lean ...check for vacuum leaks around intake manifold...spray carb cleaner(or brake cleaner if flammable)around intake manifold..if rpm goes up you have a vacuum leak....fix leak ..clear codes and test drive.....at least two drive cycles

Apr 01, 2014 | Cars & Trucks

2 Answers

1999 Chevrolet Silverado, 5.3, 1500, 148K Miles. Problem when cold it has a miss under a load, but it will idle good. After warmed up no problem. After checking for a vacuum leak we replaced the following:...


This is just a stab in the dark, have you checked the hydraulic lifters? I had a similar symptom on a 4 cylinder engine and it turn out to be a stuck valve lifter.

Oct 22, 2013 | 1999 Chevrolet Silverado 1500

2 Answers

99 ford f250 6.8 litre engine i have anti freeze in my two front spark plug ports on the passenger side


could be intake, could be head gasket. take the radiator cap off and fill it to the brim with water, then start the engine and look for bubbles in the water. you might have to top it off while it's running to get a good reading. if any of the plugs you took out were much cleaner than the rest, or had a white crust deposit on them, the head gasket is probably the culprit.

Feb 27, 2013 | Cars & Trucks

2 Answers

Why does my 2001 dodge intrepid shut off while in motion?


po108 check for vaccum leak ,check cracks around engine.check air fiter,mas air flow sensor try to clean,is between air filter and engine.DO NOT DAMEGE,try to remove dirt,spray on it,cleaner.

Feb 07, 2013 | 2001 Dodge Intrepid

1 Answer

Keep getting ses codes p507 p171 p174


The codes you show are all about air leaks. The 507 is about the IAC and may simply be the system noting the connection was unplugged.

The 171,174 are lean codes and usually mean more air is coming in than is needed. Did you use a water mist to check for leaks? Have you checked Vacuum solenoids for leaks?, the EGR diaphram?

You did not indicate the engine and vehicle this problem was on. Some of the 6 cylinder products had sandwich type manifolds and the upper and lower chambers had a gasket which would dissolve and leak internally.

Some people have had problems with the runners on dual plane manifolds, but I question whether a 171, or 174 could generate from this defect.

I think you should retest with a water spray after clearing the computer.

Jan 24, 2012 | Cars & Trucks

1 Answer

Dodge 2004 p171 p174


p0171-- system to lean (bank 1)----p0174-- system to lean (bank 2 ). bank 1 is the side that #1 cylinder is on. bank 2 is the other side. the cause may be bad 02 sensors on both banks, or a exhaust leak. also you may want to check and clean the mass air flow sensor. for the sensor will set the same code as 02 sensors. good-luck!!

Aug 11, 2010 | Dodge Durango Cars & Trucks

2 Answers

99blazer s10 trouble codes p171/p174


P0171 - System Too Lean (Bank 1)
Basically this means that an oxygen sensor in bank 1 detected a lean condition (too much oxygen in the exhaust). On V6/V8/V10 engines, Bank 1 is the side of the engine that has cylinder #1.

A code P0171 may mean that one or more of the following has happened:
  • The MAF (Mass Air Flow) Sensor is dirty or faulty. Note: The use of "oiled" air filters may cause the MAF to become dirty if the filter is over-oiled. There is also an issue with some vehicles where the MAF sensors leak the silicone potting material used to protect the circuitry.
  • There could be a vacuum leak downstream of the MAF sensor.
Possible solutions include:
  • In the vast majority of cases, simply cleaning the MAF sensor does the trick. Consult your service manual for it's location if you need help. I find it's best to take it off and spray it with electronics cleaner or brake cleaner. Make sure you are careful not to damage the MAF sensor, and make sure it's dry before reinstalling
  • Inspect all vacuum and PCV hoses, replace if necessary
  • Check for a dirty fuel filter and proper fuel pressure

P0174 is identical to P0171, except it indicates the problem exists on Bank 2 as well.

Nov 22, 2009 | 1999 Chevrolet S-10 Pickup

1 Answer

Check Engine Light On


have the 02 sensors checked

Jan 20, 2009 | 2001 Ford Explorer

Not finding what you are looking for?
1999 Chevrolet Silverado 1500 Logo

2,044 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7782 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...