Question about 1987 Ford Taurus

1 Answer

My 1987 Ford Taurus 3.0L, AT stalls after it's been running for a little while. Has new fuel pump and filter. Any ideas? partsplusguy

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Ford Master
  • 2,030 Answers

Have you checked the fuel pressure when running?

Is the fuel pressure correct?

Perhaps your fuel pressure regulator is bad, or the fuel pump relay is going bad.

Posted on Feb 02, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2002 taurus 3.0L OHV stalls when hot have replaced IAC,camshaft position sensor,fuel pump and there are no codes on engine stall occurs most often when slowing and turning


If you have to wait to restart its usually a faulty coil or ignition module.
Someone would need to troubleshoot the ignition system when the engine fails to start to proceed. Could be a faulty relay too.

Sep 13, 2012 | 2002 Ford Taurus

1 Answer

I have a 93 ford taurus unstalled a fuel pump & filter it runs then stalls c ant get it to go until it sits for awhile


Sounds like a bad crank sensor to me....probably the original problem instead of the fuel pump.

Jun 02, 2012 | 1993 Ford Taurus

1 Answer

2000 taurus duratec has problems staying running when you first start it.the rpms drop and the car stalls out. i have to give it gas and keep giving gas to keep it running for about 5 min then it runs...


sounds like you are running lean , i would start by changing the fuel filter and check for fuel pressure using a fuel pressure guage at the shrader vavle on your fuel rail, if your fuel pressure is not above 35psi when you cycle your key on and you have changed the fuel filter i would recommend changing the fuel pump,

Dec 15, 2010 | 2000 Ford Taurus

1 Answer

My 1999 Ford Taurus has been sitting for about a year. I just put in a new battery. It is turning over just not starting. I also checked two different spark plugs to see if they were firing and they did....


Try changing the fuel filter first, then listen for the fuel pump running when the key is turned 'on', but not to 'start'. The pump should run for a few moments, then shut off. If it continues to run, then likely the pump is defective and should be replaced. The gas is likely to be 'stale', so the car may be hard starting even after the above is checked and repaired. A little starting fluid in the throttle body might help that. Fill the tank at first opportunity. Hope this helps!

Oct 02, 2010 | 1999 Ford Taurus

2 Answers

Stalls when coming to a stop


Mine stalled when I stopped and it was the Idle Speed Motor. If it only stalls when you stop, I would check that before messing with the fuel filter or pump.

Aug 23, 2010 | 1998 Ford Taurus

1 Answer

Stalling after about 15 - 20 minutes


Change your fuel filter first.
If the problem is still there your fuel pump is going bad.

Aug 11, 2009 | 1987 Ford F 150

1 Answer

Cannot get 1987 chevy van 20 to keep running... stalls out


Best do a fuel pressure test. Should have chg. fuel filter from the get go. The only other filter is on the end of the fuel pump in tank. Bad gas and dirty gas will plug up fuel filter, hense burn pump up.

Apr 11, 2009 | 1987 Chevrolet G20

1 Answer

1987 Buick Lesabre T stalling and running rough


I just had the same problem. Replaced the fuel filter,still crappy idle and no acceleration. I replaced the fump pump along with the wiring harness and the fuel pump screen and my cars purrs like a kitten,has back to normal acceleration and idles better than before. Hope this is some sort of help to you. I did it myself. Total cost, a little over $120. Good luck. By the way, your fuel pump should be pushing out about 65 lbs of pressure. is it ???

Apr 08, 2009 | 1987 Buick LeSabre

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

209 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5474 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...