Question about 2004 Toyota Matrix

2 Answers

What happens when Matrix doesn't accelerate, but sputters slowly? Is it because I put non superior gas in it? or because condensation pools up in the tank when extreme cold? I am in Montreal. I appreciate your answer.

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

In extreme cold dont let your gas tank go below half full. Keep it as full as possible to keep condensation from forming.

Posted on Aug 14, 2010

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

  • Contributor
  • 4 Answers

Hi, The Condensation pulls up in the tank in extreme cold..its because of that it doesnt accelerate and sputters slowly.

Posted on Feb 01, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Acceleration problem


possibly camshaft position sensor in the distributor, or weak fuel fump starts acting up when warm, or throttle position sensor. heat has a effect on sensors and electrical components in some weird and hard to find ways.

Jun 11, 2012 | 1994 Toyota Tercel

1 Answer

My Ford Focus SE sputters when I accelerate. I replaced my spark plugs recently( and not with cheap ones). At times, it doesn't want to accelerate fast then starts to sputter. Any ideas on what it...


what does "not with cheap ones" mean? what did you put in.? Did it run like this before the plugs were changed? If you put some Bosch Platinum plugs in from Autozone take them out and put in the plugs that FORD calls for. You may have created your own problem. are your plug wires good?

Sep 01, 2011 | 2000 Ford Focus

1 Answer

96 prizm stalling at stops. sputtering when accelerating and especialy when not accelerating. If I give it alot of gas it doesn't sputter or jump.


Sounds like your Idle Air Control valve is bad. The IAC valve controls the engine idle speed. The valve is located on the side of the throttle body. This valve allows the necessary amount of air, as determined by the (PCM) and controlled by a duty cycle signal, to bypass the throttle plate in order to maintain the proper idle speed. Good luck!

Jun 12, 2011 | Geo Prizm Cars & Trucks

1 Answer

I have a BMW X5 2005. I have two problems 1 When I try to stick the gas and pass a vehicle on the highway it doesnt have and acceleration its like the vehicle died when i slowly take my foot off the gas...


Your throttle problem is likely due to a bad throttle position sensor, it isn't "reporting" back to the computer of your change in speed correctly.
Doesn't work as in no output, low output, what.

Jun 06, 2011 | BMW X5 Series Cars & Trucks

1 Answer

Sputters when I push down on the gas.


Try replacing plugs, wires, distributor cap and and rotor.

May 17, 2010 | 1994 Chevrolet S-10

1 Answer

My 2001 Nissan Xterra sputtered when accelerating and then would go above 20 miles per hr. i got off the gas and it evened out then i gave it gas again and it accelerated normally. Then about 10 minutes...


Sounds like you have water in the gas. Are you in cold country? The whole country is right now. Anyway, if that is the problem, It could have easily come from the gas station, there tanks condensate too, Get a can of dry gas. If that is not it, get the code checker on there and see what it says, could be an o2 sensor, something in the air horn sensor. a bunch of things most people don't even know exist. hope this helps.

Mar 02, 2010 | Nissan Xterra Cars & Trucks

1 Answer

96 honda civic sputtering now is not accelerating at all


Your timming belt has jumped a tooth.Remove the covers and check that all teeth are ok.Then tighten or change the timming belt.I would fit a new timming belt.Has it is costly when they fail.Good luck.pippall.

Aug 08, 2009 | 1991 Honda Civic

Not finding what you are looking for?
2004 Toyota Matrix Logo

Related Topics:

184 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7782 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...