Question about 1999 BMW 323 Series

1 Answer

Sometimes i get lack of power,this seems tobe intermittent?its as if there is a delay of about 3 seconds,sometimes i smell fuel.ive changed plugs and air filter.please can u help?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 96 Answers

Is the check engine light on?
this could be a number of different sensors(mass air flow, crankshaft position sensor etc), or even a wet ECU.

I have a 99 M3 (new to 400,000 kms), had to change the ECU twice now. ecu compartment gets wet. Wet circuit boards do lots of different things. If you've checked most of the standard stuff plus, coils, check the ECU box area below the windshield passenger side.

mine started with a replacement windshield, grounded off area never retouched with paint and rusted out, water off the windshield drained into the ecu compartrment and soaked the ECU slightly different results when things got wet,

Posted on Feb 04, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What is causing intermittent lack of power?


seems like it's going into limp mode intermittently i would try cleaning crack shaft sensor. or replace.

Apr 05, 2016 | 2003 Hyundai Elantra

1 Answer

Hi. Last August I purchased a 1999 Dodge Caravan with a 3.8 front wheel drive. As of the past few months I have had problems starting it. In the morning it engine cranks hard for about 3 seconds before...


This sounds like an engine temperature, or ambient air temperature, sensor problem.
On a cold start, the computer is supposed to deliver a little more fuel through the injectors, and it sounds like it isn't doing that. When the engine is warm, the computer is supposed to acknowledge that, and adjust the fuel delivery accordingly, but, instead, it is delivering too much fuel, slightly flooding the engine. Hence the hard start, and gas smell.

Have your mechanic check ALL the relevant Engine Temperature Sensors, and All the sensors related to incoming air temperature, and Mass Air Flow, and their related wiring.

Jun 21, 2011 | 1999 Dodge Caravan

2 Answers

2000 Mercury grand marquis has frequent intermittent shuddering, especially going up hill, and stops when ever I let off the gas or give it more gas. Also now it's starting to have delayed downshifts...


These sound like two seperate problems. The first sounds like a clogged fuel filter or faulty fuel pump. The second problem could be a bad transmission filter.

May 28, 2011 | 2000 Mercury Grand Marquis

3 Answers

Lack of power in gas pedal


Check fuel pressure and see if its around 30-35 psi while under load if not replace fuel pump, also the gas thats in the tank may be no good if it has sat for so long..

Jan 05, 2010 | 1989 Oldsmobile Cutlass Ciera

1 Answer

Ive got a ford fiesta zetec s 2001 with a severe lack of power. changed plugs, leads and coil pack. put engine under load and seems as tho theres a air flow problem? nothin coming up on IDS.any...


HERE ARE SOME MORE CAUSES FOR LACK OF POWER.DIRTY AIR FILTER.TRANSMISSION SLIPPING.MANUAL TRANNY CLUTCH SLIPPING.FUEL FILTER CLOGGED.AND RESTRICTED EXHAUST.

Oct 03, 2009 | 2000 Ford Focus

1 Answer

Sputters and lack of power when cold


check transmission fluid.smell burnt change it and filter.stop up transmission cause power lost when engine cold.change fuel filter. check plugs and wires and coils.also do a compression test.to make sure your valves and rings are good.

May 30, 2009 | 1996 Chevrolet Blazer

4 Answers

1983 Mazda RX7 lacks power rough or no idle


Sounds like carb idle air or fuel jets are clogged.. Test pressure with a gauge to be sure. Float level and drop needs to be exact.. Operation of the whole carb relies on this. Probably why you are not getting any change in your air/fuel adjustments.

Apr 22, 2009 | 1983 Mazda RX-7

1 Answer

2000 SS camaro lacking power producing overwhelming exhaust


did you put the platinum plugs back in.get a noid light test the injector wires make sure they are working . when you hook noid light up these should have a steady blink .if light dont blink just light up.you got pcm problems .if you get no lights you have open wire.besure to check ignition coils that control those misfiring cylinders.

Feb 23, 2009 | 2000 Chevrolet Camaro

Not finding what you are looking for?
1999 BMW 323 Series Logo

Related Topics:

105 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Frankie B

Level 2 Expert

65 Answers

Fred Sops

Level 2 Expert

272 Answers

Doberman

Level 2 Expert

254 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...