Question about 2000 Ford Econoline

1 Answer

2000 ford econoline 7.3l diesel,when idle its ok but as soon as you drive for 3minutes its shakes,miss and stall.and then you have to wait for 10-15 minutes to start it

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers

Replace your fuel filter.

Posted on Dec 13, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Misses when in drive and shakes a little when idleing what might it be ?


Make sure that all the spark plugs are firing Could be a bad plug or high tension lead

Apr 18, 2016 | Ford Cars & Trucks

2 Answers

Motor shakes very bad


-Sounds like blow head gasket, broken or burn valve.
-Do compression check each cylinder to see what you have and compare to its specification.
Or
-Was it recently rebuild?
If so then timing might be off.
spark plug wire connect to the wrong spark plug.
Vacuum line might connect to the wrong line.
Bad rotor or cap .

Good luck

Mai

Nov 27, 2017 | 2000 Ford Mustang

1 Answer

My 2000 Ford Ranger suddenly started idling really rough (like it wants to stall) and also shakes really bad at 40 mph. It also shakes the truck while driving, but not as bad as at idle or 40mph. No e


First question is - is the check engine light on ?
If so you need to start with the trouble codes in the computer.
Could be a faulty injector or coil among other things.
You should have a codes for which cylinder is not firing and other possible problems.

Sep 15, 2012 | Ford Ranger Cars & Trucks

2 Answers

Once started, the engine stalls on my 99 Ford E150 Econoline V8. If I hold down the accelerator, the engine runs fine. By the way, it is cold outside too.


check the air bypass valve on the throttlebody at the air inlet try tapping on it and see if it will idle ok

Dec 07, 2009 | 1999 Ford Econoline

1 Answer

Cannot locate cam sensor


The cam sensor is located on the cam cover.It sounds unlikly thats your problem.Try changing the mass air flow meter.

Jul 09, 2009 | 2000 Saturn SL

3 Answers

2000 ford explorer 4.0 x-engine is stalling, missing and lose power while driving


I personally would check the fuel pressure. Then I would go back to the coil. I have seen brand new bad coils out of the box. The symptoms of a loss of power point to this component, especially if the car idles well, but loses power when accelerating. Please do not rate this reply - we all are left to grasp at straws since you have changed pretty much everything. Good Luck. Please post the final fix of the problem.

Oct 15, 2008 | 2000 Ford Explorer

Not finding what you are looking for?
2000 Ford Econoline Logo

Related Topics:

81 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

Marvin
Marvin

Level 3 Expert

83096 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22382 Answers

gerry bissi

Level 3 Expert

4387 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...