Question about 1997 Chevrolet Blazer

2 Answers

I Just replaced the motor with a used one. Run's great, except at take off from a stop it seem's to miss. Once the RPM comes up it run's great.???????????? The used motor was rebuilt, apperantly with a performance cam. Did a diagnoses check and came up with code P 1345 crank sensor, replaced, did not help. Any idea's??

Posted by on

  • 39hudson Dec 12, 2009

    No, still the same code. Maybe a bad wire by the sensor?

  • Mark Egan May 11, 2010

    Any new codes since replacing the crank sensor?

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 2,359 Answers

Performance cam will deliver more power.

More power equal more AIR and FUEL.

Can you go back to the same yard to pull the fuel pump,fuel injectors,fuel regulator?

===

Check for vacuum hose leak.

Check for intake manifold leak.

===

Back track and check for the cam requirement.

Is it come in a FULL KIT?

===

Posted on Dec 12, 2009

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 117 Answers

Usually when the crank sensor goes out the engine wont run at all cause the computer does not know when to fire the plugs or the injectors. I would find out what size cam is in the engine because the calibration could be wrong in the computer for a large cam. Also it sounds like it is either not enough or too much fuel present during take off.

Posted on Dec 12, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What might be causing the problem listed below?


Could be bad ignition module as they have a low rpm section and a high rpm section. Low side may be failing as it heats up. Hard to test for this as parts store testers may not see the problem.

Jun 26, 2015 | Cars & Trucks

3 Answers

High idle unless driving in gear, but if clutch is pushed in or car is in neutral rpm goes up to 2900


run fault codes to check for accelerator position sensor problems . Check for vacuum leaks. If cable accelerator then check that the return spring on the end of the cable is attached and not missing.

Feb 14, 2014 | 2004 Subaru Outback

1 Answer

High idle, and engine misses


could be a spark plug or plug boot, depending on the last time they were replace i would recommend replacing them all.

Nov 19, 2012 | 1994 Toyota Pickup

1 Answer

2000 chevy blazer -starts great-idles great when after start in idle-misses when accelorating until shift-then misses occasionally until it warms up-then runs perfrct at any rpm-continues to run perfect...


check see if one of the coil packs have a crack in it. if so replace it if you start the car in the dark with hood poped the crack will show right now looks like a light show

Aug 02, 2011 | 2000 Chevrolet Blazer

1 Answer

My heater blower comes on a long while after I turn in on. Sometimes it doesn't come on and sometimes it does. Everything else works well except for this The blower works great too when it runs.


could be the blower motor itself. if you are handy with a voltmeter, you can check to see if the blower motor is getting power while the switch is on. if it gets power and doesn't run, there's your problem. sometimes electric motors have a tendency when they are failing to come and go, working fine once they get going. its the getting it started from a stop that can be the problem.

Feb 19, 2010 | 1998 Buick LeSabre

3 Answers

2000 Ranger 4.0 Automatic 4x4 will not idle up at


Have you tried cleaning the throttle plates and idle air control motor

Nov 26, 2009 | 2000 Ford Ranger SuperCab

4 Answers

I have a 572 crate motor 620hp. Car runs great on highway.But if i get at low rpm or traffic and come to stop car wants to stall. Seems like carb is problem . I see you changed to holleys Why? Is this a...


Try setting the idle speed up a little--the racing cam in this engine will not allow idle very well at best. An improvement in the ignition system performance will help starting. This engine wasn't made to poop around in traffic.

Sep 07, 2009 | Chevrolet Chevy Cars & Trucks

Not finding what you are looking for?
1997 Chevrolet Blazer Logo

70 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

79865 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...