Question about 2000 GMC Sierra

1 Answer

I replaced my fuel pump and sending unit and it seems that it is not powering up. i checked the fuses and they are good. the truck will not start. what else can i test?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • GMC Master
  • 5,763 Answers

Gm had aproblem with the harness plug to fuelpump, did you check plug for melted connections, also check crank sensor ,if it doesnt give computer a signal then computer wont power up pump. also if theres a chip in key try a spare key, start there, good luck hope this helps.

Posted on Dec 12, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where is ecm on 95 gmc jimmy


The ECM on the jimmy, is located on the passenger side fender well by the overflow tank. But before replace the ECM, inspect the fuel pump and fuel pump relay. The ECM sends power to the fuel pump relay and if the relay has gone bad will cause the fuse to blow which will kill the the power to the ECM, in turn kill the electrical power to the ignition system.

Start by removing the fuel pump relay and swap it with another relay and see if the fuse will blow again, if is does. Disconnect the fuel sending unit wire harness at the frame and see if the fuse blows again, if the fuse stays good. Chances are your fuel pump has gone bad or the fuel filter is dirty/clogged causing your fuel pump to draw more amp and will need to be replaced or the wire harness from the frame to the sending unit has a short which is common on older Jimmy's.

Here is a link to the electrical harness throughout the Jimmy.
http://www.compnine.com/index.php?t=...lid=6872&uid=1

Mar 06, 2014 | 1988 Mazda B2200

1 Answer

96 chevy k1500 5.7 runs good starts hard, turn it over and it wont start if i bump the starter a couple of times it will start then run good and will start no problem if it does not sit for a long period...


The problem on your vehicle is much more likely to be the oil pressure sending unit ore the fuel pump relay . The way the systems works is the fuel pump is supplyed by the fuse box fuse #9 but the cirrcuit splits and goes to the oil pressure sending unit in case the relay fails when your drivering the fuel pump will still have a power supply its stupid but its a safty thing that was mandated. If the fuel relay is NG the vehicle will still start but it takes the engine some time to build up enough oil pressure to trip the switch inside the sending unit to send volatge to the starter . Witch means slow starts long cranking times I would check the fuel filter first but realsticly if you don't know if the fuel pump has been replaced or you haven't done it your self this is vary likely the cause of the problem . If you have then try the oil pressure unit

Jul 23, 2011 | 1996 Chevrolet K1500

6 Answers

No power to fuel pump


when u checked this u do realize the fuel pump only has 12 volts for 1 second then the computer turns it off unless the engine is started? let me know.

Dec 03, 2009 | 1997 Dodge Ram 1500 Club Cab

1 Answer

Replaced fuel pump, pump wiring harness, fuel


Fuel Pump RELAY & FUSE CHECKED & DO you Have POWER "TO" Fuel Pump ? ALSO OIL Sending Unit Supplys the GROUND To Fuel Pump , This is A Saftey FEATURE that Shuts Down Fuel If ENGINE Looses OIL PRESSURE . And If This OIL Sending Unit or also Called (OIL PRESSURE SENSOR) << If It FAILS it WILL Cause What Seems Like A Fue Pump Problem But Is Rally Just The Sensor that is BAD. HOPE this Sheds Light on Your Problem !

Sep 30, 2009 | 1994 Buick Roadmaster

2 Answers

My corvette doesnt want to start because theres no power going to the fuel pump fuse.


I am looking at alldata , the schematics for the fuel system. I see a fuse in the fuse block(10 amp) that comes from the fuel pump relay to the pump. I see a fuseable link (link H)that goes through a oil pressure sending unit. I would get a test light and test the oil pressure sending unit, the inline fuseable link and the relay. If still no power check the connection at the pump and then work backwards testing the harness.

May 27, 2009 | 1985 Chevrolet Corvette

1 Answer

Buick Regal dying


You have a problem in the fuel pump relay circuit for sure then. I'm betting the relay, but it could be that dropping resistor.

May 11, 2009 | 2000 Buick Regal

1 Answer

New relay an new fuel pump no fire goin to fuel pump


Check fuel pump fuse, remember fuse send power to relay and relay sends power to pump, Check power wires to pump and make sure FUEL PUMP FUSE IS GOOD if not replace and take care of this problem. Good luck and thanks for using FIX YA.

Mar 25, 2009 | 1990 Ford F150

4 Answers

Chevy s10 pickup fuel pump does not work


i have a 98 chevy s10 zr2 and we changed the fuel pump and aint gettin no power to the fuel pump checked the fuses and relay under the hood no power and the gauges inside are not working other than lightin up.are there another fuse link some where

Mar 18, 2009 | 1999 Chevrolet S-10 Pickup

1 Answer

1987 chevy r10 won't start


Assuming it is a fuel problem I checked at the carb. to be sure no gas was being pumped through the filter located under the power steering pump then the fuse on my 87 s10 was the ECM fuse.then check for the relay to click and the had to replace the oil pressure sending unit and mine started right up..the oil pressure must be about 4 lbs for the Pump tp operate...I loosened the fuel line to ck. for fuel but thats living dangerously...a pressure guage would be on the safe side......

Aug 19, 2008 | 1987 Chevrolet R10

Not finding what you are looking for?
2000 GMC Sierra Logo

Related Topics:

106 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

Marvin
Marvin

Level 3 Expert

82149 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22382 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...