Question about 2002 Ford Escort

1 Answer

Whilst driving today my ford puma suddenly felt and sounded unhealthy it was suddering i was low on petrol thought it was that filled up still felt bad then my engine light started flashing , I got home checked oil and water they were low so filled them up but engine light stayed on car still felt juttery and there seems to be a clicking sound coming from exghaust area, my cars on a 02 plate and i had a new clutch done 12 month ago any help with be much appreciated thankyou ..(.please note my cars a puma but it wasnt on the list for products so i had to put something)

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Ford Expert
  • 279 Answers

Check the ht leads and the coil pack and also get it plugged in to a fault code reader to find out why engine light is on

Posted on Dec 12, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Jetta 3 cli fuel system dirt in tank


Add 2 bottles of "heet" to your gas tank...also add 1 to 2 bottles of injector and gas system cleaner...good to remember this lesson of when not to buy gas...::( Hope this helps.

Jan 17, 2014 | Cars & Trucks

2 Answers

Hi i am having trouble finding the speed sensors on my 1991 legacy, i think that is what might be causing the shuddering when i am driving, does anyone knoe if that mighjt be the case thans


Possible that the fault is relative of problems in the differential drive or the drive shaft. It is possible that the propeller shaft is bend or has a faulty universal joint which seems to go eccentric. If the rear wheel are jacked up and if you can check the bearings on the wheels and the drive shaft it will be noticed that there is some play or off movement. If so the section from the shaft to the differential must be checked. remove the propeller shaft, somtimes it needs to be checked in a lathe bed. Also check for low transmission fluid in the differential. A possible bearing issue within the gear box output drive shaft must also be confirmed.

Nov 21, 2011 | 1991 Subaru Legacy

1 Answer

Eingine broken


hi could you please give some more info as engine broken ? does not help what happened ? is engine petrol? or diesel? milage ? did car suddenly stop whilst driving? any noises from engine b4 it brokedown ? is oil and coolant levels ok ?

Mar 09, 2010 | 1996 Ford Windstar

1 Answer

I have a 1989 jeep wrangler. yesterday, after the stick shift felt stiff to shift, the clutch felt suddenly loose. Today, the stick shift stopped moving completely while i was driving. Finally, I was able...


Sounds like you are having a clutch problem. The sudden looseness in the clutch pedal indicates a problem with either the hydralic system, (slave or master or line) leaking or clutch pressure plate going out. Check your clutch fluid resevoir first, if low look for a leak under the vehicle, have a friend push the clutch and get underneath to find leak.

Jan 10, 2010 | 1989 Jeep Wrangler

1 Answer

2000reg ford focus holding back.


check the fuel pump and the fuel filter.

Aug 24, 2009 | 2000 Ford Focus

1 Answer

It felt like I had run out of petrol,It was very low.I filled up but now i go a few metres then it cuts out again.


sounds like a possible fuel pump could be a clogged fuel filter as well try the filter first.

Mar 07, 2009 | 1993 Toyota 4Runner

1 Answer

Lacetti Chevrolet. Malfunction Indicator light is on.


It may be the same problem as my 56 plate Lacetti. The yellow malfunction light came on two weeks ago and two days ago, both times shortly after filling up with petrol to the brim, and I suspect it is the petrol sensor as I only clicked the petrol cap once after fitting it back - the handbook says click it several times. The yellow light also came on yesterday after taking the car a short journey so it is likely that the sensor is still picking up a small escape of petrol, but the car has been fine today with no light appearing now that the fuel level has dropped a bit. Like you, I have not noticed any drop in power with the light on.

Dec 29, 2008 | Daewoo Korando Cars & Trucks

1 Answer

Toyota rav4 1996, 2.0l petrol


Welcome to FIXa

Sounds like the drivetrain is slipping best bet might be to take it to a garage sorry but thats what it sounds like

have a good day :)

Jun 21, 2008 | 1996 Toyota RAV4

2 Answers

Ford Puma cutting out


sensor ,go to ford garage

Jun 06, 2008 | 1998 Ford Escort

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

266 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

Marvin
Marvin

Level 3 Expert

83096 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22382 Answers

gerry bissi

Level 3 Expert

4387 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...