Question about 1987 Chevrolet S-10 Pickup

2 Answers

Need 2 know what could be wrong with the motor! it is timed right but still runs rough! all sensors r new new cap rotor and plugs and wires!

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Have you checked for Vaccum hose leaks?

Posted on Dec 10, 2009

  • aocomp
    aocomp Apr 09, 2012

    a vacuum gauge will let you know many things... bad valve timing, vac leak, etc..
    carb cleaner could be used to find a vac leak, if running rough, might die when leak is found.

×

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 2,359 Answers

Advance it by 1/2 to 1 degree.

The time chain can expand after so many miles.


====

You will have vacuum leak on the intake manifold.
Check when it was changed. 100K

====

Have to check the compression across all the cyclinders?

What is the compression reading?


Please post more information so I can give you a better answer.

Posted on Dec 10, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 99 Durango 5.9 rpm goes up and down rep. Crsen wires plugs cap rotor bug still runs really rough


Check to see if all the vacuum hoses are connected to the right source.
Regards
Sir Dana

Apr 27, 2017 | Dodge Cars & Trucks

1 Answer

Just put new wires cap rotor and plugs now runs really bad?


Sometimes the rotor button contact slips off the cap when you put it on. Check that and also if you have gotten anything inside the cap causing a cross fire. Most importantly!!!! Did you happen to cross any wires? Thought I had them on right but had 2 on wrong cap contact..lol.. ran but rough. Also just thought of the plug gap. Hope this helps without me looking at it. Good Luck.

Apr 19, 2015 | Cars & Trucks

2 Answers

1990 geo storm sohc is running rough. Parts that are new: cap, rotor, plugs wires,plugs, pickup coil, and the ignition module looks brand new. The coil is old, but is still sending spark through all the...


I would look into replacing the coil even though it is sending spark it might not be enough and I would go through and just double check all my wires as well as the firing order because if it's off just a little it will make the car run rough

Nov 06, 2014 | 1990 Geo Storm

3 Answers

My 94 Toyota Camry 4 cyl is running really rough and stalling out once the engine warms up


1. Error Code 24. Intake Air Temperature Sensor.
Solution:
Check the following:
- IAT Connector and wiring.
- Intake Air Temperature Sensor.
- Engine Coolant Temperature Sensor.
- ECM.
2. Rough Idling when the engine is hot.
The following are the reasons due to which the engine can perform bad when it is hot.
- Fuel pump control circuit.
- Fuel pump pressure.
- Fuel injectors.
- Non Return Valve clogged, located on the lower side of car chassis above the fuel tank.
- Engine compression, valve clearance, spark plugs.

Apr 14, 2014 | 1994 Toyota Camry

2 Answers

Ford 1981 f 150 not running changed Coil distributor cap Roar arm plug wires did not help started bur ran extremely rough then died


motors need 3 things to run properly. gas spark and compression. the starting point. also spark timing.
the motor you are dealing with is easy. i just rebult a 1978. anyways sounds like a timing problem . first i would check the distributer. if all is ok spay a squirt of starting fluid in the air filter, or even wd40.,,,,,,,see if it is gasoline problem. isolate where the problem is.

Aug 29, 2017 | Ford Cars & Trucks

1 Answer

Check engine light is on, emmissions said o2 sensor out replaced sensor replaced plugs,rotor ,cap and wires still idels rough and floods


95 16v ?
what DTC, post DTC? why skip that,... there are many 02 DTC.
most fail for heater, dead,
lets play a game. say;
1: CEL out running, is it , now?
2: you did the 60k by the book, did you? if not why not?
3: checked spark timing, its good, not way off, is it?
the 60k requires a new Timing belt, ever check that, or the timing of the cam? or compression, if not why not.?
no motor can run right with all or any of those stated items bad.
is the fuel filter packed up. 60k.
lets now pretend the 60k was done and done right.
click 60k here
http://www.fixkick.com/IGN_timing/tune-ups.html

"what can make my 95 very rich?,"
Ill pretend it's a MPI 16v engine, not TBI. big differences that.
The 16v has 4 injectors, quad trouble !
rich? you never said under what conditions, hot or cold?
ill pretend, its all the time. rich. not just cold or hot.
1: engine never reaches 180F and holds there (miniumum)
does it? if not it will run rich forever. the ECU thinks its cold all the time and guess what it is.
2: Exhaust cracks, near the 02 sensors, making said sensor useless (new or old)
3: fuel pressure not near 30psi ($20 gage) found at 60. opps. bad.
4: leaking injectors.
5: clogged injectors, (seems odd but is true) ask.(complex)
there is an order to finding this.
ask for detailed help here, totally free.
http://www.fixkick.com/bbs2/Suzuki-bbs/

Feb 18, 2013 | 1995 Geo Tracker

1 Answer

1993 c1500 runs rough right above idle


Check the throttle position sensor (TPS) and system vacuum.

Jan 22, 2018 | 1993 Chevrolet C1500

1 Answer

Running rough ,no power back fires sometimes while exceleration. new plugs,plug wires ,cap,rotor,o2 sensor, fuel filter firing order is right ...


Check Alternator for bad diodes and A/C output,
you shouldn't have

Check fuel pump--with a scope, to see if that
is getting ready to fail

Exhaust Converter- most likely clogged,thus
no power & all the other issues

Timing Chain --loose ?
Rock crank back and forth
Check timing with light, half way thru
firing order,should be same as on #1

Feb 22, 2011 | 1990 Cadillac SeVille

2 Answers

Wires our in the right order. could timing have jumped if so how do i set it


What were you doing to the plugs and wires????? I need a little more information before i can tell you anything else. Like did you pull the motor, etc.

Feb 07, 2010 | 1993 Lexus Ls 400

1 Answer

95 GMC Jimmy 4.3l W vin rough idle


My problem was solved when I repaired my 4 wd activation dash switch. The switch was contacting on 2WD & 4HI at the same time. The front differential activation is vacuum activated possibly creating a tug of war that didn't actually engage it but drained off vacuum from the engine? A theory at best but stumbbled across it because I knew the switch wasn't working properly I repaired it and low and behold rough idle disappeared and all is good for 3 weeks running.

Nov 17, 2008 | 1995 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

59 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

83593 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22393 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...