Question about 1983 Ford Ranger

1 Answer

On acceleration it it misses through 1st 2nd 3rd gear.......runs better when cold... might be egr... disconnected the hose to valve.. still lacks power... put new carb gaskets... thought there might be a vacuum leak... it just jerks you off on acceleration... thanks.......mario.... fresno ca.....

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 14 Answers

Sound slike some of the things you mentioned, could likely be causeing the problem. A vaccum leak would steal from the acceleration. also the EGR. You may just need a tune up. New plug, wires, filters, the whole deal.

Posted on Nov 20, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Dodge Ram 3500 skips from 1st to 3rd gear, had rebuild after still the same issue. Any advice?


Governor pressure controls the 1st and 2nd shifts. After that is the 3 and 4 solenoids. you would need to look at the pressure when driving(takes a scanner). pressure is 20 to 30 PSI from 1st to 2nd, depends on acceleration. After that the pressure will jump to 100+ psi. Did you replace the governor solenoid and sensor? They are on the passenger side of the transmission and sit in a block that detaches from the valve body.

Sep 22, 2016 | 2005 Dodge Ram 3500

1 Answer

Where is the pcv valve located on a chrysler 300


Here is the info you need. Notice the numbers in the image are the steps in which you should take 1st, 2nd, 3rd etc

24580049-jq13pypi3egybe0aho3o0ljx-4-2.gif
Disconnect the EGR tube, PCV, Purge and power brake booster vacuum hoses from the upper intake manifold
Re-Install is basically the same procedure just reversed.
  1. Connect the EGR tube, PCV, Purge and power brake booster vacuum hoses to the intake manifold.
Please let us know if you need further/ more detailed info.
Regards,
-Tim

Jun 05, 2014 | 2007 Chrysler 300 AWD Sedan

2 Answers

C-4 transmission slides between 2nd and 3rd under light acceleration


Is it over filled?

You cold try cleaning the valve body

I guess you have a modulator,is that
leaking fluid,pull of vacuum hose & check

Nov 30, 2012 | 1966 Ford Mustang

1 Answer

Heres the symptoms : engages but slips in reverse and drive, sometimes feels like partial brake applied. I have manual 1st and 2nd. When engaged in drive, you turn off overdrive and you can spin the...


it may be a bad transmission modulator valve located on the side of your transmission,vacum operated. a sudden downshift or forward shift when unexpected is sign of a bad modulator valve or a vacum leak to the transmission.best to shop around for a garage w/references when it comes to transmission work though. check all the vacum lines to your transmision,you need to look on the underneath side of your truck on the side of transmission for a loose or disconnected vacum line on the side of the transmission. when you feel the vacum line,follow it to the top of engine,the vacum line is about 3/8th line,and may be disconnected or losing air. to make this short,when you drive the car,start out in low gear and shift the transmission,manually from 1st to 2nd to 3rd does it do right with no slipping? if it does this right and shifts great manually,the modulator valve on the side of the transmissions bad,or a bad vacum leak in-between.thank you for choosing fixya.com

Apr 09, 2011 | 1998 Ford Explorer

1 Answer

Hi, I have a ford Mondeo duratec diesel 2.0l 2001 reg. I had the misfortune of hitting a bad flood during the heavy rain back in November last, bent a conrod etc. Got all fixed had the car back a few hours...


Hi Tom, Sounds like your car may be running in limp mode. might be worth a diagnostic check and clear any codes and get them reset. Hope this works.

Mar 12, 2010 | 2001 Ford Focus

6 Answers

Jag X TYPE Diesel Black smoke coming from exhaust on acceleration


i had this problem and thought the fuel filter oil filter needed replacing so i have just had a service done but problem is still there but not as bad. been told it could be the AGR valve or a split pipe going to it which recuirculates unused fuel back to burn again. therefore unspent fuel is coming out of the exhaust causing the black smoke. i am still looking for the answer aswell, hope this helps.

Nov 07, 2009 | 2004 Jaguar X-Type

2 Answers

95 GMC Jimmy 4L60E no 2nd or OD 4L60E


do u have any trouble codes for the trans? u need to find out to see if a shift solenoid (possible 2-3) has failed.

Apr 15, 2009 | 1994 Pontiac Firebird

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

187 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5501 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...