Question about 2004 GMC Sierra 1500 Crew Cab

1 Answer

Idle problem when brakes applied

2004 Sierra 1500 V8 5.3 vortic - idling well when cold at approx 1000 rpm. Once it is warm idel drops to between 500-800 rpm excelling not a problem, but when I apply the brake the RPM drops to 0 and engine stalls.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 172 Answers

Sounds like you have a vacume leak on your brake booster ....with engine running have someone press the brake while you listen on the driver side by the master cylinder the large vacume line going to the booster behind the master cylinder is most likely the vacume leak...and if so you can get what you need at your local parts store ...

Posted on Nov 20, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1997 acura cl 2.2 revs up to 1500 rpm and down to 1000 rpm just several seconds after start


Cars are design to run at a higher idle at start up to warm them up quick. There is a sensor that reads water temperature and tells your car's computer how fast to idle. Your RPMs seem slightly high but not out of the norm. Does idle ever drop to around 600/800 after about a minute? If not, your engine temperature sensor maybe defective.

Mar 16, 2014 | Acura Cars & Trucks

1 Answer

96 RS Camaro High Idle on Cold Start.


you prob need a coolant temp sensor

Oct 30, 2009 | 1996 Chevrolet Camaro

1 Answer

When started idels high about 2000 rpm then drops when hot cold ?


the iac probably has carbon built up around it this controls the idle speed try cleaning it first,if not it could be a bad iac or a vaccum leak that the iac takes some time to compensate for to control idle.

Sep 17, 2009 | 2002 Jeep Wrangler

1 Answer

Ideling 1600 rpm onlywhen engine warm


please change the idling switch control valve assembly plus the sensor!

Jun 18, 2009 | Mercedes-Benz SL-Class Cars & Trucks

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

365 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...