Question about 1998 Lincoln Town Car

1 Answer

The steering wheel controls ie. cruise/radio/temp dont work as well as the horn doesnt function

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Lincoln Master
  • 75,817 Answers

In most cases this problem is caused by the rotating ribbon circuit contact under the steering wheel having a broken filament, the part is known as a clock spring contact, u will need to properly disarm the airbag and remove the steering wheel to access the part. WARNING: Failure to follow factory Airbag disarming protocol can result in an unexpected Airbag deployment and possible serious personnel injury or death.

Posted on Nov 19, 2009

Testimonial: "Thank you very much emissionswiz...I am confident you know what you're talking about, and even more confident I can't do the work myself! "

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My horn isn't working on a Chevy equinox but it's a new horn. What could be wrong with it..and my cruise control don't qork. Is it my steering wheel?


Was Cruise Control working before the New Horn was installed? The power supply to the Horn, (input to ground wire) is connected to the Cruise Control Module (CCM). This CCM is wired to the Relay Switch Box located in the Engine Bay. The Relay Box cover will have a Chart indicating what function each Relay coresponds to. Your local autoparts store (AutoZone) can test the Relay Switch, and you'll know (if any Relay) need to be replaced.

The CCM is also wired to the Steering Wheel, but first passes through the Clock Spring Coil, located just behind the Steering Wheel. The Clock Spring allowes for the Function Buttons on the Steering Wheel to have power while Steering Wheel spins.

The Clock Spring can malfunction or break, its rare, but this will cut power to the Function Buttons on Steering Wheel. If ALL the buttons on Steering Wheel dont work, then the Clock Spring is the Culprit. The Coil may need to be replaced.

The Cruise Control Module itself may have failed and also would cause a few or all Steering Wheel Functions to quit working.

But first check the Relay Switch Box and examine the Harness Cables connecting (Steering Wheel--to--CCM--to--Relay Switch Box--to--Battery Supply).

Also if Cruise Control was working before the new Horn was installed and now not working, then most likely the Problem is a bad wire connection somewhere and/or is a faulty Relay.

(Any Questions/comments jtobias1020@gmail.com)

Feb 26, 2017 | Chevrolet Equinox Cars & Trucks

1 Answer

I have a 2009 Mazda 5 and my horn or ruise control buttons on steering wheel doesnt work the radio cotrold work from left side of steering wheel but cruise and horn wont?


More then likely the coiled ribbon electrical contact under the steering wheel is defective, it is called the "clockspring" contact.

Jan 09, 2017 | 2009 Mazda MAZDA5

1 Answer

MY LOW BEAM LIGHTS, BREAK LIGHTS AND RADIO SOUND CONTROL ON STEERING WHEEL, ALL STOPPED WOKING


Steering wheel radio controls and horn not working - Jeep Wrangler ...

www.wranglerforum.com/.../steering-wheel-radio-controls-and-horn-not...

Sep 22, 2014 - 12 posts - ‎6 authors
... 2Dr sport and my step/reset buttons, radio control and horn all stopped working. ... Also the lights behind the step/reset and cruise control went out, but the ... Soundslike a bad clock spring ribbon cable in the steering wheel. steering wheel buttons not working
30 posts
Jun 14, 2012
Steering wheel audio controls
30 posts
Mar 5, 2011
More results from www.wranglerforum.com

Nov 23, 2015 | Cars & Trucks

1 Answer

Cruise radio and heater functions dont work but horn does on 04 ford king ranch


you may be facing a prolem wiht your spiral cable, this carries signals from your swithes to a body ecu or else, have your truck been in an accident and air bag deployed? if yes, then this is your most possible cause.

Apr 21, 2012 | Cars & Trucks

1 Answer

Steering wheel controls ie: radio controls, horn and cruise control only work occassionally


It sounds like the steering wheel needs to be removed and the rotator joint needs to be cleaned or replaced. I would not advise trying it myself because of the airbag.

Feb 22, 2011 | 2000 Jeep Grand Cherokee

1 Answer

How do i replace the cruise control on/off switch on my 1999 alero


TO REMOVE CRUISE CONTROL SWITCH. FIRST TURN OFF RADIO TO KEEP FROM LOSING CODE. DISARM AIRBAG IN THE STEERING WHEEL BY REMOVING NEGATIVE BATTERY CABLE WAIT 20 MINUTES FOR AIRBAG TO DISCHARGE BEFORE REMOVING AIRBAG AND HORN PAD IN STEERING WHEEL.ONCE AIRBAG IN STEERING WHEEL OUT.YOU CAN REMOVE THE CRUISE CONTROL SWITCH.BECAREFUL REMOVING AIRBAG IN STEERING WHEEL CARRY IT AWAY FROM BODY WITH AIRBAG HORN PAD POINTING UP.IF YOU DROP IT.DONT PUT IN BACK IN STEERING COULD DEPLOY ON INSTALLATION.

Nov 14, 2010 | 1999 Oldsmobile Alero

1 Answer

Horn and steering wheel functions not working


could be a bad clocksping the airbag is on it to but one of the thin film "wires" that are glued to it may have cracked.all the switches are on one "wire" the resistance of each switch is how the body control computer knows what button is pushed. i broke one of those clocksprings accidently when i worked at volvo so thats how i know those things are/were 1400.00$ i would take it to the dealer to have them diagnose and repair. the clock spring breaks real easy when you take off the steering wheel.

Apr 24, 2010 | 2003 Volvo XC90

1 Answer

I lost all power to the steering wheel components,


Your issue is most likely the clock spring which is part of the air bag system.

All of the signals controlling these functions are routed through the clock spring.

Should cost around 200-300 to have it done, or more like 100-150 if you do it yourself. You must know what you are doing though as the airbag system is not to be taken lightly.

Apr 04, 2010 | 2001 Dodge Durango

1 Answer

Horn, cruise control, and radio controls on steering wheel do not work ?


The clockspring behind the steering wheel is possibly defective or unplugged. It is the one and only component that all of your symptoms have in common.

Apr 27, 2009 | 1999 Jeep Grand Cherokee

Not finding what you are looking for?

Open Questions:

0 Answers

98 Lincoln TC,Cold starts fine ,runs good until warm, then shuts off. No codes,Cranks ok, have spark, PATS ok. No fuel pressure, cant hear fuel pump prime,New Fuel relay. jumped fuel pump - works. I do not hear fuel pump prime up, do not have fuel gauge, but pressing on valve in fuel rail- no pressurized fuel. Fuel regulator seems ok, not leaking / vacuum line dry as a bone. If I let it set for 15 min , it will start up again, but for a few minutes then dies out. If I let it set overnight it starts up perfectly and runs until operating temp is reached then stalls/stumbles, and shuts down. Vacuum is good while cranking, even with no start, Checked Inertia switch in trunk, it is not tripped. I have seen Ford TSB summaries' that mention issues like this , but I am not able to see to description. A point to add, the MAF sensor was cleaned, then I decided to replace it and did not make a difference. I do not have any stored codes, and the PATS is working fine, typical 2 second flash from and once key is inserted a 3 second steady light, then disappears. I have seen the TSB mentioning C103 Connector, it looks fine, I swapped out fuel pump relay with ac relay, still no difference.mention of wires around battery, do not know where to start. in dash service engine light and odometer is normal, seen other posts the say they only have lines, but mine is ok. the start of all of this , I washed engine with regular garden hose, ( not using pressure washer).also in the mean time, rear window defroster stopped working as well, can not say for same reason, but a mention.My problem started after washing engine. this is one of four Panther platform vehicles I owned with exact 4.6l w code engine, which I rinced down before. The only sensor I can think of is Oil pressure , or a corroded wire

Feb 27, 2017 | 1998 Lincoln Town Car

See all 1998 Lincoln Town Car Questions

1998 Lincoln Town Car Logo

182 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lincoln Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

fordexpert

Level 3 Expert

5495 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Lincoln Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...