Question about 2000 Ford Expedition

1 Answer

I was driving my ford when it slowly lost power to the radio and windows. Shortly thereafter the needles on the dash all dropped then the car just stopped running. when we jumped it the car started but it wouldnt hold power. what could be the problem

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

It sounds as if your alternator is going bad

Posted on Nov 19, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My wipers...lights..radio and horn went out but I can drive the car..what would cause this?


2008 Chrysler Town & Country Intermittent Electrical Failure ...

www.carcomplaints.com/Chrysler/Town_Country/.../intermittent_electric...
The 2008 Chrysler Town & Country has 25 complaints for intermittent ... The horn,lights, wind shield wipers front and back going crazy could not shut off. .... I was Driving down the road and my van went crazy possessed! ... Electrical checks reveal nothing wrong with the electrical system, and there is power to the radio.

2003 Dodge Caravan ES Electrical Problem - Discussion on Topix

www.topix.com > Dodge Grand Caravan
Aug 7, 2011 - my van was running fine, shut it off, went in for half an hour then it would not ... or the electric doors. windows do and brake lights. heater stays on hot and i can only ... My horn wipers,power windows, radio,blower front and back, headlights, do not work. ... Chrysler Readies Next-Generation Town & Country.Missing: 2004

Thread: I lost almost all of my dash lights, instruments, and ...

forum.chryslerminivan.net/.../7261-I-lost-almost-all-of-my-dash-lights-i...

Jan 17, 2008 - 10 posts - ‎6 authors
I have a 2003 Town and Country mini-van and I lost power to all my ... In addition to this my wipers, headlight controls, blinker controls, power door locks, and A/C/heat controls are out as well. The odd thing is that the power windows work, the power sideview mirrors work, the radio and ceiling lights also work.

Dec 16, 2015 | 2004 Chrysler Town and Country

2 Answers

Car radio short circuit


IMO TWO DIFFERENT ISSUES
WITH FUSE OUT OF RADIO, IT SHOULD NOT BE THE PROBLEM

Dec 27, 2013 | Ford Focus Cars & Trucks

1 Answer

2000 Ford Focus lost electicity while driving. Belt is good.


You may want to have your charging system diagnosed. It is possible that your alternator quit working. And this particular alternator could be a bit challenging if you've never done it or have the know how. Good luck!

Mar 15, 2012 | 2000 Ford Focus

1 Answer

I lost my manual guide for 2002 ford explorer. Witch fuse belongs to the power windows?


It is fuse #17 in the fuse block under the driver side dash. That fuse controls the dome light, radio, and power windows in the 2002 Explorer. Nowhere n the manual does it tell you that the power windows are on that fuse. I am going from recent personal experience. It is a 15A mini fuse (blade type). Good luck!

Oct 12, 2011 | 2002 Ford Explorer

1 Answer

1999 town and country van, battery indicator light came on, stayed on, then power was lost to the van slowly- first the radio, then then abs light went on then the windows didn't work finally full display...


double check the battery terminal or wire connector if loose,go to nearest autozone to check the load test on the alternator,your alternator might loosing it already.

Jan 25, 2011 | 1999 Chrysler Town & Country

2 Answers

Battery won't hold charge


My 2002 Ford2.gif Escape had a similar issue later in 2006. My alternator died and I needed replacement. After replacing, the light would come on and off at times. When everything running (i.e. radio2.gif, air conditioner, driving lights) and tocuh electric windows up the power would lower and sometimes battery light on dashboard would come up. Original mechanic could find out what was going on and I lived for 2-3 years with it.

This past August 2009 after a long trip (i.e. 8 hours or so) my battery died. Brought to a auto parts place and they determined it was the baterry and the alternator. Since I was back on my home town I went to a good friend that is a mechanic and he fixed it for real.

He had a similar issue with three different Escapes coming back with alternator or baterry or both death. He found out that Ford has an official report for Escapes that when this happens the electric fan behind the radiator are short circuiting, affect direclty the baterry and alternator killing them, and needs replacement.

Try this and may work for you.

Aug 21, 2009 | 2002 Ford Escape

2 Answers

2002 ford focus 1.4l ,73000mls,speedometer problem.


it is the vss (vehicle speed sensor). i had the same problem, cost £35 for sensor and clip. its behind the gearbox. very awkward job but can be done yourself. the hardest part is getting the pin out, you need a very good pair of molegrips and a lot of patience.

Jul 07, 2009 | 2000 Ford Focus

1 Answer

1997 pontiac grand prix gtp superchareged...freaked out


do you have any thing extra hooked up to your battery because i have a 96 and my amp kills the car when im sitting still abs light cuts on then i lose power for a few seconds

Feb 05, 2009 | 1997 Pontiac Grand Prix

2 Answers

99 Oldsmobile Alero - Speedometer Problem - needle is stuck at 140mph


I replaced the radio with an aftermarket one and now my dash lights, power windows and my headllights have dont come on automataclly like they did before. my alarm on my remote dont work either, I think i did something to the alarm system, that is why they are not working.

Aug 18, 2008 | 1999 Oldsmobile Alero

Not finding what you are looking for?
2000 Ford Expedition Logo

Related Topics:

78 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5501 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...