Question about 2003 Mitsubishi Eclipse Spyder

1 Answer

My 03 eclipse rs was running fine. Decided to put in a new aftermarket ram air intake. still fine. bout 20,000 miles later. (latest milage 99000) its having a engine sputter issue in first gear. then in its second gear a few months after noticing it in the first. ive changed all four plugs and cleaned my air filter. losing power and still sputters.during low accelleration car feels weak and sputters. Tried more than once fuel injector cleaners by Lucas. nothing. About to change timing Belt and check head gasket. PLEASE any help? need power and accelleration back. College Student low on cash.

Posted by on

  • trey_leal Nov 18, 2009

    Does that cost anything to check the pressure?

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 202 Answers

Have the fuel pressure checked

Posted on Nov 18, 2009

  • jz auto Nov 19, 2009

    some places may charge you but it should be less than the cost of buying a gauge at sears for 40 somthing

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

My 03 Envoy 4.2l reads ph 300 just put a newer throttle body on it got rid of 2 codes ,runs rough I dont have iridium plugs in it


You need to get rid of that aftermarket air intake . And put the mass air flow sensor back on .

Dec 19, 2016 | 2003 GMC Envoy

1 Answer

I have a 06 Hyundai 3.3 thats throwing a PO133 O2 sensor code-we put a brand new GOOD Oem sensor in bank 1 sensor 1, disconnected the battery and bout 3 starts later on with the check engine light so we...


Are you absolutely sure that you replaced the correct side sensor. It has two front (upstream) oxygen sensors. Aftermarket intake or exhaust components can cause this code. Poor connection at O2 wires possible. Could be wrong part number sensor.

Apr 20, 2014 | Hyundai Sonata Cars & Trucks

1 Answer

Car starts up but dies immediately.


Use a bottle of yellow HEET dry gas to remove any moisture problem in the fuel.

Clean / replace air filter.

If there is check engine light on then please pull code.

Jan 18, 2014 | 1998 Mitsubishi Eclipse

2 Answers

I have a 96 eclipse.that was overfilled w/oil new sparkplugs and wires,air filter,and oil changed.now it runs fine for about a mile then it acts like it is running out of gas and dies.wait bout 5min...


check your distributor cap to make sure no oil got in there also check your fuel pressure regulator to see if its a normal pressure any shop can tell you what it should be so just call and ask the fuel pressure tester is about 45 dollars at autozone

Jan 25, 2010 | 1996 Mitsubishi Eclipse

1 Answer

Idles high on 1997 mitsubishi eclipse rs 5 speed


This is definitely a bad Idle Air Control motor. It is right below the throttle position sensor, and will cause the idle to run high if it sticks.

Aug 22, 2009 | 1995 Mitsubishi Eclipse

2 Answers

I have an 03 merc. sable. 58000 miles. drove 22 miles home from work parked and shut it off. went to leave 5 min later put in drive and it started to spit and shudder and then just died. 20 - 30 min later...


Start at Changing your sparkplugs wires (if you are performing this on your own replace one by one to prevent mix-up). If problem still persists, have coil pack checked or replaced. Hopefully this helps!!

Aug 12, 2009 | 2003 Mercury Sable

2 Answers

Check engine light on a 2002 Acura RSX


Just hit the reset button, i have a 03 Civic Si same motor as base RSX mine came on everytime when i kept disconnecting the plug, never came back on. (i have a short ram intake)

Jan 30, 2009 | 2003 Acura RSX

2 Answers

Mazda 6 cold air problem


did you have a air flow sensor on the factory air intake you removed?
if so you will need this part connected to your ram pod outher wise the car wont run properly

Jan 02, 2009 | 2008 Mazda MAZDA6

1 Answer

2008 Dodge Ram 2500 Milage


have you checked the air filter? could have picked up some trash and clogged the air intake.

Oct 03, 2008 | 2008 Dodge Ram 2500

Not finding what you are looking for?
2003 Mitsubishi Eclipse Spyder Logo

332 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8516 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...