Question about 1999 Oldsmobile Alero

1 Answer

What is the cost to replace the plug and box for the rear window defroster for a 1999 alero

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Oldsmobile Master
  • 14,036 Answers

You need to be more specific.what plug and box.you need to give me more detail.cant help if you dont tell me.i dont know what i am working with.

Posted on Nov 22, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2002 alero. Need to know where to plug in the radio antenna.


THE OLDSMOBILE ALERO DONT HAVE A EXTERNAL ANTENNA MAST. THE OLDS ALERO HAVE WIRE GRID ANTENNA INCORPORATED INTO THE DEFOGGER GRID IN THE REAR WINDOW.THE GRID ANTENNA HAVE A REAR WINDOW ANTENNA MODULE MOUNTED BEHIND TOP OF THE REAR SEAT BACK. THE RADIO ANTENNA CABLE GOES TO ANTENNA MODULE LOCATED TOP OF THE REAR SEAT BACK.

Jan 02, 2011 | 1999 Oldsmobile Alero

1 Answer

I have a 2003 Alero, replaced relay switch and fuse under the bonet for the rear defrost, all wires hooked up...no lines broke.. rear defrost button lights up , but rear defrost dont work. Are there any...


There is a connector going to rear defrost on the rear window. Disconnect this and check for voltage with defrost on. If this is good, check resistance for the connection to window. This will tell you if the electrical is working or the element is bad for the window if there is a open reading on multimeter.

Dec 03, 2010 | 2003 Oldsmobile Alero

2 Answers

Rear defrost won't work in 2000 alero v6


Check the fuse first. Then check the resistance of the Defroster grid w/ohm meter. As long as you measure anything BUT infinate, its ok. If ok replace the timer/switch module in the dash panel.

Mar 06, 2010 | 2000 Oldsmobile Alero

1 Answer

Rear window defroster does not work the fuse and relay are new


YOUR SWITCH IS BAD OR THE GRID IN BACK WINDOW HAS A BROKEN PLACE IN IT.YOU CAN GO TO ANY AUTO PARTS STORES LIKE AUTO ZONE OR ADVANCE AUTO TO BUY THE REPAIR KIT.

Jan 19, 2010 | 1999 Oldsmobile Alero

2 Answers

When I turn on the rear defrost of a 1999 Olds Alero, the light comes on but the rear window does not defrost. What can/is causing this?


You should take a test light & check for continuity between the feel & ground at the window. If there is no power check the switch as it is probibably burnt out.

Dec 02, 2009 | 1999 Oldsmobile Alero

1 Answer

Rear window defroster does not work. the light on the button turns on, then a few minutes later turns off, but the window does not defrost. Checked the connectivity on the tabs on the rear window and...


inspect every line/grid in the glass as an open circuit can be there...continuity must be present in the connectors at the window. There are products available to repair open spot(s) in grids on glass...

Sep 27, 2009 | 2001 Oldsmobile Alero

1 Answer

Rear defrost on olds alero


Remove the interior panel next to the rear window on the passenger side. There should be a small black box (3"x3") bolted there. This box sends power to the rear defogger and carries the signals from teh integrated FM antenna. Often, the end of the plug fries and stops the defoggers from working while the radio has no problems.

The plug into the box is usually melted. It may look like it can be soldered and hardwired to work again, but more often than not the box is fried too. You can get them on the cheap from a JY or get them through GM.

Jul 13, 2009 | 1999 Oldsmobile Alero

Not finding what you are looking for?
1999 Oldsmobile Alero Logo

115 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...