Question about Saturn SL2

1 Answer

During driving and idel the car sputters runs very rough. It just started 2 weeks ago.The service engine soon light goes on every other two trips. We replaced plugs and plug wires. This didnt help.My husband is a mechanic. But we need to be pointed in the right direction.What should we check next? Could it be any of the O2 Sensors or a fuel problem?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,608 Answers

Have the codes read.The codes will help in diagnosing the problem.If you keep replacing parts it could get costly.When you get the codes make sure and check the wiring and connections of any sensor that the scanner comes up with.If you post back I can help you with this problem.Good luck.

Posted on Nov 18, 2009

Testimonial: "That was our next step. Thanks for your help. Keep up the good work."

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sputtering/ chugging while driving


Disconnecting the battery could reset codes and/or sensor readings in the engine computer.
Is the check engine light on, and have you checked the computer for trouble codes ? Is fuel pressure normal ?

Aug 27, 2015 | 2001 Chrysler PT Cruiser

1 Answer

What are codes P0133 & P1134, for a 2005 Buick Lacrosse 3.8L V6 with 94,000 miles.


i have replaced an O2 sensor and had similar failure after 1500 miles.
I removed it, chkd it, reinstalled it and it ran fine.
P0133 is related to slow response of O2 sensor. P1134 is mfg specific so google that for ur car.

Aug 11, 2014 | Cars & Trucks

1 Answer

Got a 1997 Chevy Suburban 5.7 liter 4 wheel drive and the check engine light is steadily on. I not too long ago changed the spark plugs and just changed the EGR VALVE. As I drive now it's running rough....


What you do when the engine light comes on is to stop the vehicle ---check the oil level and let it cool down then check the coolant level at the radiator. The engine light is the message to you that the CPU has found sensors /servos that have gone outside set parameters and your course of action then is to prove that the engine is safe then run the fault codes to find the recorded faults and fix them . use the code reader to reset the CPU to ensure that the faults are fixed.

Nov 11, 2013 | Cars & Trucks

1 Answer

1988 Pontiac Lemans Runs Rough


i can recommend to RUN scanner/computer for easy diagnostics and fix . God bless you
any components can be faulty32cbf899-f6e4-4700-9849-2f8e8911acec.jpgd28e17fa-ceac-4b84-b842-b66ec79f6c63.jpg

Jul 11, 2013 | Pontiac LeMans Cars & Trucks

1 Answer

1999 Denali rough idel and driving


You should have 2 02 sensors in your exhaust system. The second one trips the ligt if your emmissions are too high abd it monitors the condition and efficiency of the cat converter. The 02 sensor in front of the muffler monitors the fuel adjustment for too rich or too lean. Now, on a cold start there ias a "cold start valve tha enriches your fuel like a choke. It can be the culprit because the #2 02 sensor is doing its job. The cold start valve can be chk'd to see if it is working by observing it.. It is behind the Throttle body. It should be clicking. Good luck and I hope this helped. Oh, wwhen the engine warms up, and you have clear the exhaust of excess fuel the light should go out.

Nov 07, 2009 | 2000 GMC Yukon Denali

1 Answer

1996 Buick Roadmaster rough start sputters and


Check the mass air flow sensor (clean both heated wires with carb cleaner and Q-tip). Remember...cleaning does not always work...sometimes they are actually bad. Also check map sensor. Check for vacuum leaks at all hoses and fittings. If engine rpm drops sufficiently, engine vacuum will drop which may have caused a/c malfunction (controls work with vacuum signal) so I wouldn't worry about that 'till the run problem is dealt with.

Jul 30, 2009 | 1990 Buick LeSabre

3 Answers

Rough idel/no power


0475c6f.jpg As a former Audi technician, I can pretty much guarantee the coil packs are your problem.

Jan 25, 2009 | 2004 Audi A4

1 Answer

1996 Jeep Grand Cherokee stalls when brakes are applied


My 2000 Grand Cherokee had the same problem, without all the sputtering, it would just die approaching a stop. We could only keep it running by slightly pushing down on the gas petal when coming to a stop. I replaced the Throttle Position Sensor, but that didn't change anything. A new mechanic I found replaced the Idle Air Control Valve, and we've had no problems in a week.

Jan 02, 2009 | 1986 Jeep Cherokee

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

108 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saturn Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8572 Answers

Are you a Saturn Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...