Question about 1998 Chevrolet C1500

2 Answers

97 s-10 runs fine when it's cold but when hot it starts to back fire when i give gas

Posted by on

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 102 Answers

Could be anything, its one of those thigns that are hard to figure out sometimes. Could be a EGR valve not working properly, could be MAF or MAP sensor, failing O2 sensor(s) as well. or simply a vacume leak around the throttle body or at a vacume line.

start with the simple, look for broken or cracked vacume lines or obvious leaks.

What motor is in this s-10? 2.5 4 cyl? 2.8 V6?

im thinking if it was a fuel supply problem you would notice the issue at fast idle when cold as well.

also. how does it idle when it warms up?

Posted on Nov 18, 2009

Testimonial: "where is the camsenser on a 4.3"

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 819 Answers

Check for a fuel restriction, ie plugged filter

Posted on Nov 18, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I just put an engine in a 1972 VW bug just won't start firing order is fine top dead center is fine just turns but doesn't want to turn over


Hi Timothy:
Old Dude wisdom..........
- Fire at the plugs and
- Fuel in the jugs

If everything else is OK it should run. Not necessarily well, but it should run.

What to do?
1) Check for hot blue spark at the plug electrodes
2) Check for fuel in the carb.

If you have spark, give it a shot of gas into the carb, and give it a try. If it doesn't start, backfires, or catches fire, you'll need to double check the timing and plug lead firing order.

Not kidding! Don't set fire to it!.

Jul 13, 2015 | Cars & Trucks

1 Answer

Idle fine give gas brakes up pops new coil like out of time all mart are right crank h


can i buy a comma? says Vanna White, LOL !, i cant understand that.
brakes up pops? the cars foot service brakes, fail?

new coil, car has 10 or more coils which one, is a problem.
no year stated (fail)
no engine option stated (fail ) and country. fail 3.
Jeeps are sold all over earth, in 3 types. and postal an police, (5)
1984 ? 2001? i6? v6?
the only word i found , clear was pops

this is back fire, but to intake side or exhaust.?
intake side is bad spark timing.
exh side is gross over fueling and cracks in the exhaust pipe,
causing what is called, muffler explosions... loud report
the intake pops are back fires and is a not so loud , cough. sound.
or hickup
induction back fire is 90% bad ignition, and 10% causes by huge lean conditions.
Engine posts:
does it run bad, cold , hot engine or both?
does the engine run bad, even raced, in neutral , or cold.?
does the engine misfire at any time. say when?
does the engine bog, (lost power up hills or any time)? explain when.?

Jan 12, 2014 | Jeep Cherokee Cars & Trucks

1 Answer

Starts when cold


Sounds like a bad ignition system, if its firing poorly through your distributor once it warms up its not firing hot enough.

May 21, 2013 | 1992 Subaru Legacy

1 Answer

SC2 car cranks and starts sometimes.put new plugs and wires and noticed oil on the 3 and 4 plug. Car once started with some starting flluid runs fine. and will restart. weather is getting cooler 20 degrees...


A common problem with the 90's engines was the ECTS (electronic coolant temperature sensor) going bad. Seems when attempting to start the car, the computer in the car will only allow enough gas it thinks is needed to start. When a car is cold, the computer gives more gas initially, until the engine warms up, then gives less gas. When starting a warm engine, less gas is needed.

If the sensor goes bad, it always tells the computer that the engine is hot. The computer give less gas to a cold engine, and sometimes it will start, sometimes not. Its a pretty cheap part, and a do it yourself one, just research it a bit on line...good luck

Dec 23, 2010 | 1999 Saturn SC

1 Answer

My 95 Wrangler wont start when the engine is cold. it will crank but not start unless you give it gas. It starts fine when its hot (90 degrees) outside or i've already started and drove it that day, but in...


i was told that if the jeep all of a sudden didnt start on its own without giving it gas, then next time you start it hold the pedal all the way to the floor and it resets something in the computer and sets you back to normal.

Sep 04, 2010 | 1995 Jeep Wrangler

1 Answer

2001 Toyota highlander(4cyl),turns over,won't start afer few spins.Then,it will finally start.Has always started(fired)immediately- pumped gas a couple of times and it will finally start-runs fine-any...


Your cold start valve is not opening to assist the firing. It function is to provide extra fuel to ignite the all combustion chambers easily. When the engine doesn't have this extra fuel from the cold start valve, it will take a few times to get it going. The cold start valve is turned on at the time of starting only if the ECM get the signal from coolant temperature sensor saying it is at a preset level. When the sensor is bad, it can give a wrong value so ECM think that temperature is hot so not turning the Cold start valve. Replace this coolant sensor first, then the next thing is to check out the cold start valve.

Oct 29, 2009 | 2001 Toyota Highlander

1 Answer

96 Honda Passport hard starting


Air cleaner, fuel filter, plugs, bad gas

Sep 21, 2009 | 1996 Honda Passport

2 Answers

1990 Chevy Scottsdale 1500 wont idle when first starting cold


ICM idle control module, loc throttle body, it may be dirty, remove clean or replace, its easy..

Jul 29, 2009 | 1999 Chevrolet Silverado 1500

Not finding what you are looking for?
1998 Chevrolet C1500 Logo

104 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...