Question about 1997 Chevrolet Blazer

2 Answers

1997 blazer... Transmission problem maybe?

Ya I was going down the highway yesterday and had my cruise control on, and all of a sudden the engine started to ref and i lost speed. I stopped, and noticed a small leak coming from it, but it was a dirty water color and not thick. Whenever i go to accelerate, i have to give it an extra amount of gas to get it to accel as it seems to have problems. Also, their is a burning smell.. any ideas?

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,118 Answers

Best get it chk. out sounds like trans is!!!!!!!!!

Posted on Nov 17, 2009

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 118 Answers

Sounds like you blew a head gasket.

Posted on Nov 17, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

2007 Jeep Liberty traction control light starts flashing on highway and then can't use cruise control anybody know what it could be Ty


that is normal for cruise, ( its goes dead, when there are other dangerous conditions, or jeep gets lawsuit like TOY did)
did you scan it yet.
??????
that be first. (after checking fuses)
look for ABS failures. or Traction control)

or get car serviced?????? like oper guide stated, for this error?

Jul 25, 2015 | Jeep Cars & Trucks

1 Answer

What does the MIL code "PO 320" mean, please?


code p0320 refers to cam shaft position (CKP) sensor/engine speed (RPM) sensor--circuit malfunction=== causes --wiring--CKP/RPM sensor ---ECM
because the engine runs ok until it is on cruise control I would be investigating the RPM sensor for a fault
The cruise control takes its control from the RPM sensor and if that circuit is interminable the the cruise control doesn't know what rpms to maintain.

Jan 29, 2015 | Cars & Trucks

1 Answer

Cruise goes off when left or right signal is used.


you may need to change your signal/cruise control device. You may try an auto recycling center.
Remove the positive wire from the battery
remove screws at the back of the airbags. Don't worry, you disable them when you remove power,
With a socket 1/2in drive and maybe an 18 or 20 remove steering wheel
Once the wheel is remove you should see your signal/cruise device.
You could go to your local auto store and buy a book or online www.hayes.com and it will help with the procedure

Jul 31, 2010 | 2004 Toyota Sequoia

1 Answer

Speedometer, Odometer, Trip Odometer stopped working


yes the transmission speed sensor has most likely failed, to confirm this have a trouble code test run

Jul 05, 2009 | 1996 Nissan Pathfinder

1 Answer

Transmission


sounds like maybe your gas pedal might be sticking

May 25, 2009 | 1996 Chevrolet Blazer

1 Answer

1997 Blazer 4wd auto transmission


IT IS POSSIBLE THE FILTER CAME OFF and allowing it to **** air

Oct 06, 2008 | 1997 Chevrolet Blazer

2 Answers

Transmission problem


car out of cruise control flutters or runs rough from 45 mph to 55 mph and once over 55 mph runs smooth. I notice from 45 to 55 the rpm guage moves with flutter or rough running engine. when i put in cruise control it smooths out.

Sep 12, 2008 | 2000 Chevrolet Blazer

Not finding what you are looking for?
1997 Chevrolet Blazer Logo

83 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...