Question about 2002 Chevrolet Avalanche

1 Answer

Perfectly running 2002 Avalahche 110k miles 5.3 4wd with engine at 3000RPM on highway misses as if about to kill then works fine for 20 miles or so.... recently changed oil and air filter. Could it be Bad gas?, bad fuel filter? This started happenning after battery went dead from car being stored without running for 4 months and putting a new battery. Could it also be injectors being gummed up from lack of use?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 708 Answers

I would replace the fuel filter and if you are using the gas from 4 months ago then you should put some stabilizer in the tank. Also, inspect the plugs, if they are black then replace them. If you are using new gas then put some lucas fuel treatment in, that will help if the injectors are dirty. If they are clogged then you will have to take it in to have them cleaned.

Posted on Nov 16, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my truck run fine at Highway speed and rattle real bad when I come to a stop


Sounds like you have a misfire in the engine. Do you have a check engine light on?

May 22, 2016 | Cars & Trucks

1 Answer

What is causing my Trooper to hesitate when I accelerate to 20 miles per hour.


Have an electronic evaluation carried out, it's quicker and in the long run safes you frustration and cash.

Oct 10, 2014 | 2001 Isuzu Trooper

1 Answer

I have a 2002 Lincoln LS that up to 3000 rpm seems to run fine. at 3000, it starts to shudder and miss. any ideas/


If one of the engine components is acting up, you should get a check engine light and have codes for the components. If the light is not coming on, it could be a suspension or mechanical problem.
Low fuel pressure could also do it.

Jan 23, 2014 | 2002 Lincoln LS

3 Answers

2002 Sable sedan choke/missing/sputtering intermittent


The PO 316 is still misfires om first 1000 revolutions
so the shop did a poor job for you on resolveing the
cylinder misfires

Try a diffferent shop

Have to clean the MAF Sensor & replace upstream
oxygen sensors if over 100,000 miles

Need the correct oem spark spark plugs/any brand

No reason the gas filter should be clogged unless it was in
the car for 10 years

Fuel pressure should be checked

Need to check for cylinder misfires on a road test of 20
miles or more with professional software in Mode#06

Jan 17, 2013 | 2002 Mercury Sable

1 Answer

Lincoln 2002 ls overheating


the fan will turn on when the engine temp reaches a set temperature and will only turn off when the engine drops below a certain temp and on the highway running hard it may stay on longer

Oct 01, 2012 | 2002 Lincoln LS

1 Answer

My 2002 envoy has a miss that just started==was driving on the freeway for about 40 miles @70 pulled n a station to get a drink ==started it back up and it started missing like a dead plug or coil i...


2002 Envoy sle 4.2 L straight 6. Random misfire(PO300). After erasing codes for several days, I finally took my car on the highway and ran it at high speed(70+) for about 4 to 5 miles. Check engine light came on as before but this time it gave me(PO305). Random misfire cylinder 5. So I switched coil 5 with coil 2. Went back out on the highway and repeated as before. This time it gave me(PO302). This was telling me I had a bad coil. Replacing one coil pack solved the problem. The professionals told me low fuel pressure would not give me random misfire, but rather a O2 code because the engine is running lean. Thank you------------------------------------ thank you very much.

Jun 26, 2012 | 2002 GMC Envoy

1 Answer

I have a 2002 Trailblazer with 120k miles. I have driven this truck for the last 30k miles with no problems. This afternoon while driving home from work it started misssing and the "Service Engine...


You need to get the fault code scanned to be able to get an idea of where the problem is. It's possible you have a coil pack that goes bad when it heats up.

Aug 02, 2011 | 2002 Chevrolet TrailBlazer

1 Answer

Engine Floods after brief start and run when cold -then shut off


Local mechanic determined engine was flooded and started it by holding throttle to the floor and cranking 5-7 seconds - then the engine sputtered to life. It has run perfectly before and since and I'm at a bit of loss to understand why this occurred this one time - so far. It's been driven now 5 days with no problems.

Nov 19, 2008 | 1996 Honda Odyssey

Not finding what you are looking for?
2002 Chevrolet Avalanche Logo

120 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...