Question about 2002 Chevrolet Astro

3 Answers

I have a 2000 chevy astro and it runs but porly every time i step on the brake it wants to stall if i press on the breake hard it stalls and i have an awful vibration when mantaining a sdeedy speed and all so get static throuh the radio that just so happens to go insync with the engine any ideas

Posted by on

  • 1 more comment 
  • emeryjosh200 Nov 16, 2009

    yes the noise gets louder withh the engin gaining rpm as for the vibraision it goes away when i let off the gas and then comes back when applied again but only when maintaning a sdeedy speed when idling it wants to stall and then will catch up to its self on take offs it dose not want to move then in second gear it dose just fine but i know its not the tranz

  • emeryjosh200 Nov 16, 2009

    the temp runs fine i do have a pin hole leake in the radiator i have not had it over heat yet

  • emeryjosh200 Nov 16, 2009

    i also have a 95 gmc safari and get very little heat even when the temp is upto full runnig temp it just blows out cold air i have no idea new heater core

×

3 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 120 Answers

I would check the spark plugs and distributor cap and rotor if equipped. If not, then check the spark plugs, and if worn, replace all six and fuel filter...and any other tune up parts....the stalling with the brakes applied could the be the hose running from the power brake booster to the intake manifold. If that hose is plugged, it too will cause the rough running and stalling...however your van may have a hydra boost and that hose will not exist...in that case, spark plugs might be so worn out that its in such dire need of a tune up, the engine cannot keep up and stalls out everytime you hit the brakes.....okay? good luck

Posted on Nov 16, 2009

Testimonial: "this was very helpful i had no idea were to start"

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 881 Answers

Well with out driving it my self and finding the fault ,i have to go by the infomation you give me but its rather poor but will try..
Is the car missing when under power at low and high speed..What does the temp gauge read when driving.
What RPMs are there on idle (700rpm)max.
The vibration is it there all the time when running and in all gears/and does it sound like in the front or at the top of engine ,and is the vibration there when you take you foot off the throttle and does the car pull either way when power on and then off, but the noise in the radio does it get louder when you go faster as it sounds like either the radio aerial is picking up the spark to the plugs {bad earth on areial} or the spark is comming from the Alternator.
So let me know to all the above ASAP. RON

Posted on Nov 16, 2009

  • Ronaldbrains Nov 16, 2009

    OK then on the information you gave me the main problem is in the automatic gearbox and the 1 gear being selected dosent hold to drive, so you take off in 2nd ,also when braking the forward band isent braking at 500 rpm which brings the box down to neutrel alowing you to stop without stalling the engine ,and when this happens its like braking in a manule box without pushing in the clutch ,SO drive it and then when on a empty road at about 20MPH drop in to Nutral and then brake,, do this 3 or 4 times and if it does not stall then its the box,if it does then its a good tune up wanted (but i dont think so).

    The viberation sounds like you have either got a rattle in the converter or muffler cause loose baffle plates as they do the type of noise you have OR a bad viberation could be the Uni/joints in the Tail shaft throwing it out of balance..

    But you still dident say how much water you loose in a week and how much oil.

    Let me know. RON

  • Ronaldbrains Nov 16, 2009

    Ho yes your other car,s heater is mainley caused by either rusting up heater core or the hot and cold switch- over isent working because its lacking Vacuum and i would say if its a vacuum type is the hose which has split or come off and not turning over to hot,

    So take off the 2 heater hose,s and turn on to hot and try blowing down either one with about 10lbs of air with a compresser and it should remove the blockage and then use a water hose to flush it out, refit hoses tighten all clips and leave heater on hot every time you fill with water/coolant/or antifreeze, to get rid of all the air whilst warming up... RON

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Chevrolet Master
  • 11,147 Answers

Check brake booster possible vacuum leak and or bad diaphragm with vacuum leak will make vehicle run ruff and can cause vibration and stall as well as problem shifting

Posted on Nov 16, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Why do i have loss of brake pressure


Long shot: Bad master cylinder - Typically the brake pedal will slowly sink to the floor. On early 2000 vintage Chrysler products you need to check brake lines as they have been known to rust (and fail catastrophically)

Jul 04, 2014 | 2003 Jeep Wrangler

1 Answer

Stalls stop


IT sounds like a vacuum leak from the brake booster on brake application . Easy test run the car and if it idles ok then put your foot on the brakes and if it stalls it is the booster.

Mar 20, 2014 | 2000 Ford Focus

1 Answer

I have a chevy s10 2.2 2003 truck and one day it ran about five miles. then stalled. it started back up idled fine but put it in gear. stalled again. had to get towed home replaced the fuel filter,truck...


When you press on the gas when the truck is running, does it rev up?

Did it die while driving down the road (foot on the accelerator) or when idle? - If so, try cranking it and get your RPMs up to 1500-2000 RPMs and put it in drive (with your other foot on the brake). See if it will continue running if you never take your foot off the gas.

Apr 06, 2013 | Cars & Trucks

1 Answer

1999 chevy astro van studdered stalled and now will not start


I have had that exact issue on my 99 astro,but before it left me stranded on the side of the Highway it was running a little rougher than usual,but once accelerated it was fine,until it finally Stalled. So i Replaced the fuel filter and The Cap and Rotor and now it is Fine,started Right Up.

Jun 16, 2009 | Chevrolet Astro Cars & Trucks

1 Answer

1996 astro van stopped running


Sounds like dirty gas and the fuel filter is clogged...try changing the fuel filter...some are under the car, but most are mounted against the firewall in the engine compartment.

Apr 19, 2009 | 2005 Chevrolet Astro

1 Answer

2000 dodge caravan sport


you may have a vacuum leak, this will cause the engine to inhale excess air and when you put your foot on the brake, which is vacuum assisted, it stalls the engine.Check your vacuum lines at the cruise servo( behind the battery) , up to the throttle body, also, check vacuum at the EGR valve and at the front of the engine where the belts run, there is a line that crosses to the fender wall there. Hope this helps.
R

Oct 04, 2008 | 2000 Dodge Caravan

Not finding what you are looking for?
2002 Chevrolet Astro Logo

654 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7772 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...