Question about 1996 Mercury Sable

1 Answer

96 Mercury Sable, stero has no sound, display lights are on

Posted by on

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 10,865 Answers

Hello. Thanks for choosing Fixya! It is unclear from your question whether this is a newly installed stereo that has never worked properly or a stereo which did work properly and now it does not. Lets begin with the scenario where this is a newly installed stereo. In some cars, all the speakers are run off of a stock amp....in the wire harness adapter that you installed check to see is there is a amp remote wire that needs to be hooked up to 12+ volt source to turn the amp on.
If your situation is that the stereo used to have sound and now it doesn't, there are a couple of possible culprits. Lets begin by checking the fuses. look in your owner manual for the fuse diagram(s), and check the radio fuse. Sometimes a fuse looks to be ok when in reality it is not. Install a new fuse of the same amperage to see if this solves the problem. If it does not, the next thing to check is the wiring to the speakers. What you are looking for is a loose connection or a situation where a wire is disconnected all together. I hope this solves your problem. Thanks for choosing Fixya! Regards, Joe

Posted on Nov 16, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

96 mercury sable thelt is on how do i turn off


THEFT SECURITY LIGHT ON CANT TURN OFF UNTIL YOU FIX PROBLEM. YOU COULD HAVE PARTIAL KEY CODE RECEIVED MEANING KEY DAMAGED OR FAULTY, IMMOBILIZER READ COIL IN THE IGNITION SWITCH KEY LOCK CYLINDER,COULD HAVE FAULT IN THE ECM AND IMMOBILIZER CONTROL MODULE.

Oct 02, 2011 | 1996 Mercury Sable

1 Answer

I just got a brand new battery for my 96 mercury sable and the battery light is on and my radio wont work


usually if a battery light is on it is a sign that the alternator has went out, start it and take the negative battery cable off while its running, if it dies the alternator is bad.. as far as the radio, that has nothing to do with it, most likely a fuse blown.

Jun 28, 2011 | 1996 Mercury Sable

1 Answer

My 2001 mercury sable just cut off on me after i got my stero system put in now the theft light is on and my car wont start


Your car is probably not starting because it is in security mode. You will have to reset or reprogram the system. They usually give directions of this in the owner manual. If not, you might have to call a Ford dealership to get it.

Feb 09, 2011 | Mercury Sable Cars & Trucks

1 Answer

I have a 96 Mercury Sable and everytime it is started it beeps 5 times for 5 cycles. What is this for


if here is no airbag light on when you first turn on the key. then the beeping is coming from the airbag module. you will have to take cluster apart and replace airbag light bulb, that should stop the beeping.

Aug 29, 2009 | 1996 Mercury Sable

1 Answer

Car intermittently stutters


i have 96 merc sable nd its located under the back right seat and u cant reach it when u r in the car, u have to go under it

May 30, 2009 | 2003 Mercury Sable

1 Answer

Timming marks on an 96 mercury sable


no timing is needed to replace oil pump

May 13, 2009 | 1996 Mercury Sable

1 Answer

Tryin to find the O2 sensor on a 96 Sable


theres a sensor before the catallitic converter and one after. yes easy to get to and takes a 7/8ths wrench

May 05, 2009 | 1996 Mercury Sable

1 Answer

96 Mercery sable no head lights


Have you checked the fuses and the headlight relays? 

Apr 06, 2009 | 1996 Mercury Sable

Not finding what you are looking for?
1996 Mercury Sable Logo

Related Topics:

69 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

fordexpert

Level 3 Expert

5520 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...