Question about 1989 Ford F 150

2 Answers

Internal and external fuel pumps wont run when key on. Pumps run when jumped. Replaced pump relay and EEC power relay. What should I check next?

Posted by on

  • demuszart Nov 15, 2009

    Thanks for the helpful advice. I'll check the sending unit in the morning.
    demuszart

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,533 Answers

I would check the sending unit give these websites a try www.alldatadiy.com and www.autozone.com if all fails stop by your local library amd get your hands on a Haynes auto repair manual for your truck wish you the best of luck Michigan Man. also check for loose wires.

Posted on Nov 13, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Ford Master
  • 2,030 Answers

The ECM

Posted on Nov 13, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Injectors not pumping gas i can dump gas in the TBI and it will crank


check all fuses under left dash if that doesn't work check to c if you are getting power on the injector plugs if you are getting power then go to a junk yard and get a throttle body

May 31, 2013 | Cars & Trucks

1 Answer

I have 1986 Alfa Spider that won't start. Car has been sitting for a year. I replaced battery, fuel tank, fuel sender unit, both fuel pumps. I seems that the in tank pumps is not getting any po


Could be the main or fuel run relay located in the compartment under the luggage rack, passenger side, main relay also, fuse for the fuel relay 8amp. Electronic Control Unit is also located there.

Could be electrical, Hook up a timing light, three leads: Power, Ground, and one that goes around the wire to #1 cyl. Turn the engine over and see if there's firing. Note: u can check all 4 spark plugs this way.

Fuse lead goes to pin 30 of the fuel relay, u can jump 30 across to 57 and check for the pumps running, if not, change-I suggest both relays, main and fuel run relays. Both pumps get their 12v DC from the fuel run relay, both should be running when you switch ignition switch to on, then a tachymetric signal is fed from the coil to the relay to keep it running.

Jun 10, 2012 | 1986 Alfa Romeo Spider

2 Answers

1986 f-150 not getting gas


is the fuel pump switch inside the cab tripped or has burned connector?

Sep 02, 2009 | 1986 Ford F150 SuperCab

4 Answers

Two fuel pumps???


The 88 Cabrio has 2 fuel pumps and 2 fuel filters as well. One filter next to the main fuel pump and another under the hood next to the air filter. The transfer pump in the tank is easily acsessed under the back seat by an access panel with 3 screws. The Transfer pump has a screen which is notoriously clogged. The Main pump is on the frame on the passenger side mounted in a rubber casing. Both pumps can be tested by wiring the terminals straight to a battery. Check your relay and fuse first. The fuse is the 5th from the left and the relay is the 2nd from the left in the first row.

Jul 25, 2009 | 1988 Volkswagen Cabriolet

1 Answer

Wont start. Radio says safe mode.


Hi Jeff I have the same problem. No current to pumps. will post solution should I find one. Nick

Apr 19, 2009 | 1993 Volkswagen Fox

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

147 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

fordexpert

Level 3 Expert

5546 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...