Question about 2003 Oldsmobile Alero

2 Answers

Rear defrost isn't working, replaced the relay and the fuse. The light comes on when you press the button but the defrost still doesn't work

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 4,088 Answers

Check for power at the rear heating element with a voltmeter--look for a bad connection between the exterior wire to the printed element on the glass. A repair can be made by using a silver-based conductive paint to bridge the defective connection (which is available from your local auto parts supplier). If no power is measured at the wires, check the local grounding connection for one of the wires.

Posted on Nov 13, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Oldsmobile Master
  • 12,173 Answers

Check for power at rear wires if good look at defroster grid if any breaks auto stores sell a repair kit sometimes the grid breaks or cracks from cleaning window

Posted on Nov 12, 2009

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: where is relay and fuse for rear window defrost

Where is relay and fuse for rear window defrost

Posted on Nov 30, 2009

  • 12 Answers

SOURCE: I have a 2003 Alero,

There is a connector going to rear defrost on the rear window. Disconnect this and check for voltage with defrost on. If this is good, check resistance for the connection to window. This will tell you if the electrical is working or the element is bad for the window if there is a open reading on multimeter.

Posted on Dec 03, 2010

jcameo7270
  • 675 Answers

SOURCE: My rear defroster stopped working.

Check to see that the wires that connect to the rear window are indeed intact...then you will need to look at the lines in the window to be sure none of then are broken...to go further, you will need a voltmeter...hook up the voltmeter across the two leads that connect to the window and turn on the system to see if it delivers 12 volts to the window...if so then the connections are either bad or the wires inside the glass are open

Posted on Jan 21, 2011

  • 1 Answer

SOURCE: Rear defroster not working on 2002 Tahoe (double

try cleaning contacts near door hindges rough them up with some steel wool or emry cloth

Posted on Feb 05, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Rear defroster works intermittently. Please help.


Quanchi, just for the heck of it remove lower half or rear seat and se if there is a fuse/relay center there, GM did this on some of there cars. press the helpful button

Feb 08, 2016 | 2004 Chevrolet Chevrolet Impala SS...

1 Answer

Ok 2005 chevy malibu. Fan hits on all speed rear defrost works. temp control does nothing no heat no ac. Blower blows from dash vents only no defrost no foot no blend on vents no nothing. Compressor does...


replace the switch its self.. you can search ebay motors under electrical and find one easily.. also they remove easily and just plug in the back..

Apr 05, 2014 | 2005 Chevrolet Malibu

1 Answer

Malibu heating and ac


does the car have automatic climate control?

Apr 05, 2014 | 2005 Chevrolet Malibu

2 Answers

Rear defroster not working


there is a relay should hear it click when you press the button and the ligh comes on. can be in the dash or in the fuse box or behind the fuse box

Oct 15, 2013 | 2005 Chevrolet Cobalt

2 Answers

Need wiring diagram of rear-window defogger circuit for 2008 Chevy Impala LT


i just fixed my car to the exact question above, it took 20 minutes total. yes I\'m good with a wrench, but this fix doesn\'t reqire you to be.

Problem: Rear defroster doesn\'t work, but the fuse is good and the little light comes on on the button.

Answer: Go to front passenger kick panel where the "other" fise box is and remove the pastic panel, it just pops straight up. Under the fuse block is a white plug that connects front wire harness to the rear harness. this is where the problem is. pull the connector off the body, my plugslide straight back. Now flip the whole connector over, there you\'ll see the burnt spot on the plug. losse, corroded connection causes melt down. this stuff happens. my car has a purple wire going into the plug and a black one coming out, this is the rear defroster wire. cut the purple wire aleast a half inch before the plug and cut the black one coming out of the plug the same, always leave a little wire incase you ever want to reuse that terminal, standard rule. now take two butt connectoers and a four inch piece of ten gauge and splice the purple and black wires back together. lots of current so DO NOT use 12-14 gauage wire, it will melt. and Wa-La, its fixed!! since you dont have to do the trouble shooting and chase down the wires like i did, should take you ten minutes to fix.

Now if this doesn\'t fix your car, then don\'t pay me!!

If this DOES fix your car, then take your wife out to dinner with the $150.00 i just saved you from having to take it to the dealer,

(they would sale you new connectors and harness)

Oct 30, 2012 | 2008 Chevrolet Impala LT

1 Answer

In my 1995 dodge neon my rear defrooster doesn't


did u try looking at the fuses maybe a blown fuse

Dec 07, 2011 | 1995 Dodge Neon

3 Answers

To whom it may Concern: My 2002 Toyota Corolla real brake lights and front high beam head lights have stopped working while all the light bulbs are still good. In fact they have not power going to...


In the passenger compartment: The Fuse no.# 18 (15A) = rear brake lights

tdisline_620.jpg

If the fuse no.# 18 - F18 (15A) is good, check and replace if necessary the brake pedal switch!

Jun 03, 2011 | 2002 Toyota Corolla

1 Answer

I have a 2003 Alero, replaced relay switch and fuse under the bonet for the rear defrost, all wires hooked up...no lines broke.. rear defrost button lights up , but rear defrost dont work. Are there any...


There is a connector going to rear defrost on the rear window. Disconnect this and check for voltage with defrost on. If this is good, check resistance for the connection to window. This will tell you if the electrical is working or the element is bad for the window if there is a open reading on multimeter.

Dec 03, 2010 | 2003 Oldsmobile Alero

2 Answers

Where is relay and fuse for rear window defrost


Where is relay and fuse for rear window defrost

Nov 29, 2009 | 2000 Chevrolet Impala

2 Answers

Turn signal


The wire under the hazard button has probably come loose. Most GMC vehicles this year range were made with a closed circuit wiring between the flashers, hazard lights, and rear defrost. Over time the wiring under the hazard button has been known to loosen. This causes the whole system to lose function. If pop out the hazard button on you center console you should be able to tighten that wire back on and the system should work again.
The same thing happened to me when I put in a new radio. I bumped the wires off and my blinkers, rear defrost, and hazard lights went out. I replaced the fuses and the flasher relay but nothing. Then I asked a mechanic and he told me what I just told you.
Hope it helps!

Nov 04, 2008 | 1997 Geo Prizm

Not finding what you are looking for?
2003 Oldsmobile Alero Logo

555 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...