Question about 1995 BMW 5 Series

1 Answer

I have a Europe-spec BMW 520. After not driving it for several months, I drove it for a few days and noticed it runs for no more than 10 minutes before it starts overheating. Replaced fluids to no avail. What's my next step?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,627 Answers

Replace the thermostat first,it is located in the housing that the top rad hose goes to,sounds like it's not opening when it's up to temp.

Posted on Nov 12, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a 99 Frontier 3.3. Started running real rough, bucking and jerking. Didn't idle. Hard to start when warm.


I have seen a few crank sensors do this. When I pulled them, they had a small crack in them. Don't know where yours is. But guessing under the harmonic balancer.

Dec 02, 2015 | Cars & Trucks

1 Answer

Po305 error code


With that many miles, I would expect to find the injector as the issue. But it could also be a sticking valve. Or a valve that has problems opening as the oil gets hot. You may want to do a compression test hot and cold too.

Jul 12, 2013 | 1994 Toyota Camry

1 Answer

Car overheating while driving but not in idle


Head gasket, if you are lucky it might not need a new head.

Mar 19, 2017 | 1994 BMW 3 Series

2 Answers

MY 02 KIA SEDONA STARTS UP AND RUNS FINE FOR 20 MINUTES THEN SHUTS OFF THEN AFTER ABOUT 10 MINUTES STARTS BACK UP THEN SHUTS BACK DOWN AFTER DRIVING FOR LITTLE WHILE AND KEEPS REPEATING THE SAME.WHAT...


Sounds like the same problem I have been having with my 2002
Sedona for the past 6 or 8 months. It would run OK for several days,
weeks, or months, then just quit. If I let it set for 10 to 20 minutes, it
would restart and run fine for at least the rest of that day. About 2
weeks ago, I was fortunate that it happened when someone was
with me, so I was able to determine that it was not getting any spark.
Since then the problem has gotten worse and more frequent - it was
happening almost every day and would take over 1/2 an hour before it
would start again. This morning was the last straw. I drove for about 4
miles and it quit. Took 1 hour and 10 minutes before it would restart.
Drove another 2 miles and did it again. This time it took 1 hour 35
minutes before restart. After 1 more mile, it quit again. Took 2 hours,
this time. Made it another mile and BAM! - did it again. My bro towed
me home. I determined that it is most likely NOT the crankshaft
position sensor, because 99% of the time they either work, or they
don't. Very rarely does it cause in intermittant problem. The most
likely suspect is the engine computer. That was always a likely
culpret when I worked on GM cars. Today I installed a $50 junk yard
engine control computer.
I am crossing my fingers!
I will know on Thursday, as I have a 50 mile trip to make.
I will post again on Thursday, to let you all know.

Feb 06, 2012 | 2002 Kia Sedona

2 Answers

2002 chevy suburban shutting off whil driving in extreme heat


I had the same problem with mine. I installed a fuel pressure gauge, and drove around until the problem started. The truck should be running between 48 to 56 lbs. of fuel pressure. Mine ran at idle at 42lbs. , not even high enough. Drove it for about 20 minutes, and it started to stumble. Fuel pressure dropped to 30lbs, 20 lbs - then all the way down to 2lbs. I shut it off, and it would not start back up. 30 seconds later, I turned the key and it came up to 10lbs. press. 10 more seconds 20lbs. After almost a minute, it came up to 42 lbs. started and I drove away. I replaced the fuel pump assemb. on 7/3/2008. Drove it around,and the problem is gone. Mine is a flex fuel, and the pump retails for $668.00. I did find a AC Delco pump for $221.00. I hope this helps.

Jun 29, 2009 | 2002 Chevrolet Suburban 2500

2 Answers

BMW E35 95, no heat coming thru vents


check the hoses going through the firewall to the heater assembly,they should be hot.there is a vacuum controlled assembly driven by the climate control assembly.check the vacuum and the cables

May 23, 2009 | 2001 BMW 5 Series

1 Answer

Coolant issue


broken fan belt water pump dont turn water dont circulate its gonna overheat alternator dont turn battery light stay on you said the bottle was full and when it cool down it was on low level that normal radiator took back what it was missing check the belt HOPE IT HELP FIXYA OUR POST THANKS PIERRE

Jul 11, 2008 | 2002 Mazda Protege

Not finding what you are looking for?
1995 BMW 5 Series Logo

Related Topics:

128 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Frankie B

Level 2 Expert

65 Answers

Fred Sops

Level 2 Expert

272 Answers

Doberman

Level 2 Expert

254 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...