Question about 1997 Chevrolet Cavalier

2 Answers

I have mazda 96 which the rear defrost is not working, I checked the fuse and the grid, they are ok. where can i find the relay and how can i disassemble the botton, by the way the LED is not on when I push the botton can you help me please

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 563 Answers

The heating-element's electrical contacts could be dirty as well.

Posted on Nov 15, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 460 Answers

Is it a possibility the heating element on the window has an open break somewhere? the only way to find out actually is to have it tested in the shop.. if there is a relay it is under the hood and in a main covered fuse box. possibly, so to say...

Posted on Nov 12, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Rear defogger on 1995 mazda mx3 not working checked fuse ok


You need to check the glass heater grid or continuity, turn it on and check across the grid with a 12 volts test light

Jan 25, 2017 | 1995 Mazda MX-3

3 Answers

How come on my 2005 pontiac aztek if i take out the rear defroster fuse (#21) the light still lights up on my dash and the relay still clicks?? Help why did this rear defroster stop working?!?


I found this. Your heated mirror also works off that relay. You can do ohms test on the grid, if the grid is open, no continuity. The auto store should sell a product to paint over the open spot to restore continuity, if you can find the open spot.
Not trying to cause trouble, just killing time. Have a good day.
come-2005-pontiac-aztek-out-rear-ed5fvbjuyfmssjamkecfw2ck-4-0.jpg

Oct 24, 2016 | Pontiac Cars & Trucks

1 Answer

Where is the Power Windows Fuse in a 2005 Ford Taurus?


It is located in the SJB smart junction box , it's a fuse / relay center / microprocessor ! Fuse # F2.10 30 amp . location -behind left side dash panel . Also check the accessory relay . Top relay left side , same location SJB .
Visual Inspection Chart Mechanical Electrical
  • Door window regulator and motor
  • Door glass top run
  • Door window glass
  • Loose, corroded connectors
  • Circuitry
  • Window control switch
  • Battery junction box (BJB) fuse(s):
    • 1 (60A)
    • 3 (60A)
    • 11 (50A)
  • Smart junction box (SJB) fuse(s):
    • 7 (20A)
    • 27 (10A)
    • 30 (10A)
  • SJB circuit breaker 10 (30A)
  • SJB rear window defrost relay 1
  • Relay center box 1 rear window defrost relay 2
  • Delayed accessory relay
  • Battery saver relay
  • Rear window defrost grid

Sep 23, 2015 | 2005 Ford Taurus

1 Answer

Rear window defrost not working Ford fusion2009


If only the rear window defrost does not work, check 30A FUSE 8 in the smart junction box. If the fuse is OK, the defrost grid may be in need of repair.

Oct 17, 2014 | Cars & Trucks

1 Answer

Rear window defrost not working


Check the fuse, then relay, closely look at the wires that connect the defrost grid and look to see if there are any tears in the defrost grid.

Oct 17, 2014 | Cars & Trucks

1 Answer

Defogger window wont work


front or rear.?
my guess, wild is, the rear electric defogger, is dead.
the test is so easy.
attach any voltmeter to the 2 grid terminal. and turn the defroster on.
12v there? yes, then the grid is open.
no> the relay that feeds it is bad. (or its controls or FUSE is blown)
check all fuse first.

Jan 11, 2014 | Acura TL Cars & Trucks

1 Answer

I have a 2005 impala. my rear defrost does not work. i dont seem to be getting power to the grid. the grid looks good, and the connections to it seem fine. i cant locate the defrost breaker or relay. all...


to check it take a multimeter and place it on each connection of the rear defrost to make sure you don't have a break somewhere in the defroster

Oct 25, 2013 | 2005 Chevrolet Impala

1 Answer

Hello 2006 Kia Rear defroster does ot work. I checked and changed the fuse but the fuse looked ok. Any help as to where to look for the problem would be appreciated. Thankyou, larry


It could be a bad rear defroster control switch or relay, it could be a loose or damaged connector somewhere in the defroster circuit, or it could be a damaged or defective defroster grid on your rear window. The easiest way to check to see if you have a circuit problem or a grid problem is to check for voltage at the connectors to the defroster grid at the rear window area. These connectors may even be located inside the trunk just below the rear window. If there is power there, then the circuits are OK and the rear window will most likely have to be replaced to fix it. If there is no power there, then the circuits must be traced to locate the cause of the failure...Most likely a burned-up switch and/or connector.

Jan 22, 2011 | Kia Sportage Cars & Trucks

2 Answers

REAR DEFROSTER NOT WORKING 2000 BUICK PARK AVE


Hello,

First I would look for a blown fuse, do you have an indicator lamp that turns on when you push it? Dose the light come on? If not a fuse or relay will most likely be the problem.

If the rear "grid" on the defroster only works in some areas then you have a broken link, the grid needs to be connected for it to work.

Check your fuses & or relays, check your grid for broken links, you can buy a repair kit for the grid at most auto part stores.

Hope this helps.

Dec 29, 2010 | 2000 Buick Park Avenue

2 Answers

Heated seat does not work on drivers side. Fuse checks ok


the grid in your seat has shorted out if the right one works The relay controls both seats so you diffently have a burnt grid

Feb 14, 2010 | 2003 Buick LeSabre

Not finding what you are looking for?
1997 Chevrolet Cavalier Logo

94 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6924 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...