Question about 2004 GMC Envoy

1 Answer

Rear windshield wiper and rear defroster dont work

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

My rear defogger won't work

Posted on Dec 25, 2009

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1861 Answers

SOURCE: 1998 Toyota Sienna Windshield Wipers not working

The fuse is the 20 amp WIPER fuse, located in the fusebox under the driver side of the dash, farthest on the left, 2nd one up from the bottom.

Posted on Jan 02, 2009

  • 840 Answers

SOURCE: Rear Windshield Wiper Problems

Check the wiper motor connection if its touching anything and loose it will automatically ground out and check at connection make sure you put some gel and then snap it in/ Please rate my response thank you very much

Posted on Jan 31, 2009

  • 205 Answers

SOURCE: Rear windshield washer motor works, but no fluid comes out

Rear washer may have it's own reservoir . Can you hear a pump humming when you activate the washer? Look in the under flooor compartment

Posted on Mar 22, 2009

  • 2 Answers

SOURCE: 2004 4Runner Rear Wiper and Defroster won't work

I just had the same problem. I have an '04 4Runner and my rear wiper, fluid wash, and defrost stopped working after it was recently serviced. If you had the battery cables disconnected recently here is the solution...Start the engine and lower the rear tailgate window all the way... close the rear window and then turn the engine off. Restart the engine and the wiper,wash, and defrost. should work again. It has something to do with the computer which needs to be rebooted. Good luck.

Posted on Jan 05, 2010

  • 335 Answers

SOURCE: trailBlazer remote lock, rear defroster, and rear

Hello and welcome. all these functions run off the liftgate module. the liftgate module is located in the rear hatch. also the replacement liftgate module has to be programmed with software for it to function correctly


  • Disconnect the electrical connectors (3) from the module as necessary.
  • Remove the bolts that retain the module to the liftgate.
  • Remove the module from the liftgate.
  • mrtechwrench_5.gif

    Posted on Nov 22, 2010

    Testimonial: "Wow, I have had it in the shop, and it took them $250.00 to come to the conclusion it was the lift gate module. With no repair."

    Add Your Answer

    Uploading: 0%

    my-video-file.mp4

    Complete. Click "Add" to insert your video. Add

    ×

    Loading...
    Loading...

    Related Questions:

    2 Answers

    Windshield wipers stop working when the defroster is on


    The only thing they have in common is the ignition switch.

    Dec 18, 2015 | 2007 Chrysler Sebring Sedan

    1 Answer

    Wiper blades were froze to the windshield and now wipers won't work.I can hear the motor running but I think the wiper linkage had been damaged


    you dont EVER run the wipers when frozen to the glass..the windshield needs thawed out first..you may have stripped the gears in the unit..replacement is required..always thaw the ice first..and not with the defrost as the extreme heat will crack the glass.. use the normal vents as a first heat source..this takes time so do it earlier..

    Dec 08, 2013 | 1997 Buick LeSabre

    1 Answer

    I have a 2002 chevy venture mini van. the rear defrost and rear windshield wiper doesnt work. possible reasons?


    rear defrost will not work with the following reasons one the fuse could be burnt, 2 the wire going to the rear defrost could be broken, 3 there is a break in one of the lines on the rear window, 4 where the connector is to the rear defrost it could have either broke at the window or the solder let go

    Feb 03, 2011 | Chevrolet Venture Cars & Trucks

    1 Answer

    Rear windshield wiper stopped working, 4x4 dosent


    sounds like a lot of fuse's blown or the fuse box it's self has a fault

    Dec 24, 2009 | 2004 GMC Envoy

    1 Answer

    Headlights, wipers, rear defrost


    sounds like a blown fuse. looke and the fuses under the drivers side dash by your left knee. there are also fuses under the hood.
    www.3si.org and www.stealth316.org are two very helpful sites for the 3000gt.

    Jun 11, 2009 | 1998 Mitsubishi 3000GT

    1 Answer

    Rear windshield wiper works...somtimes?


    I have a 2004 suburban that had wiper/defroster problems. I would check the connector between the hatch and the body. It is located at the top right corner. The plug is under the rubber boot where it enters the body. Mine had lost connection due to corrosion and needed to have a jumper wire placed around the connector for the power and ground wires. Give it a look and see if that is the problem.

    Feb 11, 2009 | 2002 Chevrolet Tahoe

    1 Answer

    Windshield wipers in front wont work but rear wipers work


    Hi! U need to check the switch and the wiring circuit that controls the motor.

    Jan 15, 2009 | 2003 Saturn VUE

    2 Answers

    Defroster


    FRONT DEFROSTER IS VACCUM OPERATED, ON PASSENGER SIDE REMOVE PANLE TO THE CENTER CONSOLE, YOU'LL SEE A CANISTES SHAPED IN TENNIS BALS IN SECUENCE, START THERE TO CHECK FOR VACCUM PROBLEM.
    REAR DEFROSTER/WIPER/WASHER ON HATCH.OPEN REAR HATCH ON DRIVER'S SIDE HINGE YOU'LL SEE A WIRING HARNES GOIN THROUGH USUALLY THAT HARNES BRAKES , LOOSING CONTACT TO ALL OF THE ELECTRICALS IN HATCH DOOR, EASY REPAIR. REMOVE HINGE GET SOMETHING TO HOLD HATC OPEN, LIKE LONG BROOM.PULL OUT HARNES AND REPAIR.GOOD LUCK

    Dec 14, 2008 | 1985 Volvo GL

    1 Answer

    Windshield defrost


    rear windshield deforst has twon connections that are black wires. you will find these under the panel on the trunk door.

    front windshield. the black stip the the wipers are on have the same black wires under it.

    check fuses under dash and hood . check relays the clean contact points under these panels.
    DO NOT BYPASS any power wires. the defrost has a low amp and voltage control.

    Nov 11, 2008 | 1998 Plymouth Voyager

    Not finding what you are looking for?
    2004 GMC Envoy Logo

    374 people viewed this question

    Ask a Question

    Usually answered in minutes!

    Top GMC Experts

    yadayada
    yadayada

    Level 3 Expert

    74896 Answers

    Freddy

    Level 3 Expert

    1311 Answers

    Colin Stickland
    Colin Stickland

    Level 3 Expert

    22095 Answers

    Are you a GMC Expert? Answer questions, earn points and help others

    Answer questions

    Manuals & User Guides

    Loading...