Question about 2000 Ford Excursion

1 Answer

I have a 2000 ford excursion and the front heat/ac does not work. No noise nothing. Rear control works just fine. Is this a blower motor issue? How hard are these things to fix? I am ok fixing things but not great. Is this something that I could do or should I take it in?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 424 Answers

Check power to the blower motor. It is located under the hood on the passenger side of the firewall. If you have power and ground it is the motor. If not you have a wiring concern.

Posted on Oct 08, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Is there a fuse for the airconditioner.. my front stopped working, but the back works fine


If the rear ac is blowing cold the the ac system is ok. Is the front inside fan not blowing and that is what you mean?

May 01, 2015 | 2000 Ford Excursion

1 Answer

Rear blower only clicks when selecting any speed


CHECK YOUR HEATER RELAY SWITCH AND YOUR FUSES

Feb 14, 2013 | 2002 Ford Windstar Cargo

1 Answer

Front blower motor doesn't work but works in rear


Change the. Blower motor resistor. $25 part near the blower. Chevy suvs are famous for bad blower resistors

Sep 10, 2012 | 2002 Chevrolet TrailBlazer

1 Answer

Front heater ac blower does not work but both rear ones do


Check the fuse first , then try tapping on the motor body
located above the passengers feet , if it runs , replace
the motor.

Aug 21, 2010 | 2001 Ford Excursion

2 Answers

I have a 2003 excursion with a 7.3 powerstroke. My entire climate control unit is dead. No Heat, no AC, no defrost... The AC was blowing cold yesterday too. Any ideas?


Did you find anything out on this question? I have the EXACT problem with excursion. Would love to find something out.

Oct 10, 2009 | 2003 Ford Excursion

1 Answer

Fan on High Only


The fan motors use a set of resistors to control fan speed. The lower speeds generate more heat in the resistors and these tend to burn out. While it is possible the switch could be the issue, I would start with the resistors. It is usually a module located somewhere near the blower motor.

Note: One of the reasons these go out, is that with time the bearings on the blower motor go bad and the motor takes more power to run. If the replaced resistors fixes the problem, but then fail too soon, look at replacing the blower motor as well.

Aug 29, 2009 | 2005 Ford Excursion

1 Answer

2000 Ford Expedition front air not blowing


TRY JUMPING THE BLOWER MOTOR APPLY 12 VOLTS TO THE MOTOR IF IT STARTS THEN THE PROBLEM WOULD BE THE SWITCH IF IT DOES NOT START THEN THE MOTOR IS THE PROBLEM GOOD LUCK HOPE THIS HELPS

Jun 25, 2009 | 2000 Ford Expedition

1 Answer

2000 Ford Excursion Rear Air Blower not Working...


Did you ever solve the problem? I have the same issue.
-josh-

Jun 21, 2009 | 2000 Ford Excursion

1 Answer

05 ford excurson front blower fan works on high only.


it's the resister in the blower motor case.

Resistor Removal
  1. Disconnect the electrical connector.
  1. Remove the screws and remove the A/C blower motor resistor.

4209c39.gif
Installation


  1. Follow the removal procedure in reverse order.

Apr 01, 2009 | 2005 Ford Excursion

2 Answers

Heater\AC no air in front 05 suburban


ase mechanic:

Sounds like a problem with the front blower motor. there is a blower motor resistor for the front blower motor that controls the speed of the blower and tends to go bad or fry out the blower motor. thats the most likely scenerio since you stated the control head was lighting up and responded to button changes.

Jan 29, 2009 | 2004 Chevrolet Suburban

Not finding what you are looking for?
2000 Ford Excursion Logo

347 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

fordexpert

Level 3 Expert

5537 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...