Question about BMW 545

1 Answer

I jumped my car after that the digital dash won't come on the analog tach doesn't work the analog fuel guage does not work

Posted by on

  • Engallr Dec 09, 2009

    Late but accurate. After another battery jump everything started working.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 560 Answers

The boost of voltage could have either disrupted the software or blown a fuse.

Check fuses, if ok disconnect then reconnect battery... if still no good let me know so we can dig deeper.

Best regards

Lloyd

Posted on Dec 09, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

MY 2001 VW CABRIO GUAGES ARE FLICKERING AND NOT WORKING PROPERLY FUEL,TEMP,SPEEDO,TACH WHAT CAN I DO


the case you have disconnect on the ground ( brawon coler) inthe claster . all guage have one ground check the braown coler wire but don't remove or disconnect the calster it may lose key prog try disconnect battarry then check from guage bording up to dash bord bracket . try make sure you have no short with any sender ( fuel .tem. or speedo)

Jul 27, 2011 | 2001 Volkswagen Cabrio

1 Answer

2001 chevy 1500 5.3l 4x4 fuel guage not working. changed sending unit no change. grounded gauge in dash went to full not guage. not getting power to sending unit fuses/ wiring good


You won't get power at the sending unit. The sending unit provides a variable ground to the dash unit. Where did you ground the dash unit? If you disconnect the sending unit at the tank and ground the fuel gauge circuit there the gauge should go to full. If if doesn't the problem is between that connector and the place you cheched it before. If it does the problem is with the sender. Occasionally new parts are found to be defective.

Apr 17, 2011 | 1999 Chevrolet Silverado 1500

2 Answers

2001 dodge grand caravan sport no dash lights speedometer tach gas guage 4 ways


  1. do the park lamps work?
  2. dash lamp fuse burnt?
  3. is the instrument cluster analog or digital?
  4. digital clusters have been known to fail however the cluster lighting is controlled by a body computer.
  5. proper diagnosis with require a scan tool that will access the body module ( computer)

Jul 05, 2010 | 1994 Honda Accord

1 Answer

All the guages on the dash quite working at the same time and even the fuel guage needle feel off, however, now they come on an go off as though they had a mind of there own, except for the fuel guage of...


plus, when im driving all of a sutton mylights goes dim and then everything just shut down and the car shuts off and wont start back up until jumped and the run a few miles and then cut right back off

Feb 17, 2010 | 1997 Plymouth Voyager

1 Answer

Dash guages quit working. Gas, temp, tach and


Try disconnecting battery for couple minutes and see if it starts working again I have done that in the past

Aug 05, 2009 | 2000 Chrysler Town & Country

1 Answer

1999 996 carrera speedo and tach does not work(analog and digital


maybe the speedo drive has stripped some teeth. good luck!

Jul 27, 2009 | Porsche 911 Cars & Trucks

1 Answer

Speedo,Tach and fuel guage not working


common problem with speed sensor failure

Dec 28, 2008 | 1999 Volkswagen Beetle

2 Answers

96 sunfire


fuses. please email me at meanness628@aim.com with any other info or questions

Jun 17, 2008 | 1996 Pontiac Sunfire

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

25 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Frankie B

Level 2 Expert

65 Answers

Fred Sops

Level 2 Expert

272 Answers

Doberman

Level 2 Expert

254 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...