Question about 1995 Nissan Quest

2 Answers

I have a 94 Quest with a fuel system problem.I have replaced the fuel pump & relay switch & I checked the filter & it still wont start.Can u help?

Posted by on

  • 2 more comments 
  • briangeorge2 Oct 07, 2009

    It will start when you spray started fluid in throttle body. It cranks fine. When I took fuel lines off of the fuel filter and cranked it, no fuel came out.

  • briangeorge2 Oct 08, 2009

    It will start if you spray Ether in it. It cranks fine. no gas coming from fuel line @ filter when turned car over.

  • briangeorge2 Oct 09, 2009

    cranks when starter fluid sprayed in. changed fuel pump still not working.

  • Greg Bernett
    Greg Bernett May 11, 2010

    Okay....describe from the start when you first put the key in and then when you turn the key. Do you have fuel flow/pressure? Do you have spark? Do you have a low amp draw while turning the motor over? (slow cranking)

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Nissan Master
  • 2,984 Answers

Okay...sounds like the fuel pump is bad.....

Posted on Oct 08, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Nissan Master
  • 75,822 Answers

HAS THE IGNITION SWITCH BEEN REPLACED? THE SWITCH ITSELF NOT THE KEY CYLINDER.

Posted on Oct 07, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Replaced fuel pump and relay. Still no fuel. Pump wont turn on. Can i bypass relays and wire directly to pump?


In theory, yes, but in practice not a good idea except to verify operation. Pump relays are usually controlled by the ECU and get power from the IGN switch. Double check your grounds at the pump.

Jan 03, 2016 | 1996 Nissan Quest

1 Answer

My 94 ford mustang gt just cuts off. ive changed my fuel pump & filter,please help


RESET THE FUEL PUMP INERTIA SWITCH INSIDE THE TRUNK ON LEFT SIDE YOU HAVE TO PEEL BACK CARPET TO SEE IT.IF ALL IS GOOD CHECK FUEL PUMP FUSE AND RELAY.

Jan 13, 2011 | Ford Mustang Cars & Trucks

2 Answers

1993 rodeo not running no power to fuel pump


if there is no power to the fuel pump check relays and fuses....UNDERHOOD FUSE & RELAY PANEL IDENTIFICATION Fig. 2: Underhood Fuse & Relay Panel Identification Courtesy of ISUZU MOTOR CO. Fusible Link Identification ? A - 80 Amp (1991-92 3.1L) ? A - 60 Amp Main-1 ? B - 30 Amp Main-2 ? C - 30 Amp (1993-94) ECM (3.2L) ? D - 30 Amp Condenser Fan (A/T Models) Relay Identification ? 1 - Headlight Relay ? 2 - A/C - Heater Relay ? 3 - Starter Relay ? 4 - A/C Compressor Relay ? 5 - Charge Relay ? 6 - Fuel Pump Relay ? 7 - ECM Relay ? 8 - Wiper Relay Fuse & Circuit Breaker Identification ? 1 - 15 Amp (1991) ECM, Fuel Injection System ? 1 - 15 Amp (1992-94 2.6L) ECM, Fuel Injection System ? 1 - 10 Amp (1992-94 3.1 & 3.2L) Heated Oxygen Sensor, Fuel Injection System ? 2 - 20 Amp (1991-92) Fuel Pump ? 2 - 20 Amp (1993-94 2.6L) Fuel Pump ? 2 - 15 Amp (1993-94 3.2L) Fuel Pump ? 3 - 10 Amp (1991) ? 3 - 15 Amp (1992-94) Turn Signal Lights, Hazard Warning Flasher Lights ? 4 - 10 Amp Horn, Door Locks ? 5 - Not Used (1991 3.1L) ? 5 - 10 Amp Charging System, Charge Warning Light WARNING: Always disconnect battery ground cable before servicing "high- current fuses. It is recommended that "high-current" fuses be replaced by a qualified technician. Page 1 of 2 FUSES & CIRCUIT BREAKERS -1994 Isuzu Rodeo LS? 6 - Not Used (1991) (1992-93 2.6L) ? 6 - 10 Amp (1992-94 3.1L & 3.2L) A/T Interlock System ? 6 - 10 Amp (1994 2.6L) Heated Oxygen Sensor, Fuel Injection System ? 7 - 20 Amp Heater/Air Conditioning Blower Controls ? 8 - 10 Amp Air Conditioner Compressor Controls ? 9 - 10 Amp Right Headlight ? 10 - 10 Amp Left Headlight © 2008 Mitchell Repair Information Co., LLC.
62217_isuzfuse_1.jpg
Underhood fuse block swap out relay #7 thats the ECM relay.
Ground Circuits Using a DVOM, touch negative voltmeter lead to a good ground. Touch positive voltmeter lead to each ground terminal. With vehicle running, voltmeter should indicate less than one volt. If reading is greater than one volt, check for open, corrosion and loose connection on ground lead. See ECM GROUND LOCATION table for ECM ground location.
Page 1 of 1 SYSTEM/COMPONENT TESTS - 2.6L EFI -1994 Isuzu Rodeo

Mar 28, 2010 | 1993 Isuzu Rodeo

2 Answers

No gas or spark


Try your inertia switch in the cargo area in back. Its located on the passenger side rear wheel well. Push the button.
2_27_2012_8_29_26_am.gif

Sep 23, 2009 | 1994 Ford Escort

2 Answers

Car statred to sputter and then died. Car will turn over but will not start. Could it be the fuel filter


Could be - however -

You need to determine if your not getting fuel - or no spark & take it from there..

Jul 12, 2009 | 1998 Ford Taurus

1 Answer

94 cutlass ciere wont start


check out fuel pump relay and oil sending unit for oil leak oil sender is made to cut out fuel pump apon oil pressure failing

Jun 30, 2009 | 1994 Oldsmobile Cutlass Ciera

1 Answer

Fuel pumps


Your problem may be in the connector where it plugs into the sending unit if the terminals are spread and not making good contact you will have voltage drop and cause the pump to overheat.

check with your car Quest dealer and see if they have a pig tail that you can solder onto your harness this will most likely solve your problem

Nov 07, 2008 | 1994 Cadillac Fleetwood

Not finding what you are looking for?
1995 Nissan Quest Logo

Related Topics:

298 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

723 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...